How often should 1password in Chrome ask for authorization?

It seems that the 1Password extension in Chrome requests authorization about once a week. Is this normal?

1Password Version: Not Provided
Extension Version:
OS Version: OS X 10.12.2
Sync Type: Not Provided
Referrer: forum-search:authorization


  • PilarPilar

    Team Member

    Hi @dougmon

    Thank you for taking some time to get in touch with us about this. The authentication code should not appear this often. Could you please try to notice what happens before the authorizations. Is it after restarting the computer, maybe? Do you use a cleaning app or tend to remove temporal files? If you can find a pattern of what triggers the authorization it would help us find out what might be causing it :chuffed:

    Could you also tell us if you have some other extensions that might be interfering with this one? If you ever use other browsers, have you noticed if you have some trouble there too?

    I hope to hear back from you so we can get to the bottom of this! :chuffed:

  • Hi, Pilar:

    You are correct, I do use a cleaning app: CleanMyMac. I looked through what it deletes and found that it is deleting the 1Password Mini Cache; however, I ran it just for a test and I didn't have to reauthorize the browser. So I don't know if that's the problem.

    One thing I did was to delete the extension and reinstall it. Perhaps that helped.

    Thanks for the reply,


  • Drew_AGDrew_AG 1Password Alumni

    Hi @dougmon,

    It's possible that CleanMyMac is the culprit here - if not due to deleting the 1Password mini cache, then it might be deleting something from Chrome that makes it forget you've already authorized the extension.

    On the other hand, it's also possible something else was going wrong. Hopefully deleting & reinstalling the extension took care of that! If it only happened about once per week, the problem might not happen again at first, so please keep an eye on it and let us know if you're asked to authorize the extension again. If you are, we'll take a further look into this. Thanks! :)

  • Thanks. I haven't had any issues since I uninstalled and reinstalled. If something happens, I'll try to remember the sequence of events leading up to it.

  • brentybrenty

    Team Member

    Great! We're here if you need us! :)

  • 1Password asked for another authorization this morning. I checked the version of Chrome, and it hadn't changed, so I don't know what's going on. Is there any data I can supply you that might help?

  • brentybrenty

    Team Member
    edited January 2017

    @dougmon: The logs are wiped out pretty quickly, so I'm not sure we'd be able to get anything out of it after time has passed. But certainly if it happens again note the date/time/zone an sending a diagnostics report to [email protected] with a link to this discussion and your username in the email so we can 'connect the dots'. Post the Support ID here and we'll take a look and see if there's some indication of what might be causing this. Cheers! :)

    ref: QSN-83788-112

  • Hi: I've run a couple of diagnostic reports that I've sent to support. They are:



    I hope these are of some help.

  • Sorry, I should've said: those are the support ids.

  • brentybrenty

    Team Member
    edited January 2017

    @dougmon: Haha no problem! They look pretty familiar to us. ;)

    Thanks so much for sending those! We'll take a look and get back to as soon as we have some news.

    ref: QSN-83788-112

  • One more, which I sent before I hit the "Authorize" button in the dialog. The other two were taken after authorizing. This is the second time I've had to authorize today.

    Support ID: FST-33417-647

    This is especially odd, because I have almost no other extensions and this is a clean build of Mac OS Sierra and a clean install of Chrome (well, as clean as it can be.) Good luck with this one.

  • brentybrenty

    Team Member

    @dougmon: Thank you for being so thorough! I'm not sure we could ask for more. I've merged all these and added some notes so we can try to break down what's happening here to find a cure for this malady. And...thanks for wishing us luck. Seriously, this has proven a rare and elusive issue to track. :blush:

    ref: QSN-83788-112

  • dougmondougmon
    edited January 2017

    One comment: you folks supplied me with a "verbose logging" version of 1password, and since I started using that, I have not seen this problem. Perhaps it's gone with newer versions than the Mac store supplies? If buying a license from you is what I need to get rid of this thing (under the assumption that I'll be able to get updates faster with the AgileBits version as opposed to the AppStore version), then I'll be happy to do that.

  • Hello @dougmon,

    It could end up being some odd issue with the Mac App Store version of 1Password but you won't need to buy a licence to use our AgileBits Store version and you won't get updates faster if you switch over as we do our best to keep the two locations in sync. When you downloaded the beta version of the AgileBits Store 1Password for Mac it automatically picked up on the fact that you had already purchased 1Password from the Mac App Store and that's why it hasn't been nagging you over an expired trial.

    It is puzzling. We've asked a few people to try the beta with the more verbose logging and nobody has gotten back to us. It is beginning to sound like an issue just with the Mac App Store version unless the beta contains some other fix that coincidentally helped. It seems we're still no closer to the cause for those that were suffering even if the beta seems to have helped.

  • Thanks, @littlebobbytables . You imply that others are having this problem; are they all using the Mac AppStore version?

    Honestly, unless this is a security issue, I no longer see it as that big an issue. Annoying, yes, but that's it.

  • Hi @dougmon,

    Thinking back I know the couple of instances I've come across where I've asked if they would be willing to run the beta I've had to include instructions on how to move from the Mac App Store to the AgileBits Store version to minimise disruption and to also say I would understand if they aren't willing. Now so far I never heard back if people did try or not and if the reason we've not heard is because the issue hasn't replicated itself with the beta but now I'm wondering if there is a pattern there. It's rare but on occasion a bug can present itself in only one of the versions if it turns out sandboxing is involved. It isn't something as simple as it affects all Mac App Store users though as the number of cases we're dealing with is very small compared to the number of people I believe use the extension with the Mac App Store version and I'm one of those people.

    There is certainly no security issue whether you use the Mac App Store or AgileBits Store version of 1Password. I am of course still curious as to why anybody is suffering this but it seems extra logging in just the beta version may not get us the answers we were hoping for.

  • Thanks for the clarification, @littlebobbytables. I do understand that these intermittent bugs are very hard to catch. I'll just keep using the beta until the new version is out. :)

  • brentybrenty

    Team Member

    Great! Thanks for your patience while we work to find a solution. :)

This discussion has been closed.