1Password extension not working on Windows 10

I'm stuck on the "The 1Password helper must be running for the extension to work properly" screen. With the same setup on Windows 8 I didn't have any trouble.

I've tried Chrome (55.0.2883.87) and Firefox (51.0.1). I've tried the steps in the support article. I do not have a firewall problem, and can access local web servers without issue. In 1password.agent.log.txt (in the diagnostic report), there are a series of entries like this whenever I try to connect a web browser:

13:35:38 [ WARN]            T1pAgent4: Denying connection from Invalid user token.
13:35:38 [ WARN]            T1pAgent4: Denying connection from
13:35:38 [ INFO]            T1pAgent4: Disconnecting from

I never got the authorisation prompt. Did I miss anything?

1Password Version:
Extension Version:
OS Version: Windows 10
Sync Type: Dropbox


  • I've been hitting the same error as well on Windows 10. Let me know if I can provide additional logs or version numbers.

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 2017

    Hi guys,

    Thanks for writing in.

    @mono / @rmardak, what anti-malware solutions are you guys using? Something's forcing 1Password to reject the connections from the browsers because it is invalid or running from another user instance that is not permitted.

    We have a list of anti-malware solutions here that is required to be configured in order to work with 1Password.

  • I've got Sophos Endpoint Protection, but I had it when I was on Windows 8 with no trouble.

  • GregGreg

    Team Member

    Hello there @Mono,

    Could you please try to configure Sophos using this guide and tell us if it helps? Thanks!

  • My organisation's IT department is not very flexible. I managed to get them to confirm that they haven't changed the configuration recently, and I didn't have any trouble with 1Password when I was on Windows 8 last month -- is that enough to rule out Sophos or do I need to push harder?

    Aside from that, I don't have any of the software on the list. I have no trouble at home with pretty much the same setup (on Windows 10 Pro instead of Enterprise and without Sophos).

    @rmardak, are you in the same situation?

  • GregGreg

    Team Member

    @Mono: Is it possible for your IT department to add an exclusion in Sophos and check if it helps? We can't rule it out yet, since you don't have Sophos on the PC, where 1Password works.



  • I don't fancy my chances with IT, but I figured out that if I just disable the Sophos Web Filter service (I have local admin) my problem is resolved. I'm not sure what caused the problem on my end -- IT said they haven't changed anything, but I didn't have trouble with Sophos when I was on Windows 8 and I do have trouble with it now. Perhaps the Windows 10 image here has a different Sophos version or something.

    Thanks for your help!

  • Sorry, I was travelling over the weekend and didn't have access to the PC with the issue. It looks like my issue is different. It appears for me that the agent process (v4.6.1.617) might not be compatible with my Chrome extension (v3.9.21.90). The agent process is listening on port 6263 and the troubleshooting info for the Chrome extension is referencing port 6258. Please see the attached image and let me know if I should open a new discussion or if you have any ideas worth mentioning here. Thanks!!

  • GregGreg

    Team Member

    @rmardak: Thank you for keeping us posted! It seems that you have an old version of 1Password extension. Please follow the steps in this guide to update it. Let us know how it goes. Thanks!

    @Mono: Yon can at least try to talk with your IT department. :) I mean, a simple rule in Sophos is better than disabling it completely. Stay safe online!


  • Wow, not sure how I ended up with an old extension (Chrome said I was up to date), but that fixed my issue. Thanks!

  • GregGreg

    Team Member

    @rmardak: You are very welcome! If there is anything else we can help you with, you now know where to find us. :)


This discussion has been closed.