1Password hangs Firefox when I revisit a site

I visit a web site (using 1Password to fill in the url). This web page uses a pop-up dialog box to ask for the login credentials which 1Password cannot fill. I have to fill in the credentials manually. When I leave the site, there is no logout button so I just leave. If I return to the site using 1Password to fill in the url, Firefox hangs. If I type in the url in the Firefox window, the page opens without asking for login credentials, (I assume it is cashed). If I close Firefox and reopen it, 1Password and Firefox work normally for one time. Then same problem recurs. Clearing history has no effect.

I would like to use 1Password to get me to this site. The site manager says that 1Password cannot handle the pop-up dialog box, but I am OK with that for now. I just don't want Firefox to hang when I try to get there a second time.


1Password Version: 4
Extension Version: .6.1.617
OS Version: Win10
Sync Type: Not Provided
Referrer: forum-search:1Password hangs Firefox when I revisit a site

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Nina_in_New_Mexico,

    Thanks for writing in.

    If you open the item with 1Password, it will encode the URL with the special parameter for the 1Password extension to pick up, so it knows what item to fill and remove the parameter before the site loads. That may be the cause of the hanging because the site uses the basic authentication dialog that loads before the site loads and you can see why it may conflict.

    Can you press and hold the Control key before you open the site in 1Password, it should bypass the parameter encoding process and stop the hanging.

    Let me know if it helps.

  • Sorry, that didn't work. When I used the CTL key as you suggested, I got a message saying "Password1 has been copied to the Windows Clipboard". Trying to place the URL in the browser address space with CTRL-V (Paste) brought up the password for the site.

    The real problem I am sure relates to the fact that the web page has no 'logout' button. So I have to leave the site by closing the window. I am pretty sure that this leaves a cookie in the browser that is telling 1Password that the site is already open. I have two work-arounds. 1) erase the history and then leave the browser. Re-opening the browser will allow 1Password to function normally again, but only once for this site; 2) go to history and click on the URL in the history list.

    I think the only real fix would be for the author of this site to figure out how to make a "logout" button.

    Thank you for your interest.

  • GregGreg

    Team Member

    Hello @Nina_in_New_Mexico,

    Thank you for keeping us posted!

    Could you please describe (step by step) how do you open a website in 1Password?

    The thing is that when I click on the URL in any of the items in my 1Password vault, it opens this URL and fills in the credentials. However, as Mike said above, when I hold Control and click on the URL, the website opens in my browser, but 1Password does not automatically fill the login and password. I wonder, if you do this differently?

    Also, do you mind to share the URL of the website you are experiencing those issues with? This way we will be able to test its behaviour ourselves. If you do, no worries, we will work around it. Thanks in advance!

    Looking forward to your reply!

    Cheers,
    Greg

  • Here is a step_by_step

    • Open Firefox - default page opens
    • Click on the 'lock' button to get to 1Password
    • Mouse to 'logins' menu
    • Mouse to 'Internet Services' menu
    • Mouse to 'FHH - user ares' menu
    • Depress control key, then L click on the menu item
    • Get this result - see screen shot

    Hope this helps.

    I am reluctant to give out the login and password for this site since it is a shared site for the family and contains some personal information. We all use the same credentials. Perhaps I could create a special set of credentials for you that I can erase after you have experienced the trouble I am having.

    Bob

  • GregGreg

    Team Member

    Hello @Nina_in_New_Mexico,

    Thank you for getting back to us with more details!

    It seems that you are accessing your 1Password data via 1Password extension in Firefox. Could you please try to do the following:

    1) Open 1Password 4 app on your PC (main app, not the extension).
    2) Find the item in question in your vault.
    3) Hold Ctrl button on your keyboard and then click on item's URL:

    As Mike noted above, it should bypass the parameter encoding process and stop the hanging. Let us know if it works.

    As for:

    I am reluctant to give out the login and password for this site since it is a shared site for the family and contains some personal information. We all use the same credentials. Perhaps I could create a special set of credentials for you that I can erase after you have experienced the trouble I am having.

    Please do not ever share the credentials from your websites with anyone. We asked for the website's URL ("Uniform Resource Locator"), not credentials. In other words, URL is a web-address, which is shown at the top of your browser. For example, the URL for our forums is: https://discussions.agilebits.com.

    However, if you don't want to disclose it, it is okay. Hopefully, our workaround will work. :)

    Looking forward to hearing back from you,

    Greg

This discussion has been closed.