Auto-fill no longer working after update

I updated both the 1password app (via your website) and the Chrome browser extension yesterday. Since updating the 'Fill login on current webpage' shortcut does not return any logins on URLs that I know have worked prior to performing the update.

Has the logic changed that detects the page URL and / or the relevant entries in 1password?

For example I have an entry with the website 'accounts.google.com'

When I'm on that page, hitting "cmd + \" no entries are returned for me to select my account.

Have I missed something about this update, maybe a setting needs to be changed or something?


1Password Version: 6.5.5
Extension Version: 4.6.3.90
OS Version: 10.10.4
Sync Type: Not Provided

Comments

  • matthew_agmatthew_ag 1Password Alumni

    Hey @c3nathan,

    Sorry about the trouble after the upgrade. There shouldn't be any changes to the URL detection logic in our latest release, if you're on "accounts.google.com", when you use Cmd + \ you should see all the Login items that have "google.com" as the host (we strip the "accounts" subdomain when matching).

    I have some questions that might help me understand what is going on:

    • When you use Cmd + \ do you see the 1Password Mini appear with no Login items offered or do you not see the 1Password Mini appear at all?
    • Do you see any error messages appear in 1Password?
    • Could you double check that the Login item(s) you were expecting to see in the 1Password Mini do have "google.com" in the website field when you view them in the 1Password app?

    Best regards,
    Matthew

  • I have the same problem with 1Password for Mac and the Safari extension. I updated to version 6.5.5 manually, and I am now unable to get any password filled in. This is an issue for all the websites I tested, which I anyway was using on a regular basis before.

    When I use cmd-\, 1Password mini appears with no login items at all. When I then manually search for the password item in the search, it finds one, and when I try to apply it, it reopens a separate window with the same URL (so it's the correct one recorded in 1Password, per your 3rd question), but does not fill the fields.

    There is no error message in 1Password or in 1Password Mini.

    There is no log in Console.

    This is on Mac OS X 10.11.6

  • OK, after a bit of fiddling, it seems what restored things was to restart Safari. But I also disabled/re-enabled the extension and quit 1Password. I did not have to restart my computer, so that's a relief :-)

  • Hi @matthew_ag

    I was being a spud.

    I've since realised as I'm doing most of my work in an incognito chrome window, the extension when it was updated/reinstalled had not been ticked to be allowed in incognito windows. Now that I've ticked that and can see the extension is available I'm seeing the normal behaviour with the popup / and or auto fill.

    Sorry for the time wasted.

  • matthew_agmatthew_ag 1Password Alumni

    Hey @c3nathan,

    No worries at all - it's a very easy thing to do. Glad you were able to figure it out.

    Best regards,
    Matthew

  • matthew_agmatthew_ag 1Password Alumni

    Hey @cparnot,

    Thanks for writing in and letting us know how you resolved that. Hmm, it seems that the 1Password extension got into a bad state and required to be reset. Sorry about that. If you encounter that again, please do let us know. We'd like to get to the bottom of that.

    Best regards,
    Matthew

This discussion has been closed.