Chrome extension is unchecking "remember me"

[Edited to reflect that the issue is with the Chrome extension. The Firefox extension works fine.]

The behavior:
1. I go to a login page.
2. I manually check the "remember me" box.
3. I use the 1Password Chrome extension to select the login.
4. The extension fills in my user name and password, then unchecks the "remember me" box and submits.

When I use Firefox (add-on version 4.6.3), it leaves the "remember me" box checked. (I've just tested with Agilebits login page and the Dropbox login page.)

I've noticed this over the past few days, but I don't know how long it has been broken.


1Password Version: 6.5.5
Extension Version: 4.6.3.90 (Chrome)
OS Version: Mac OS 10.11.6
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @cakoose: Can you give an example? 1Password should be checking/unchecking the box based on the state you saved in the login. Is that not the case? It sounds like there may be a bug, but the opposite of the one you're thinking. If you've saved your login with the "remember me" box checked, 1Password should restore that in both browsers when filling. Let me know what you find!

  • I opened the 1Password app, found the relevant login, and clicked "show web form details". That form only has two fields: "username" and "password". (I tried manually adding the site's "remember me" field and that causes the Chrome extension to check the box when submitting, but that's just a workaround.)

    Example site: https://my.nsone.net/#/login
    1. Check the "remember me box"
    2. Use the 1Password extension to fill in the login.
    3. The 1Password extension fills in username and password, then unchecks the "remember me" box, and submits the form.

    This only happens with the Chrome extension. The Firefox extension works fine.

    Something slightly different happens on https://www.dropbox.com/login
    1. When you go that page, the "remember me" box starts out checked.
    2. If you use 1Password, it fills in the username and password, leaves the box checked, then submits.
    3. But if you first uncheck and re-check the box, then use 1Password, it fills in the username and password, unchecks the box, then submits.

    Again, this only happens with the Chrome extension. The Firefox extension works fine.

  • Hello @cakoose,

    I'm actually more surprised it doesn't happen in Firefox. Your description has highlighted a small issue, one we should be able to easily fix. As I say though it highlights a difference in the browsers as I would have hoped for consistent behaviour over the browsers even if it wasn't ideal behaviour.

  • Just checking -- are you guys able to reproduce the issue yourselves? If not, please let me know and I'll try to include more details.

  • Greetings @cakoose,

    I was yes. I discovered the cause and we have a potential fix being reviewed for inclusion in the next extension beta. I'm still unsure as to why it only affected Chrome though as once I located the cause I can understand why Chrome is doing what it is doing. Don't worry, you supplied all the details needed already :smile:

This discussion has been closed.