Auto fill & submit not working on one website

For the site below the auto fill/submit function launched via the extension icon and the keyboard (command /) does not work. If I copy the password to the clipboard (via extension) and paste into the password field and manually submit the login succeeds. I have had no problem with other sites.

The site is the Social Security Administration:

1Password Version: 6.6.1
Extension Version: 4.6.3
OS Version: macOS 10.12.3
Sync Type: Wireless


  • Drew_AGDrew_AG 1Password Alumni

    Hi @ag1pwun,

    I've moved your message to our Saving and Filling in Browsers forum. I hope you don't mind!

    Thanks for including the URL of the website where you're having a problem! I tried saving a Login item for that site, and 1Password is able to fill the form correctly, so I'm not sure why it isn't working for you. Please follow these steps to save a new Login item for that site. Does the new Login item work correctly?

  • I followed the steps to save a new login and found that the saved login only stored the first 20 characters of the password. The correct password is 28 characters long. Perhaps that's a clue as to what's going on.

  • matthew_agmatthew_ag 1Password Alumni

    Hi @ag1pwun,

    Thanks for writing in, I work on the extensions team here at AgileBits so thought I'd jump in to help take a look. The password field on that Social Security Admin login form is limited to 20 characters (see screenshot of the HTML code of the password form below).

    The maxlength attribute of the password field limits user input via keyboard and copy & paste entry. So if your password is 28 characters and you copied & pasted it into the field, the field would trim the password down to 20 characters. Then when you hit "Sign In", only the first 20 characters would be used to log you in.

    However, by using 1Password's filling process via Cmd \, the whole 28 characters would be set into the password field. This is possible because 1Password enters the details programmatically rather than using the mouse / keyboard.

    I think the next test would be to remove the last 8 characters from your password. Then copy & paste the remaining 20 characters into the password field to see if that works (without using the 1Password app). If that works, then you'll know that your password is really only the first 20 characters of the original 28.

    If that turns out to be true, then the Login item created via the "Save Login Manually" should be able to work.

    Let me know if that helps!

    Best regards,

  • Because of the unsuccessful login attempts the site blocked me for 24 hours so I had to wait to try it again. Your explanation makes sense and that is indeed the problem. The saved login worked fine and I've removed the last eight characters from the original login.

    I think this is a problem with sites that don't indicate the maximum password length when registering. Then, as in this case, they accept your manually entered login because of the browser truncation before sending.

    Thanks for your help with this.

  • matthew_agmatthew_ag 1Password Alumni

    Thanks for writing back @ag1pwun and I'm glad to hear things are working for you now :chuffed:

    Those websites could certainly mention it somewhere however I think 1Password could do a better job of highlighting that it has been asked to fill a longer password than the maxlength of the password field allows. We have heard about users experiencing issues based on the maxlength before. I will add your story to our records so we know how many people have been affected. Hopefully we can improve 1Password in a way that will help users identify these kinds of problems themselves without having to resort to spending a lot of time their time contacting us.

    Thank you for writing into us about it - reports like this are critical to making 1Password better.

    Best regards,

    ref: OPX-60

This discussion has been closed.