Forum keeps rejecting a post containing a link

I tried several times to post a comment here:

https://discussions.agilebits.com/discussion/comment/362075#Comment_362075

It got rejected everytime telling me that it needed to be approved. Then I removed a link from the comment and it got posted right away. Is the forum suddenly rejecting links? Or maybe just that specific link?

(I'll try to post the link in the next comment as a test.)


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Yep, as expected my comment with the link got rejected right away once again. I don't think there is anything wrong with the link. It does contain the word "malware" in it though. Is the automatic moderation of links too aggressive?

  • And here is the link as a test.

  • DanielPDanielP

    Team Member

    Hi @pervel

    Just to make sure we are on the same page: was your link rejected in your second comment but not on the third?

  • The third comment (the one with the link) was rejected at first and then only appeared several hours later. The same can be seen in the other thread where my four attempts at posting the comment all appeared almost a day later - all at once. So something has gone wrong with the moderation.

    Also, the notification that a comment is being held back for approval is very subtle and easy to miss. I think that's why you sometimes see people posting twice or more. If you overlook the notification, it just looks like you forgot to post the comment.

  • brentybrenty

    Team Member

    @pervel: Sorry for the trouble there. This isn't moderation but rather automated spam protection. We don't see a lot of spam here because it works pretty well for the most part. But if you've seen any of the forum spam that gets through from time to time, you'll notice that it looks very much like your post: relatively benign comments with a link to an external site. While I don't have a surefire solution for you, the good news is that it does improve over time, and we're here if you run into further issues. :blush:

  • @brenty, can the automated system be tweaked so it only checks newly created accounts with no posts yet? I suspect almost all spam comes from accounts like that.

  • brentybrenty

    Team Member

    @pervel: I'm kind of glad you asked. Unfortunately spam comes from all manner of sources. But one thing that does help is verifying your forum account. It's probably something you forgot about long ago, but we just noticed that you weren't verified, which certainly contributed. But since we're pretty familiar with you at this point, we've taken care of that for you so it should be less of a problem going forward. ;)

  • sjksjk oversoul

    Team Member

    As brenty mentioned:

    … you weren't verified… we've taken care of that for you …

    And also deleted duplicates of your other comment. :smile:

  • Thanks! I don't remember ever being asked to verify my account. Strange.

  • brentybrenty

    Team Member

    @pervel: No worries. It's an email that's sent on account creation, and it wouldn't be shocking if it were overlooked or got stuck in the spam folder. It hadn't even occurred to me to check that either (as I'm sure it didn't you!) since you've been around for a while. Cheers! :)

This discussion has been closed.