Master Password not accepted in Windows beta [Fixed in 1Password 6.5 Beta 3 update]

bthayer23bthayer23
edited April 2017 in Windows Beta

I just upgraded to the Windows app, version 6.5.395, and now my Master Password isn't working. It worked before the upgrade, and I haven't changed my master password in a couple months.

Things I already tried to fix the problem:

  • The master password still works via web and iPhone
  • I uninstalled the Windows app, moved the "data" folder to "backup-data", and reinstalled beta .395. My master password worked for a few hours, then the computer locked when I stepped away and it stopped working
  • It doesn't matter whether I enter the MP via Chrome mini or Windows app, neither work
  • Fully restarting my computer (I have Intel SGX enabled, not sure if this is screwing with the beta)

Things I haven't tried yet:

  • Reverting back to non-beta version (is this possible?)

Any ideas?

-Ben


1Password Version: 6.5.395
Extension Version: 4.6.3.90
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @bthayer23,

    Thanks for writing in.

    That sounds like it may be SGX, did you enable SGX in 1Password after the initial sign-in prior to getting locked out? We have not changed anything related to the master password itself since the beginning, so this issue isn't something that should change now. However, SGX is a different story, it changes how your encryption key is stored.

    This should be easy to find out by getting the diagnostics from your computer.

    1. Click on the start button to search for Event Viewer, open it.
    2. On the left sidebar, expand Applications and Services Logs, 1Password should show up below here
    3. Right click on 1Password to select Save all events as and save it as 'logs.txt', set Save as Type to Text (tab delimited) (*.txt)
    4. Email that file to us at [email protected] and in the email, also include the link to this thread along with your forum username.

    Let us know here when you've sent the email, so we can confirm we got it.

  • MikeT,

    You're right. SGX was enabled in the previous versions, and I re-enabled it when I installed the latest beta. I've exported my logs and emailed them to the address you provided.

    Thanks!

  • I re-installed the software with a blank vault and made sure to not enable SGX this time. Login works fine.

  • MikeTMikeT Agile Samurai

    Team Member

    That's great to hear!

    We got your email and will reply to it as soon as possible.

    ref: VWM-35785-934

  • pbryanwpbryanw Junior Member

    Hi, I just had this problem after enabling SGX on my home PC with the 1Password 6 Beta (my master password wasn't recognised). This was after I had reinstalled Windows 10 to solve an issue I was having. To fix this issue, I deleted the 1Password folder in appdata and started again.

    Now, I'm reticent to enable SGX again - has the reason why enabling SGX causes this problem been found yet, and is it safe for me to re-enable SGX? Thanks.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @pbryanw,

    Wait, did you have the problem after reinstalling Windows 10 or before?

    For now, don't enable SGX, we're investigating the cause.

  • pbryanwpbryanw Junior Member
    edited March 2017

    @MikeT - It was only after reinstalling Windows 10 that I had the problem (and by reinstalling, I mean using Window's built-in reset functionality).

    I think it's the same issue as bthayer23, as I recall enabling SGX after successfully resetting Windows, then trying multiple times to login into 1Password, ending in failure. It was only after I deleted the 1Password appdata folder, that I was able to log back into my account.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @pbryanw,

    When you re-enable SGX, did you get a prompt to reinstall Intel's tool?

    One of our teammates with SGX machine was able to reproduce it as well and we're investigating to get it fixed.

  • pbryanwpbryanw Junior Member
    edited March 2017

    @MikeT - Hi, I was recently sent a newer copy of CryptoProviderInstaller.exe through 1Password support, which I had used before to get SGX working in 1Password with my Asus motherboard.

    So, after I reset Windows 10, I think I reinstalled CryptoProviderInstaller.exe, then enabled the feature in 1Password. I say think, because I was reinstalling a whole bunch of software after the reset, and I do recall taking this step. I didn't know that 1Password for Windows prompts you when you first enable SGX. I think the SGX checking tool was showing SGX as unsupported by my motherboard, until I installed CryptoProviderInstaller.exe. I will wait until you find the cause of this issue, before re-enabling SGX support in 1Password. :+1:

  • brentybrenty

    Team Member

    Thanks for the additional details! We'll get this sorted out. :)

  • @bthayer23 @pbryanw thank you for your reports, we believe we've fixed that issue (that was broken DLL link in SGX related code, not SGX itself) and it will be available with next beta update.

    I want to note that your data stays intact regardless if you are using SGX or not. SGX is another way we process your data in your device's memory.

  • pbryanwpbryanw Junior Member

    @SergeyTheAgile - Thanks, for your update (plus the extra information on SGX) - will look forward to the next beta, and will hold off re-enabling SGX until I have installed it :+1:

  • GregGreg

    Team Member

    @pbryanw: On behalf of Sergey you are very welcome! Please contact us anytime, we are always ready to help.

    Cheers,
    Greg

  • pbryanwpbryanw Junior Member
    edited April 2017

    @Greg - Thanks, I've just upgraded to 1Password 6.5.BETA398 which includes the SGX fixes, and have no problems logging in with my master password with SGX enabled. Many thanks to the Agilebits Window's Team for the prompt fix :+1:

  • GregGreg

    Team Member

    @pbryanw: That is great to hear! :+1: On behalf of our Windows Team you are very welcome!

    Please contact us anytime if you have any other questions, we are always ready to help. Have a fantastic Sunday!

    Cheers,
    Greg

  • @SergeyTheAgile @Greg Ditto, 6.5.398 works great, no issues with SGX (or anything else). Thanks for the excellent customer service.

  • @bthayer23 great to know, thanks for helping us! Please keep feedback coming :)

This discussion has been closed.