iOS sign in error

I'm using 1Password for families and recently upgraded to iOS 10.3 and changed my Master Password. Since that time, whenever I use 1Password on an iOS device (iPhone or iPad), I get the error:

Sign-In Error
We're having trouble logging into your account. Please make sure your Secret Key and password are filled in correctly.

I can confirm that the both are correct. 1Password works fine on my Mac (and bizarrely, on my iOS devices I have FULL ACCESS to all of my passwords despite the authentication error :(

Not sure what's happening here. Any thoughts welcome...


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: iOS 10.3
Sync Type: Not Provided

Comments

  • BenBen AWS Team

    Team Member

    Hi @chippyaft,

    Thanks for taking the time to write in. Sorry for the trouble. Could you please check and see if you have a Primary vault on iOS? You can do so in 1Password under Settings > Vaults. If you do, 1Password unlocks using the Master Password for that vault, and not the Master Password for your 1Password.com account, which may be different.

    Please let me know how it turns out.

    Ben

  • Hi Ben
    Thanks for the quick reply. I'm not sure I follow (the whole vaults thing confuses me a little) but I can confirm that I have a "Primary" vault under settings, along with 6 other vaults under my family name. When I login to the app, I see the "All Vaults" circle in the top left corner.

    Hope that helps?

    Richard

  • BenBen AWS Team

    Team Member

    Richard,

    Thanks. That confirms my suspicion.

    When a Primary vault exists 1Password unlocks using the Master Password for that vault. This may be different than your 1Password.com account password. It sounds like in your case it is.

    Did you print your Emergency Kit as part of your 1Password.com account setup? If so that should have the account Master Password written on it.

    Ben

  • I confess I'm still in the dark. I've only ever had 2 Master Passwords; I've tried both on this sign-in screen but neither work.

    What I'm really confused about is: if my password is wrong, why am I allowed to sign in to see my vaults? And if my password is right, why am I seeing this error?

    Richard

  • I've tried going to my.1password.com to sign in and you're right - my Master Password doesn't work there either, so I guess that must be the root cause. I've tried both of the Master Passwords that I have used in the past (which are on my Emergency Kits), but they don't work on that site.

    It's strange that having used 1Password for families for (almost exactly) a year, I've never seen this error before. My Macs are working fine with the new Master Password.

    Can you let me know how I can reset my password for 1password.com?

  • A little progress - if I ignore "my.1password.com" but go to my family site, I CAN log in with my new Master Password. So that's good news.

    So I guess the problem is with the iOS app which doesn't like my new Master Password for some reason?

  • BenBen AWS Team

    Team Member

    Hi @chippyaft.

    my.1password.com is the sign-in site for individual 1Password accounts, not 1Password Families. For a 1Password Families account you need to use your unique sign-in address (this will be on your Emergency Kit). That could potentially be the issue you're having in the app as well. Please make sure the sign-in address is correct. :)

    Ben

  • chippyaftchippyaft
    edited March 2017

    Yep - using my unique sign-in site, I can login via my browser.

    The "Sign-in Error" screen on the iOS app shows the correct unique sign-in site, e-mail address and Secret Key. But when I type the password in the iOS App (that works on the Sign-In Site), it fails.

  • I've also reset the password in two locations in the Mac app Preferences: under "Security" and "Accounts". The Mac is happy with the changes, but the iOS still shows the error.

    So in a nutshell: family website login works, Mac App login works, iOS login fails.

  • So - if I type my password into the iOS App the first time, it fails. If I type the EXACT SAME password a second time, it works!

    I've tried this on one iPhone and two iPads (all running iOS 10.3) with the same results.

    iOS App bug?

  • Spoke too soon. Now I'm getting the same error on my Mac - 1Password will launch and I can login, but then I get seemingly intermittent "Sign In Error" pop ups.

    This is really frustrating. Is there a number I can call for phone support on this?

  • BenBen AWS Team

    Team Member

    @chippyaft

    I'm sorry but we don't have telephone based support. We'll definitely get this resolved for you though, please bear with us. I'd like to ask you to create some Diagnostics Reports, one from each of your devices:

    Attach the Diagnostics Reports to an email message addressed to [email protected].

    With your emails please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/77223/
    • Your forum username: chippyaft

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the reports and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

    Ben

  • Thanks Ben. Diagnostic reports sent from both Mac and iPhone - ticket number #VSM-13467-356

    (BTW - I notice that in a section of the Mac report it says "No licence found". Is that normal?)

  • BenBen AWS Team

    Team Member

    Thanks @chippyaft. I received the reports and will reply to you via email shortly. :)

    Ben

    ref: VSM-13467-356

  • Hello,
    same problem with me, is there already a solution?
    Thanks a lot
    Marcus

  • BenBen AWS Team

    Team Member

    Hi Marcus,

    Do you have a Primary vault still? And are you able to login to your 1Password account through the web interface?

    Thanks.

    Ben

This discussion has been closed.