Login details clearing out on website after filling

This discussion was created from comments split from: 1Password won't submit form when Safari Is not open first.

Comments

  • mmcgrathmmcgrath Junior Member

    Since upgrading to the "account' version of 1Password this week ,one of my bank account logins will not operate as it has for many years on the old version. The issue is that the log in requires a username, password and random authentication key. I have set the 1PW login with the username and password and I have the display set to 'always' and the submit set to 'submit when enabled' This used to allow the user name and password to transfer to the login page and then stop and wait for the authentication number to be keyed. I would then submit and everything would work fine. Since upgrading to the 'account' model the 3 fields are populated ok but when I press enter the 3 fields go blank . This happens repeatedly. I'd be grateful for any advice as to how to fix this. all my other logins work ok.

  • mmcgrathmmcgrath Junior Member
    edited April 2017

    Further to my earlier comments, I'm using a 2015 iMac with the latest software but the same thing happens on my iPad Pro.

    Now after much experimentation , if I open the 1PW logon, fill the data, then delete the password and input it manually or copy from the original 1PW page then it works ok. Something is happening with the password when it 'fills' on to the login page . its OK manually or copied but not OK with the auto fill.
    Any ideas ?

  • brentybrenty

    Team Member

    @mmcgrath: I think upgrading to an account may be a red herring, as the apps (and browser extensions) work the same regardless.

    It sounds like what you really want is "Never submit" set in this login item. "Submit when enabled" will mean that if you have Autosubmit enabled at all (1Password mini > Settings > Submit Logins), the login will fill and submit the form without waiting for you.

    However, 1Password for iOS does not have an Autosubmit feature, so it may simply be that the website has changed. Unfortunately without some basic information it's hard to say what might be going wrong and how we might right it! Please tell me the OS, 1Password, and device versions you're using, the exact steps you're taking, and what is (or is not) happening the way you expect so we can figure out the best plan of action:

    Find your version

    The more information you can give, the better. For instance, are you having trouble with specific sites, or on a particular device? If you're having trouble with specific sites, be sure to include that information. Often simply manually saving the login will save additional information that will allow 1Password to work. Thanks in advance! :)

  • mmcgrathmmcgrath Junior Member

    Thanks for your response. I have read a bit more of your info on the different 'submit' options. 'Never" is the way to go but it still hasn't changed. has the additional info that I inputted 5 minutes ago been of value to you in understanding the issue ?

  • mmcgrathmmcgrath Junior Member

    Hi brenty I think I have found the solution .I removed all non alpha and numeric symbols, reduced the number of characters to 8 . Now it seems to work OK. Its been a long day trying to find the problem but i'm hopeful this is the answer.

  • brentybrenty

    Team Member

    @mmcgrath: I hope you don't mind, but I've split you off into a separate discussion so we can focus on the specific issue you're having.

    It sounds like you may have weakened your password for the site in the process of getting it working. If that's part of their requirements, that's unavoidable. But I'd also like to see if there's another solution that will allow you to use a much stronger password!

    If you'll tell me the URL where you're having this issue and the OS, 1Password, browser, and extension versions you're using, I'll be happy to test this to see if I can offer a better solution. :)

  • mmcgrathmmcgrath Junior Member

    Thanks for your follow up. I agree that the password structure has been weakened. Info you've asked for is :
    URL : https://www.bendigobank.com.au/eai/Logon/login.page
    OS : iMac Sierra 10.12.4
    1Password : version 6.7
    Browser : Safari version 10.1
    Extension : version 4.6.4

    Many thanks for your interest

  • brentybrenty

    Team Member

    @mmcgrath: Wow. Thank you! So, I wasn't able to see that there's any information on their password requirements...but I did notice that the password field on that login form simply does not allow more than 8 characters! If you were using something longer previously, it may be that they changed their requirements.

    However, there is another, weirder possibility. It may be that when you setup the original password, the longer one was accepted, but then truncated to 8 characters when set, and also when you tried to fill it. I'm not sure why that would no longer be the case, but it is something I've encountered with other websites myself in the past.

    Regardless, it does still seem clear that 8 characters is the maximum allowed. But if you didn't generate your current password using 1Password, I'd encourage you to find out for certain what their requirements are and have 1Password generate the strongest one allowable for you — and also encourage them to allow you to use stronger passwords!

  • mmcgrathmmcgrath Junior Member

    As I reflect back on the upgrade process... I suspect The 'submit when enabled' setting repeatedly sent the logon submission without the verification code. The bank then locked the account. I had the password reset to one that was longer than 8 characters and was more complex that the original. The new password must have been that cause of the problem. When I had a flash of inspiration (from reading your blog ) and reset the password again to a shorter and simpler array ...all my problems disappeared.
    I'll send your suggestions to the bank next week though.
    Many thanks for you prompt and insightful support.

  • brentybrenty

    Team Member

    As I reflect back on the upgrade process... I suspect The 'submit when enabled' setting repeatedly sent the logon submission without the verification code. The bank then locked the account.

    @mmcgrath: Ah, that makes sense. I hadn't thought of that. :(

    I had the password reset to one that was longer than 8 characters and was more complex that the original. The new password must have been that cause of the problem. When I had a flash of inspiration (from reading your blog ) and reset the password again to a shorter and simpler array ...all my problems disappeared. I'll send your suggestions to the bank next week though.

    That sounds like a good idea. But I would also like to say that while encouraging them to allow you to use more secure passwords is important, it does sound like 1Password played a role here in getting you locked out (due to Autosubmit). I'm sorry for the trouble that caused you.

    Many thanks for you prompt and insightful support.

    Any time! We're here if you need us. :chuffed:

This discussion has been closed.