Does not automatically lock while asleep

I put my Surface Pro 3 to sleep last Thursday mid-day and went to a conference. I didn't turn my computer back on until this morning. 1Password was unlocked when I put it to sleep, but is set to lock after 2 hours, which in the past it has always done even when I'd put it to sleep and wake it up in the morning--it would be locked. This morning, 1Password hadn't locked since last Thursday, it was still signed in and in fact I used it to sign into this forum :-) Something with the locking code has changed...it should definitely err on the side of locking if the system clock has moved 2 hours (where 2 hours is the lock timeout in preferences) even if the system has been asleep!


1Password Version: 6.6.405d
Extension Version: Not Provided
OS Version: Win 10 Pro 1703
Sync Type: Families

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @dszp,

    Thanks for reporting this.

    Hmm, we haven't touched the locking system in a long time but we'll test on our Surface Pros to see what's going on. We'll follow up as soon as we finish testing it.

    You said it used to work fine before, did you recently update to Creators Update that might be causing some glitches?

  • @MikeT Yes I did upgrade to Creator's Update. Same issue overnight last night. And I'm on 6.6.406 now.

  • MikeTMikeT Agile Samurai

    Team Member

    @dszp, do you recall if this issue has occurred for you before Creators Update and/or 1Password 6.6 beta builds (402-406)?

    From my experience, we've seen weird glitches after every major Windows 10 update and it would at least explain the timing but we have released 1Password 6.6 beta builds at the same time.

    Can you switch to the 1Password 6.5 stable and rule it out for us?

  • I will switch when I'm back at my computer, sure. Both upgrades were around the same time, within 3-4 days, to latest beta at the time and Creators. 1 or 2 beta updates have installed since as well with no changes. Haven't seen an auto-update work either though.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @dszp,

    The auto-update only works when you have a locked view at the time of the update check, which we only do once every 8 hours. Considering your issue where it didn't auto-lock overnight, it makes sense it didn't work at all. I suspect once we figure out the auto-lock issue, the auto-update will work after that as well.

    We're in the process of cutting the 8 hours timer down to 4 hours for beta updates only. We're just taking this step by step, resolving any issues we find (like this auto-lock one) and move on to the next phase.

  • @MikeT I was trying to keep it closed and locked for a while before it started not locking :-) I managed an hour or so before I needed it. I'm back to 6.5.401d now, will leave it overnight and see how it does lock-wise. I have it set to NOT auto-lock on session change (I lock my computer too often) but to lock after 1 hour idle, which is how it's been set for months.

    If you're counting on my 1Password being locked for 4 hours straight but turned on (not asleep), except occasionally when I leave it docked and forced on overnight, that doesn't happen. So auto-update probably won't do much for me ever :-) Not a problem really, I can click a button to upgrade.

  • brentybrenty

    Team Member

    I managed an hour or so before I needed it.

    @dszp: I had the same experience when trying to test the auto-update. :lol:

    Not a problem really, I can click a button to upgrade.

    I hear you. Weirdly, I kind of enjoy updating stuff for some reason. But we do want to make sure this feature works for everyone who isn't like me. Thanks for your feedback on this! :)

  • @MikeT My computer decided to shut down instead of sleep last night so I didn't get to test this. I'll give it a shot again tonight!

    @brenty Yeah I love updating stuff...gets me in trouble sometimes (you know, updating beta firewall firmware at customer sites remotely overnight--that usually ends well, but occasionally does not--this was years ago though ;-) I can leave the laptop plugged in overnight some night when I know there's an upgrade, in order to test, when I'm back on the beta from testing the other stuff in this thread--I'll try really really hard not to install an update immediately the next time one comes through. But if you guys would put less interesting stuff in the release notes, it would make it easier...

  • SergeyTheAgileSergeyTheAgile

    Team Member
    edited April 2017

    @dszp there is a little cheat that can save you night of waiting - check out %localappdata%\1password\app\6\1password.json file, look at timeBetweenCheckForUpdates ;)

    Another way to see if auto-update kicks in while locked - lock it after start, by default (delayBeforeFirstCheckForUpdates) 5 minutes later it will check for update and if app is locked and update is there... well, i expect it to work.

    Hope that helps

  • @MikeT Back on stable yesterday, wasn't locked this morning and it was locked all night and I didn't wake it up until this afternoon. Seems to be a Creators Update issue.

  • brentybrenty

    Team Member

    Thanks for letting us know. That's really odd. Do you mean that even with a shorter timer it isn't working?

  • @brenty I'm on 6.5.401 as of Thursday. Overnight to Friday and overnight last night until now, I put my computer to sleep, and upon waking it 12+ hours later 1Password is still unlocked, the same thing that was happening across the last few betas after Creators Update. Options->Security has Auto-lock set to 1 hours, and the "Lock when switching session" unchecked, a setting that I've not changed in months. Previously, waking up the computer after more than 1 hour of sleep would cause 1Password to be locked, even though the computer was not awake and idle for more than 1 hour, which is desirable.

  • brentybrenty

    Team Member

    @dszp: Thanks for confirming. I'd hate to blame this on the Creators Update, especially given that we're not seeing similar reports of this and I haven't seen this behaviour myself. But on the other hand it does sound like it's something specific to your setup. Would you mind sending some diagnostic information? It sounds like it's pretty consistent for you, so if it happens again try to grab the event logs:

    1. Click on the start button to search for Event Viewer, open it.
    2. On the left sidebar, expand Applications and Services Logs, 1Password should show up below here
    3. Right click on 1Password to select Save all events as and save it as 'logs.txt', set Save as Type to Text (tab delimited) (*.txt)
    4. Email that file to us at [email protected] and in the email, also include the link to this thread along with your forum username.

    Let us know the Support ID you receive when you've sent the email, so we can confirm we got it. Thanks for your patience and willingness to work with us on this!

  • @brenty Thanks, the Support ID is: [#RYU-21238-261]

    If I leave the computer on without sleeping for longer than an hour, auto-lock DOES seem to be working correctly. It's just when the computer is asleep it seems to avoid locking. I went ahead and updated to v4.4.407 (beta) again for now, after sending the event logs, since that doesn't seem to be making a difference.

    @SergeyTheAgile Thanks for your earlier tip about the 1password.json file, I adjusted it to check for updates every 30 minutes for now :-) I'll give the statup thing a try as well at some point now that I'm back on beta!

  • brentybrenty

    Team Member

    @dszp: Glad the tip helped. And thanks for sending that! I see that we've received your email, so we can continue the conversation there. We'll take a look at the diagnostics and get back to you shortly! :)

    ref: RYU-21238-261

This discussion has been closed.