Mac Sierra IPW v7.6.1 My identity id suddenly will not fill. ???

The Identity card no longer fills when selected for an auto fill form. Has previously been very reliable. How can I
"repair" this feature?

Comments

  • matthew_agmatthew_ag 1Password Alumni

    Hi @leemale15604,

    Sorry about the trouble with this. I'd like to narrow this problem down:

    • If this is just a problem with your Identity item then your Login items should be able to fill. If your Login items are able to fill then please try re-creating your Identity item and check if that works.
    • If none of your 1Password items (Identity, Credit Card or Login items) can be filled anymore then something is wrong with the extension's connection with the main 1Password app. In that case please let me know what happens when you click on the 1Password extension button in your browser.

    Finally, from your title you mentioned your using 7.6.1 but I'm assuming you're using 1Password for Mac 6.7.1?

    Looking forward to hearing back.

    Best regards,
    Matthew

  • Matthew Thanks for your response. My login items are all working I don't know of a way to test the identity or the credit card without a form to fill. Any suggestions? The last two or three times I have had occasion to use identity it has not filled at all. I am not sure either way about "credit card". I have deleted and re written identity but not sure how to check it.
    You are correct in your assumption about v6.7.1. for Mac.

  • Greetings @leemale15604,

    The following page will allow you to test filling an Identity item.

    Mozilla Autofill Forms Test Page.

    With the relevant fields filled in an Identity item, 1Password will fill all the textfields in the top section with the exception of Street Line 2 & Homepage. To help I'm also including a screenshot of one of my test items (the PG friendly one :lol:).

    Notice how many of the entries do not have the delete button. Those are the default fields and are the only ones 1Password will use to fill. Custom fields are not currently considered for filling purposes.

    If you find your Identity item still isn't filling on the test page I've linked to can you see if you find the same with new test Identity item. The values won't matter, just that you have text in the default fields that 1Password should fill and whether 1Password fills it into the correct fields.

    If you're still seeing issues can you tell us what browser you use please and what version of the 1Password Browser Extension you have installed. Maybe these details will either highlight something or at least allow us to test for the presence of a bug in a specific configuration :smile:

  • Good Morning Very interesting. The test form ,Mozilla Autofill forms test page works with my new identity selection. I could not find one for the credit card but am confident that one will work. After completing a few tests, I took a screen shot of the original form and found that it would not work. I assume it's protected somehow. Returning to the original test form worked every time. Do you have any idea why the original identity card failed, or why the new one now works? It would be nice to know I could fix the problem myself if it reoccured.
    In any case, it does work and I thank you very much for helping me get that function going again. Lee

  • Drew_AGDrew_AG 1Password Alumni

    Hi @leemale15604,

    After completing a few tests, I took a screen shot of the original form and found that it would not work.

    I'm probably misunderstanding what you meant, but it sounds as if you took a screenshot of a web form and then somehow tried to use 1Password to fill that screenshot - which of course won't work. Can you please let us know the exact steps you took to test this when it failed to work?

    Returning to the original test form worked every time.

    Are you referring to the original web form that you weren't able to fill via the 1Password extension? Or the 'Mozilla Autofill Forms Test Page' that littlebobbytables suggested?

    In any case, it does work and I thank you very much for helping me get that function going again.

    I'm happy to hear it's working again for you! On behalf of Matthew and littlebobbytables, you're very welcome. Hopefully it continues to work for you, but please let us know if you run into that problem again. Have a great weekend! :)

This discussion has been closed.