1Password 6.8 no longer works with Vivaldi

Hello AgileBits Team,

I just updated my 1Password installation to version 6.8 and can no longer use it with Vivaldi. When I open the browser, I get the error message "1Password can't save or fill in Vivaldi".

Now, I did follow the steps from this support article, but I noticed two things here:

First, the 2bua8c4s2c.com.agilebits.1password.json file is not at the location specified in step 2 because that directory doesn't exist on my system. I could however find the file in ~/Library/Application Support/Mozilla/NativeMessagingHosts because I happen to have the Firefox browser installed as well.

Second, even when I take that file and copy it to Vivaldi (following steps 4-6), I still get the error message each time I start Vivaldi and can't use 1Password within the browser.

  1. Do you have any other solutions that might work for me?
  2. If not, might it be possible to go back to the previous version of 1Password until the issue is fixed?

Best regards
kaffeeundsalz


1Password Version: 6.8
Extension Version: 4.6.7.90
OS Version: macOS 10.12.5
Sync Type: Families Plan

Comments

  • It's as if you're using my computer. I'm having the same issue with Vivaldi, and did all the identical steps, with the exact same result.

  • Hi @kaffeeundsalz and @schac8,

    We're updating our support article to better account for people who have never installed Chrome. There was an assumption made that is clearly false. Can you try the following for me please.

    1. Open a Terminal window, if you haven't used Terminal before Spotlight is the easiest way to locate it as it's my top result even just after typing ter.
    2. Paste in the following command and press enter, the command is mkdir -p ~/Library/Application\ Support/Google/Chrome
    3. Quit 1Password using the keyboard shortcut ⌃⌥⌘Q and then launch 1Password again. With the outer folder now existing thanks to step 2 1Password will create the NativeMessagingHosts folder and the file inside.
    4. You should now find the steps outlined on our page https://support.1password.com/kb/201707/ under the section titled If you use Vivaldi or Chrome Canary work.

    While I certainly applaud your inventiveness in trying the other JSON Mozilla and Chrome have different details which is why it didn't work. Each JSON details what is needed for that browser where Chrome, Vivaldi and Opera all share the same details. We are in the process of updating that support article and I apologise that we didn't anticipate this well enough in version 1 of the article.

    For what it's worth I'm a Vivaldi fan too so I can at least say that once you're past this you should find everything works as it has/does for me.

  • Hi @littlebobbytables,

    That procedure worked! Thanks so much.

  • sjksjk oversoul

    Team Member

    You're welcome, @schac8, on behalf of littlebobbytables. Thanks for letting us that you had success when following his instructions. :+1::chuffed:

  • edited July 2017

    @littlebobbytables Me too, I was able to get 1Password working again with Vivaldi after following your instructions. Thanks for the clarification and also for the background information about why the JSON file for Firefox didn't do the trick.

  • sjksjk oversoul

    Team Member

    Glad to hear Vivaldi+1Password is also a working combo for you again, @kaffeeundsalz. :+1::chuffed:

    I'd momentarily forgotten that those JSON files differ until littlebobbytables reminded me. :lol:

This discussion has been closed.