1Password can't create a required support file

The new update (6.8) is having trouble writing to NativeMessagingHosts

When I follow the instructions in Terminal, I copy the recommended command in, hit enter and type my password in and receive an error message "chown: t: illegal user name"

Can you please help! I can't use 1Password at all while the error continues.

1Password Version: 6.8
Extension Version:
OS Version: 10.12.5
Sync Type: Not Provided


  • sjksjk oversoul

    Team Member

    Hi @tomslater, and welcome to the forum!

    Sorry you're running into this snag with the instructions in How to change ownership of your NativeMessagingHosts folder. Instead of copying and pasting the command from there into Terminal, try copying/pasting this simple one instead:

    echo $USER

    Then copy/paste the output from that command into a reply back here on the forum. It should only be a single line with the username for your Mac user account, something like this:

    $ echo $USER

    I've got a hunch what the trouble is and the output from that command will help determine what to suggest you try next. Thanks in advance!

  • Hi @sjk

    The output is "t slats"



  • sjksjk oversoul

    Team Member
    edited July 2017

    Thanks, @tomslater -- that confirmed my hunch that your Mac username has a space character in it.

    Let's try making a small adjustment to the command in step 2 from How to change ownership of your NativeMessagingHosts folder. Change $USER to "$USER" (put double-quotes around $USER) so it looks like this:

    … chown "$USER":staff …

    I'm intentionally not posting the full command here, and please excuse the difference in formatting between here and the article.

    If you have any trouble with that please post your result here and we'll get it sorted out. Thanks!

  • Fixed. Thank you!!

  • sjksjk oversoul

    Team Member
    edited July 2017

    Sweet! I'll be updated I've updated the article to include the double-quotes around $USER, which I'd been tempted to do earlier when wondering if anyone might have whitespace characters in their Mac username that could trip up that command. :)

    ref: DCX-27449-793

  • I suspected that might have been it as well, so thanks for sorting.

  • sjksjk oversoul

    Team Member

    My pleasure to help, Tom. Thanks for providing an actual case to test that with. :)

    And now that we've resolved this here on the forum, I've closed the support ticket with the email that you also sent about it.

    Have a fun week!

  • Hi, I seem to be having the same trouble with the support file not creating. The output looks like this:
    chown: /Users/danbutler/Library/Application Support/Mozilla/NativeMessagingHosts: No such file or directory

    Hope you can help! Thanks!

  • matthew_agmatthew_ag 1Password Alumni

    Hey @Ess4agilebits,

    Thanks for writing in and sorry about the trouble. Could you run the following command in Terminal please?

    ls -la ~/Library/Application\ Support/Mozilla

    This will check whether there is any permissions on the Mozilla directory that is preventing 1Password from creating the file.

    Looking forward to hearing back.

    Best regards,

  • Hi Matthew, this is what came up when I ran that command.

    ls: Mozilla: Permission denied
    Dans-iMac:~ danbutler$

  • jxpx777jxpx777 Code Wrangler 1Password Alumni
    edited July 2017

    That's a bit strange, @Ess4agilebits. Could you try this command for me and paste the output?

    ls -al ~/Library/Application\ Support | grep -E '(\.$|Mozilla|Google)'

    This should give us a more complete picture of the permissions. To be transparent, this command will tell us the permissions for the Library (..), the Application Support (.), and the Mozilla and Google directories in the Application Support folder.

  • drwx------+ 59 danbutler staff 2006 Jul 25 13:51 .
    drwx------+ 68 danbutler staff 2312 Mar 9 18:25 ..
    drwx------ 4 danbutler staff 136 Feb 16 16:36 Google
    drwx------ 2 saundersd staff 68 Apr 5 2012 Mozilla
    Dans-iMac:~ danbutler$

    Thanks jxpx777

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Thanks, @Ess4agilebits! That last line indicates the issue: drwx------ 2 saundersd staff 68 Apr 5 2012 Mozilla Notice how the other lines are all listed as being owned by danbutler but the Mozilla one is owned by saundersd? That's the source of the "Permission denied" message.

    To correct this, try this, again in Terminal:

    sudo chown -R "$USER":staff ~/Library/Application\ Support/Mozilla && mkdir -p ~/Library/Application\ Support/Mozilla/NativeMessagingHosts

    That should get things sorted out for you. Translated into English, this will change the owner of the Mozilla folder (and everything below it) that's causing issues to your user and make sure the NativeMessagingHosts folder exists.

    This command assumes your current user account is also an administrator and will prompt you for your user account password to authorize the changes. Be sure to close the Terminal window when you're done to close out the sudo session.

    I hope that helps! Let us know how it goes!

    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • Thanks Jamie! Looks like that took care of it! You have all been very helpful, thanks so much for the help!

  • Glad Jamie was able to help @Ess4agilebits and hopefully things go a bit more smoothly now :smile: Please do let us know if you run into any other issues.

  • I have the same problem but none of the above solved it for me. Any suggestions?

  • Hello @asw,

    We may need to review a diagnostic report. Can you create one please and send it in, this link will guide you through the steps and has sections for the various supported versions of 1Password.


    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. Can you post that here please to help us to keep an eye out for it. With access to the report we should be able to better assist you :smile:

  • Have sent by email. [#XED-79282-673] 1Password Diagnostics Report

  • matthew_agmatthew_ag 1Password Alumni

    Got it, thanks @asw,

    Will contact you via email soon!

    Best regards,

    ref: WID-61398-981

This discussion has been closed.