Internet connection appears to be offline

I use iOS 10.3.1 on iPhone 6S and latest 1Pw built. Since last update I can't get access to website with internal browser (error message see in Headline) - even I am online... !?

Comments

  • Nobody with the same problem not being able to open any website in any of the integrated browser (while being online - despite of error message)??

  • BenBen AWS Team

    Team Member

    Hi @macgordon,

    Thanks for taking the time to write in.

    I can't say I recall hearing of that before. Does this happen both while on WiFi and on the cellular network? Are you using any sort of VPN or proxy server?

    Please let us know.

    Ben

  • Hi Ben, thanks for your kind reply.
    It tried it - it seems to be a cellular problem only, all ok wifi wifi.
    I deactivated VPN, but maybe some newly installed certificates for companies internal communication may cause these problems (is this some sort of proxy?)

  • BenBen AWS Team

    Team Member

    @macgordon

    1Password is fairly strict about making sure it is talking to the website it thinks it should be talking to. That means that it may not work with some VPN/proxy configurations. I would suggest using the 1Password extension within Safari if you need to use 1Password under these conditions:

    Use the 1Password extension to fill in Safari and apps on your iPhone, iPad, and iPod touch - 1Password Support

    I hope that helps. Should you have any other questions or concerns, please feel free to ask.

    Ben

  • Hi @macgordon. I am having the same problem that only started yesterday. Any logins via the IOS App is greeted with an error 'Failed to load page. The internet connection appears to be offline'. This only happens on cellular. I went and purchased the iPassword subscription thinking that would fix it, but no. Even when I change browser to safari it doesn't work. Can you help? Regards, Paul.

  • brentybrenty

    Team Member
    edited July 2017

    @flanagan65: I've had this happen when I'd gone through and disabled data for apps in iOS Settings > Cellular — and done this for 1Password as well without thinking.

    When you said "Even when I change browser to safari", do you mean that opening the Safari app doesn't allow you to load webpages either. That may be a deeper issue then. Did you perhaps disable cellular data completely? I'd definitely try restarting the device. Let me know what you find!

    ref: GRA-96792-668

  • Hi Paul, I' m afraid but only Ben's workaround by using iOS normal browser (please see above) is helping (in my case). It seems to be a VPN / proxy problem... (did you change anything st your system regarding this recently?). Unfortunately 1Pw internal browser is not usable for us while being online under cellular conditions ... Regards, Markus

  • brentybrenty

    Team Member

    @macgordon: Thanks for following up. Yeah, I've experience that as well. But, as far as I know, that should prevent both 1Password (which uses Safari as it's internal browser) and Safari itself from accessing the internet. That's why if one works but not the other only on cellular, it would seem to point to cellular data being disabled for the app.

  • Hi Gordon & Ben, it's very strange only because I do not use a VPN on my phone. I am from Canada and travel back and forth for work to Orlando all the time but coincidentally (or not) I arrived this past Wednesday in the US and suddenly the app doesn't work via cellular. Perhaps the cell company is causing issues. I tried the work around but do not even have the option to hit the share icon as it is greyed out. Thanks for the insight. I'll have to copy and paste login info while down here but as they say, it's first world problems :) Have a great weekend! Regards, Paul.

  • brentybrenty

    Team Member

    @flanagan65: Just to confirm, are you saying that...

    1. You are able to access websites with 1Browser in 1Password on a Wi-Fi connection,
    2. you're able to access websites in Safari on a Wi-Fi and cellular connection,
    3. but you're unable to access websites with 1Browser on a cellular connection;
    4. and you do not have iOS Settings > Cellular > 1Password disabled,

    is that correct? If so, does this happen with all URLs or just certain ones? It's possible that your provider is causing a secure connection failure because it is trying to filter traffic. Do you see the same result for both secure (HTTPS) and insecure (HTTP) sites?

    https://example.com
    http://example.com

    Thanks in advance!

  • Hi @brenty,

    You solved the issue. When I went to check the cellular data settings it was switched off. I've never had a reason to go in there before so no clue how that happened. Possibly a recent carrier setting update. Regardless, thank you very much for your help. Cheers!

    Paul

  • BenBen AWS Team

    Team Member

    Thanks for the update Paul. Glad to hear re-enabling cellular data for 1Password caused normal operation to resume. :)

    Ben

  • @Brenty: same on my site... great hint, thanks - that was the solution: cellular data has being disabled for the 1Pw app ... never went there (conciously... ;-) )
    @ all: Have a great weekend!

  • brentybrenty

    Team Member

    Excellent! Thanks for letting me know. You are most welcome! It sounds like you should be all set, but we're here if you need us. Cheers! :)

This discussion has been closed.