Escape not always exiting the extension

I'm not sure what level of nitpicky-ness you guys are looking for in this beta. This may be more fine-grained than you are focused on right now. But... if I do a CTRL-. to open the extension window, then a few characters to search for something, then to exit out of the search, hitting a second time will not exit the extension window. Ubuntu 14.04.5, 1password extension 0.8.4, Chromium 60.0.3112.78.


1Password Version: Not Provided
Extension Version: 0.8.4
OS Version: Ubuntu 14.04.5
Sync Type: Not Provided

Comments

  • Hmmm, apparently my escape characters didn't print here. It should read "...then ESCAPE to exit out of the search, hitting ESCAPE a second time..."

  • beyerbeyer

    Team Member
    edited August 2017

    @Pontoffel_Pock: This no such thing as "nitpicky-ness" during a beta in my opinion. Please don't hesitate to let us know what bothers you and I'll add it to our issue tracker. Odds are if you notice it, many people after you will as well.

    I'm in agreement that if the Esc key closes the popup in most locations, then it should do so in all locations. I've added this to our issue tracker, and we will be sure to get this resolved when we clean up our keyboard navigation. It might be a little while as we have a lot of development time dedicated to developing some much need features, but we will get to it when we can.

    As a tempory fix it looks like hitting Tab and then Esc will close the popup as intended.

    Thanks for taking the time to post your findings!

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

    ref: b5x-33

This discussion has been closed.