Extension not working - daily problem

Every day I come to work and my 1password extension doesn't work. Right-clicking brings up the usual menu options but the extension won't actually fill in any of my passwords/user names. The only thing that fixes the problem is rebooting my computer. I'm on Win 7 and Chrome 60.0.3112.101 (Official Build) (64-bit). This has been happening for a few weeks.


1Password Version: 4.6.2.625
Extension Version: 4.6.9.90
OS Version: 6.1.7601
Sync Type: dropbox

Comments

  • brentybrenty

    Team Member

    @boslaw: Are you using Native Messaging in 1Password 4 (under Help > Advanced)? That's a relatively recent addition to support Chrome and Firefox going forward. If you're using WebSockets currently definitely try that. Also, do you perhaps have multiple versions of 1Password installed? The browser extensions will only be able to talk to one or the other. Let me know what you fin!

  • I am using Native Messaging and I do not have multiple versions of 1Password installed.

  • Same problem is happening with Chrome on my Mac -
    1Password 6
    Version 6.8 (680015)
    Extension Version: 4.6.9.90

    This may be the flakiest software I've ever purchased.

  • matthew_agmatthew_ag 1Password Alumni

    Hey @boslaw,

    Every day I come to work and my 1password extension doesn't work. Right-clicking brings up the usual menu options but the extension won't actually fill in any of my passwords/user names.

    Sorry about the trouble with this, hopefully we can figure this out and get it back working for you.

    • When you notice filling no longer working what happens when you click on the 1Password extension button?

      If it does nothing then the connection from the extension to the app is broken but if it shows the 1Password mini then the connection is active but something is going wrong with filling on the page.

    • When filling stops working, are you always attempting to sign in on one particular web page or does filling fail on all websites until you reboot?

    Looking forward to hearing back.

    Best regards,
    Matthew

  • if I click the 1password extension button, I get a drop down (1password mini?) and usually see the option to fill in username/password. it just doesn't work - does nothing. It doesn't work on any site until I reboot

  • matthew_agmatthew_ag 1Password Alumni

    Thanks for the quick reply @boslaw,

    It sounds like the connection is up but something is going wrong with the extension itself. If you had a moment could you check the following to see if you see any errors?

    1. Go to the following web address in Chrome:

      chrome://extensions

    2. Enable "Developer mode" in the top right.

    3. Then under the 1Password extension you should be able to click a new link called "background page".
    4. Clicking this will open a new Window. When it opens please click "Console" at the top of the page.
    5. You may see errors or other messages printed here but they have no information about time.

      To enable this, please click the cog / settings icon in the top-right of the Window and then enable "show timestamps".

    6. Then right-click anywhere in the console area and choose "Save as..." and please send it via email to [email protected]
    7. You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the email and ensure that this issue is dealt with quickly. :)

    Looking forward to hearing back.

    Best regards,
    Matthew

  • FMT-36629-159

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hm, that log didn't really have much in it, @boslaw. Sorry about that. Could you reproduce the problem and then immediately create a diagnostics report from your Mac. Here's how: https://support.1password.com/diagnostics/?mac (You might want to download the troubleshooting tool first before reproducing the problem.)

    Attach the diagnostics to an email message addressed to [email protected]. In the subject line, put in that same ticket id that you got before like this: [#FMT-36629-159] so that it will be linked up properly. (For anyone else reading, this id is only for boslaw; if you're having a similar issue, please let us know. We may need diagnostics from you as well, but they will need to be sent differently.)

    Sorry for the additional request, but we should be in a better position to help with this additional report.

    Thanks!

    --
    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

    ref: FMT-36629-159

  • uploaded another console log. This ticket has 75 views - I'm guessing this browser issue is pretty widespread.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @boslaw I'm sorry, but this appears to be another log from the browser. Could you send a diagnostics report as I described above? It'll be most helpful to reproduce the problem and then generate the report immediately after so we can narrow down where to look in the logs that will be included.

    Thanks!

    --
    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • still experiencing daily problems. if the product can't fill in passwords & user names on websites then it really isn't worth $65 -- I can save passwords in an encrypted excel spreadsheet.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @boslaw. You're right that 1Password should be doing better for you; your situation is not normal and we need to figure out how to get things working smoothly. In order to do that, we really need that diagnostics report I asked for in order to understand what is happening. Most likely, there is some simple configuration thing that can be sorted out easily.

    While we review the report, it would also be helpful to know if you're seeing this in all your browsers or just Chrome.

    Thanks!

    --
    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • I have posted 2 diagnostic reports via email to the address provided. The problem persists with both Chrome and Firefox

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @boslaw Please review my instructions above. The diagnostics report is different from the Chrome console logs that Matthew requested initially. I have seen two sets of logs from the browser but no full diagnostics report yet. If you did send it already, perhaps it came from a different email address or something and got lost in the shuffle somewhere?

  • I sent the diagnostic report (not Chrome logs), both yesterday and today, to [email protected] with case [#FMT-36629-159] in the subject line

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Ah, I see them now, @boslaw. So sorry for the misunderstanding. For some reason our support system did not notify me that there were updates to the ticket. I will review and get back to you.

    --
    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

This discussion has been closed.