Login item won't "open and fill"

I have a login item (keyhole icon) that won't "open and fill" when I use the 1P Safari extension. It doesn't do anything and Safari just stays on the current page. I can use the credentials to login if I manually navigate to the authentication page. In that case, the 1P extension properly shows the login item and duly autofills the username and password fields. If I select "open and fill" while in the 1P app, the authentication page is opened but there is no autofill. I have tried editing the item and looking at the web form details to see if there is some secret sauce I am missing to no avail. I recently upgraded and was having some issues with 1P (problems connecting to 1P mini and the extension login window popping up with every web page) but things seem to have settled down. I believe this item was at least updated with a new password since the update.
Any clues here?


1Password Version: 6.8.1
Extension Version: 4.6.9
OS Version: OS X 10.11.6
Sync Type: iCloud

Comments

  • LarsLars Junior Member

    Team Member

    Hi @iphoneuser -- sorry you're having difficulties with one login bedeviling you. Can I ask what the site in question is? If you'd prefer not to say, I'm happy to take this to email, just let us know.

  • iphoneuseriphoneuser Junior Member

    Lars,
    Here is the URL;https://express2.praxair.com/Authentication/Login
    Not very scandalous.
    Thanks.

  • LarsLars Junior Member

    Team Member

    @iphoneuser - LOL! I didn't think it was a scandalous site, necessarily -- some users just want as little personal information publicly available as possible.

    So, I don't have an account at Praxair, but using dummy data, I was able to get pretty much everything to work (except for the successful login, of course). That makes me wonder if you need to update any of your components? It looks like you're using 6.8.1, but your extension appears out of date. Would you mind updating it to 4.6.10, restarting both Safari and 1Password, and giving it another go? Not sure that will make any difference, but it's the best starting place.

  • iphoneuseriphoneuser Junior Member

    That is interesting. Safari shows no update for the 1P extension. Checked on two different computers. I downloaded from your website but Safari won't install the extension.

  • brentybrenty

    Team Member

    @iphoneuser: Sorry for the confusion there! If you installed the 1Password extension from the Safari Extension Gallery, you may be a bit behind, as Apple needs to approve updates there — and often there's some significant lag. You can always install the latest version directly from our website though:

    https://agilebits.com/onepassword/extensions

    Note that Safari will still suggest installing the Gallery version instead, but you can opt out of that. Are you getting an error message when you try to install that? Sometimes Safari's extension database gets screwed up and you have to manually remove it first before you can install it again.

  • iphoneuseriphoneuser Junior Member

    Yes, I installed the extension through the Gallery. In the meantime, I tried navigating to the authentication page, and selected "Save New Login". I then used the extension to fill in the credentials. I did not get a "save" window and the 1P login item did not update. However, the "open and fill" command now works, at least on my laptop. I will try the same thing with my desktop (after the holiday - have a good Labor Day!). Thanks.

  • Hi @iphoneuser,

    I think things are working? If I'm wrong, if there is something still to resolve please do correct me, it just sounds like you're saying the issue isn't present now. We do want your Login item working properly for you though so if it isn't working as expected please do say.

  • iphoneuseriphoneuser Junior Member

    I checked my work desktop Mac this morning and now the login item is working, either via the Safari extension or choosing "open and fill" in the 1P app. The login item now shows a modification date of last Friday (9/1). Apparently, even though I did not get any kind of save dialog from the 1P extension when I selected "Save New Login" on my laptop, something was modified and presumably synced over to my work machine (preferences show a recent sync). Interestingly, on my laptop, where I tried the "Save New Login" route on Friday, the item modification date shows as 8/30.
    Strange, but I will take it as a win.
    Thanks.

  • LarsLars Junior Member

    Team Member

    @iphoneuser - thanks for the update. I’d like to be able to say I’m glad I helped you get things squared away, but since you appear to have solved the problem by yourself, I can’t hardly claim any credit for it. :-) However, around here, we’ve also learned to call a win a win.

    Have a great week, and thanks for being a 1Password user!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file