dropbox is resyncing and resyncing the files in the 1password dropbox folder.

Today I see that my dropbox account is constantly syncing and the files it is constantly syncing are the 1Password files (the .icn and .def files). I have the lastest version of 1Password. 1Password 6
Version 6.8.1 (681006)


1Password Version: 6.8.1
Extension Version: Not Provided
OS Version: 10.12.6
Sync Type: dropbox
Referrer: forum-search:dropbox is resyncing and resyncing the files in the 1password dropbox folder.

Comments

  • 30th August 2017. I have exactly the same issue today. Have tried stopping the sync process and restarting it. ReBooting my Mac etc. but as soon as I open 1Password it starts syncing again – constantly. Help please Agile Tech.

  • Let me chime in and say I noticed yesterday that Dropbox was going nuts syncing the same two files as noted by the extensions above. I killed 1Password 6.8.1 (681006) and the syncing stopped. Turned it back on and the syncing resumed. I even rebooted the Mac to no avail.

    Then I disabled Dropbox but noted that the modification time of the files were changing rapidly and continuously. I don't know how many times per second or minute they were being modified. I opened one file and found a clear text string name for an attachment.³ From that I could find the entry. It was an older entry that I hadn't changed for months. Trashing didn't help. I mailed the entry to myself and emptied the trash. Only then could I reenable Dropbox without it going crazy.

    Adding the exported entry back did not cause the problem to resume.

    Three other issues:

    1. When I trashed the entry and emptied the trash, two of the three files remained in the folder. A .icn file and a .tombstone file. Does this mean that 1Password isn't cleaning up properly, but slowly accumulating detritus with every entry I delete?
    2. When I mailed myself the entry, the attachment was not included. So reimporting the entry lost data. An export/import should be round-trip identical with no data loss.
    3. Isn't having attachment names in clear text a security issue? While mine was an innocent "Travel Benefits.jpg" I can imagine a filename of "My Impending Divorce Plans.pdf" that could get one into trouble. Clear text leaks information to an attacker and should never be visible.
  • LarsLars Junior Member

    Team Member

    Hi @TWSheppard @Andy_R and @dda -- This is unfortunately a known issue that a minority of users are experiencing. The problem appears to be related to the Agile Keychain format - can you each tell me if the vault keychains on Dropbox are in Agile Keychain format? If so, the best solution (both in terms of ease and increased security) is for you to follow these instructions on How to switch to the OPVault format from Agile Keychain. You'll wind up with a more modern, more secure and more robust keychain format that will be less susceptible to odd errors like this one. If you've got some really old devices in your lineup, you may not be able to do this -- and if you're already using OPVault, then this is obviously not your issue and not your solution. Let us know!

  • yep, I think so. That is, it says 1Password.agilekeychain .
    I'll try the opvault conversion. (Why doesn't 1Password do it that way in the first place??)

  • LarsLars Junior Member

    Team Member

    @dda - ahhh, that's a question that requires some back-story. Too much in fact for me to post the entirety of here. But briefly, the Agile Keychain format was developed along with 1Password 3 for Mac, way back in 2009-ish era. It was our step up from using Apple's keychain, and it was quite robust for its day. It also had the advantage of working on all of the commonly-used hardware of the day. Encryption is a very processor-intensive operation, and some of the problems of that time were that mobile devices (smartphones; the iPad didn't even exist yet!) just didn't have the CPU horsepower to do hardcore encryption without it significantly affecting usability (i.e. - speed of performing the operation). What would've worked fine (or at least tolerably) on a Mac or PC would sometimes bring a mobile device of that day to its knees, depending upon the device in question and the operation being performed. So we kept Agile Keychain as the default format for some time, even after we'd launched OPVault, because there were a lot of users who still had older devices in regular use that just couldn't handle the new format well. And on another note, 1Password for Android was the last client to be able to utilize OPVault (early last year). So, there are quite a few older Agile Keychains still out there. That's not a reason to panic; Agile Keychain is still secure...but with the advent of 1Password for Android's ability to use OPVault, and the fact that most of those older devices that were still in wide(-ish) use in 2012, 2013 had been retired by 2016, we switched all 1Password apps over to using OPVault as the format when creating new sync keychains.

    All of that said, this does not mean that we aren't going to try to fix this problem of constant sync loop with Dropbox/Agile Keychain combo that appears to have sprung up after the upgrade to 8.6.1. It just means A) we haven't nailed it down yet, and B) it's also a great chance for people who ARE having this problem and write in about it here, to switch to the more robust, secure and flexible OPVault. Thanks for the question, and let us know if you have continued problems with this. :)

  • @Lars Thanks for that. A nice cogent, succinct account. I'm going to go convert. Thanks.

  • @Lars How do I know if the conversion "took". I went through all the steps and dropbox did a syncing and stopped. But can I tell via Finder if it worked? (I'm asking because the relevant package in dropbox is still a .agilekeychain ??

  • LarsLars Junior Member

    Team Member

    Hi @dda -- the easiest way to check is to open your Dropbox folder on your Mac and look there for .opvault files. When you performed the switch-over, what location did you choose in your Dropbox file for the keychain to be written to? That's the best place to begin looking. You should be able to see the .opvault file. But if you can't find it, or still aren't sure, then I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/comment/387504#Comment_387504
    • Your forum username: dda

    That way we can "connect the dots" when we see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once we see the diagnostics we'll be able to better assist you. Thanks very much!

  • My files are .agilekeychain files. If I convert them to .opvault, can I still use 1Password.html inside the package?

    Since I've cleared the problem by deleting the problematic entry, I'm not anxious to convert unless there are some distinct advantages and I don't lose any functionality. I'm using 1Password 3.8.22 on one old computer that can't be upgraded beyond OS X 10.7.5.

  • @Lars Thanks, it worked the second time around; just a little confusion about checking the Tools-->Enable OP...

  • LarsLars Junior Member

    Team Member

    @TWSheppard -- ahh, you didn't mention that earlier, only that you were using 6.8.1. If you've got 3.8.22 on a Mac that can't be upgraded past Lion, then yes, you'll need to stick with Agile Keychain. 1Password 3 for Mac cannot and will never be able to read/use the OPVault format. So in your case, deleting the entry is likely the only way (other than waiting for a fix from our developers) to handle this issue.

    Question, though: have you used 1PasswordAnywhere at all lately? Because that should not work; Dropbox has not just deprecated but actually removed the APIs that were underpinning 1PasswordAnywhere. I'd be surprised if you were able to get it to work.

  • LarsLars Junior Member

    Team Member

    @dda -- Excellent! I'm glad that worked for you. :)

  • After I posted my comment I found out that Dropbox is killing off OS X 10.6-8 support on November 3rd so it looks like I won't be able to sync the 10.7 computer anyway. If I use ChronoSync to the Dropbox folder, will 1P detect the changed files, are you using the Dropbox API to detect updates?

    As for 1PasswordAnywhere, it still works fine on macOS Sierra and the old 10.7 computer, although I have to lock/unlock to see changes reflected. I changed a note on one entry using the app, and both the 10.12 and 10.7 .html files reflected that change.

    However, when I log into Dropbox and try to use it there, it doesn't work. Unfortunately, that's exactly where I wanted it to work in case I needed a password but didn't have my phone or Mac handy. I guess it's been a long time since I used it last, but I remember it being a life saver at the time. Any workarounds?

  • LarsLars Junior Member

    Team Member

    Hi @TWSheppard -- ChronoSync is a wonderful product, but it's never been an officially supported solution for sync. Some users in the past have reported success with it, but so much is dependent upon multiple variables with such a setup that we can't and don't offer support for it.

    However, now that you mention it, we DO have a "workaround" for 1PasswordAnywhere. :) I put workaround in quotes because what we have is actually what 1PasswordAnywhere was always merely a precursor to and pale shadow of, namely: 1password.com memberships. A 1password.com account gives you everything you remember/liked about the now-defunct 1PasswordAnywhere (a web-based way to securely access your 1Password data), and a lot more.

    Like what? How about a rock-solid sync engine created by the 1Password team and designed specifically for 1Password, instead of a generic third-party API broadly designed to sync everything from 1Password to spreadsheets to photos of your cat? How about zero-effort (for you) offsite backups of your 1Password data, and individual item history (restore to any previous state of an item, if something goes wrong)? How about unlimited access to ALL our 1Password apps (Windows, Mac, iOS and Android), including all future upgrades, for as long as you maintain your membership? How about Travel Mode and the increased security provided by your Secret Key? All of these things are possible with a 1Password account. You can read about them -- and a lot more -- at the above link. True, you need 1Password 6, which requires hardware capable of running it (so no OS X 10.7). But the benefits - at least in my opinion - outweigh the drawbacks of not being able to use it on older hardware. If you're willing to give up running 1Password on your 10.7-limited Mac, there's a whole new level of awesome waiting for you.

  • whayneswhaynes Junior Member

    Yesterday, I noticed that Dropbox was continuously syncing 4 files like "40B7D72B43DD4482A37250C76DC08E75.def", even though I wasn't doing anything.

    I put Dropbox syncing on pause on my main computer, but I can see from the finder that four files in 1password.agilekeychain/a/default/files are changing every few seconds, based on their modification date.

    When I stop 1password mini, the files stop changing. I left it off overnight, but when I restarted 1password mini this morning, the same files resumed changing again. Again, this is with dropbox syncing paused on this computer.

    What's going on, and how can I fix it?


    1Password Version: 6.8.1
    Extension Version: 4.6.9
    OS Version: 10.12.6
    Sync Type: dropbox

  • LarsLars Junior Member

    Team Member

    Hi @whaynes - I've merged your thread with an existing one, since you're not the only person to either experience this or report it; I hope that's OK. The problem appears to be related to Agile Keychain format only, and our devs are working on a fix. However, in the meantime, the best solution for it that you can take for yourself is to follow these instructions to switch to the OPVault format from Agile Keychain. This is NOT recommended if you have any devices that are still using 1Password 4 for Mac or earlier; version 4 had support for OPVault in its last few updates, but there were many updates and fixes in version 5. Version 3 had no support at all for OPVault because it predated that keychain format. However, if you're using only current (or more-recent) versions of 1Password on modern hardware, this is an excellent solution: the format is newer, faster and more robust. And it will solve that Dropbox sync issue. :)

  • budbud Junior Member

    I had the same problem with Dropbox syncing endlessly with my .agilekeychain vaults. Found this thread and switched them to .opvault. Seems to have fixed the issue. Also provided this same fix for family members. All started with the update to v6.8.1 yesterday. Thanks!

  • LarsLars Junior Member

    Team Member

    You're quite welcome, @bud! Glad that got you not just fixed, but updated as well to the newer keychain format! Cheers.

  • jtbaylyjtbayly Junior Member

    Thanks for this! Constant syncing was driving me nuts!

  • A dumb question...How do you know DropBox is continuely syncing i macOSX?

  • brentybrenty

    Team Member

    @jtbayly: Excellent! Thanks for the update. Glad that helped! :)

    @Starflyer: The Dropbox app can be set to show desktop notifications (I think that's what they're called) in macOS. I generally turn these off though, because I have a lot of stuff in Dropbox. :lol:

  • sjksjk oversoul

    Team Member

    How do you know DropBox is continuely syncing i macOSX?

    Dropbox Help center article:

    How do I get notified of changes in my Dropbox? – Dropbox

    Hope that helps. :)

  • I'm also having the continuous syncing issue. I have 1Password (6.8.1) and Dropbox running on 3 Mac's (and some iOS gear) and the issue shows up on all of them(I think only on the Macs not on the iPhones and iPad). I see that because the icon in the control pannel of the Macs is showing that dropbox is syncing all the time (sometimes every 2 seconds). It concerns the files 633D64A264074C0A8684BB1D5B60A1AA.def and .icn. I tried to switch to the OPvault format as that could, according to your support note, possibly be the cause of this issue, but in the help menu I saw that the OPvault option was already ticked, so I presume that I am already using it. I read that your developers are working on this issue, so I presume that the switch to the OPvault format does not always solve the issue. What is your advice: do I wait for an update or is there anything else I can do?

  • LarsLars Junior Member

    Team Member

    Hi @robtepas - sorry to hear you've hit this issue as well. However, just because that preference is enabled in 1Password doesn't necessarily mean that your existing keychains were written in OPVault format. The only ways to check that for certain are to either open the contents of your Dropbox and check the exact file path, or go to 1Password Preferences > Sync and look at the file path for each specific vault in question. It should contain the full path, including the format (.agilekeychain or .opvault). I think if you do that, you'll find you are indeed using an older Agile Keychain for sync. To be clear, we have yet to confirm a report of this happening with OPVault. If you find you are indeed using Agile Keychain as your format, please try the instructions provided earlier in this thread to switch over to OPVault, and see if that makes a difference for you. Let us know how you get on!

  • Thank you Lars, I will work on this and report back.

  • LarsLars Junior Member

    Team Member

    @robtepas - sounds good! Let us know if you continue to experience difficulties. :)

  • Hi Lars,
    I followed your advice and it did the trick! I saw that I indeed used the (old) wrong format and I changed it to OPVault, following your instructions provided earlier in this thread. Problem (almost) solved. It turned out to be not so easy to adapt my other two Macs to the new situation. The first one autodetected the change and proposed a repair. After confirming this I had to choose between merging the old and the new vault or canceling the action. I feared double records so I tried a workaround without succes. When I finally accepted the merge, it fortunately turned out that it did not result in double records. The third Mac (Macbook Air) reported that 1Password was damaged and proposed to delete it and download it from the appstore. This also worked out well. The iOS gear reported that: ‘the 1Password.agilekeychain could not be found in Dropbox. Synchronisation is switched off. A fault occurred’. This pop-up could be ignored and after doing that, 1Password seems to work again. So as we say in the Netherlands ‘End good, all good’. Thanks for your fast and excellent response!

  • LarsLars Junior Member

    Team Member

    @robtepas - Sorry for the little hiccup there. You would definitely want to turn off sync on ALL your devices before doing those steps. But I'm glad it sounds as things are working correctly now. To double-check, just visit Preferences > Sync in 1Password on each of your other Macs, and make sure the local data is being synced with the newly-created OPVault, not the old Agile Keychain or any other keychain. If the data looks to be consistent, you should be good! Thanks for the kind words, and have a great rest of your week. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file