I can not load the 1password extension on Firefox 55.0.3 on my MacBook Pro Running MacOS 10.12.6.

Every time I try to load it from the agilebits website i get a connection error. If I do the same with Chrome or Safari it works fine.


1Password Version: 6.8.1
Extension Version: Can't install it
OS Version: MacOS 10.12.6
Sync Type: Not Provided
Referrer: forum-search:1Password extension for use with FireFox will not download

Comments

  • I had the same problem using the same versions of OSX and Firefox. I think the secret was to install and open 1Password (if you haven't already) and use the drop-down menu to create your first empty vault. Then try the installation of the Firefox extension again.

    I hope this was the right sequence ! I tried so many different ways, then all of a sudden the thing worked fine !

  • Hi @Geoffzaw,

    If the error message is one that uses the phrase connection failure as I think it is then the following steps should allow you to work around the installation error.

    1. Visit https://agilebits.com/onepassword/extensions in a different browser (Safari, Chrome or Internet Explorer).
    2. Click the "Show all extensions" link.
    3. Click the "Install" button for Firefox.
    4. This will download an XPI file to your downloads folder or wherever this browser is set to download to.
    5. In Firefox visit the page about:addons and if needed select Extensions from the menu down the left hand side.
    6. Drag and drop the XPI file downloaded by step 3. onto this page.

    Basically this allows you to install the signed Firefox extension locally and bypass the issue. The most common cause we're aware of is anti-virus interfering with Firefox. It might not be the case here, it's just the one that has explained the most number of cases so far.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file