logout session keeps giving return status 0 after logout and no feedback

edited September 2017 in CLI

So, if I logout a session, I can repeat this command over and over and still get a return status 0.
Imho it should give a error.

I think it has something to do that the original session file isn't removed.

1Password Version: 0.1.1
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • srcodersrcoder
    edited September 2017

    Hmm, that was a quirky I guess, cannot reproduce this anymore :sweat:

  • cohixcohix

    Team Member

    @srcoder The signout command in reality just invalidates the current session with the server. We do cleanup of old session files the next time you sign in! If you have no valid sessions and run signout, you should get this error:

    > op signout
    [LOG] 2017/09/08 12:14:29 (ERROR) You are not currently signed in. Please run `op signin --help` for instructions

    Please let me know if you can consistently run the command and get 0 exit code when you should be getting that error :)

  • srcodersrcoder
    edited September 2017

    @cohix if you run op signout --session=VALIDSESSION you can run it as often as you want and still get a 0 status.

    eval $(op signin) and repeat op signout will always return 0.
    Also did signin/signout several times and the files remain.

    • edit: some wording
    • edit2: added singin/signout
  • rickfillionrickfillion Junior Member

    Team Member

    Thanks @srcoder. I've reproduced this here and have filed an issue (#239) so that we can get it fixed up.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file