1P team Custom templates not working

henengelhenengel
edited October 2017 in Windows Beta

Hi there,
I saw a few days ago that a new beta for Windows, version 6.8.465, has been released.
When trying out the new beta, I noticed that 2 issues still remain when using 1P Windows:

  1. I use 1P team and have created custom templates for my custom items, in this case: Invoices.
    At first, when I used to use 1P with special items, I created a new item of some category, changed it's fields and saved that item as a custom template. I started using 1P team because it supports custom templates. At the moment when I create a new item of my custom category on my MAC, all the correct custom item's fields show up correctly. However, when creating a new item in Windows I don't get the correct fields set in my custom template for that item.

  2. Not sure if this can be considered as an "issue", maybe more of a feature not fully supported yet, but the custom category image is not shown in 1P on Windows, as opposed to MAC where it does show the correct category image.

From some reason, there always seems to be differences between the Windows version and the MAC version.
Some features that have always been working on MAC, don't work on Windows for the past several releases.
As a Windows preferred user, it's very frustrating.


1Password Version: 6.8.465
Extension Version: Not relevant
OS Version: Windows 10
Sync Type: 1Password

Comments

  • bundtkatebundtkate

    Team Member

    @henengel Since you're asking about the 1Password 6 for Windows beta, I've gone ahead and move this over to the beta topic. I hope you don't mind. :chuffed:

    You will likely see some differences between 1Password for Windows and 1Password for Mac for the foreseeable future. In some cases, this is because features haven't been fully implemented on one platform or the other (this is more common with beta features). In others, it's because MacOS or Windows allow certain functionality the other operating system doesn't. We build 1Password native apps to take fully advantage of their respective operating systems and to integrate deeply with their platforms, so we will sometimes include features on one platform that we may not be able to fully implement (or include at all) on another. The menu structure of the 1Password extension on Mac comes to mind.

    That said, custom templates should display properly on 1Password 6 for Windows. Could you tell me the exact steps you took to get these incorrect templates to display on Windows? Where and how was this custom template created? The more detail you can include, the better. If you're able to include a screenshot of the blank template (on Mac is fine, if that's what's needed for it to display properly), this will help us create one of our own so that we can investigate. Thanks! :chuffed:

  • @bundtkate Thanks for your reply.
    I'll try to include as much info as I can. If you have any other questions or need more information just ask.

    "exact steps you took to get these incorrect templates to display on Windows"
    I didn't do anything special. After updating just tried to create a new custom invoice item, and noticed that the fields in the template are not identical to what I set.

    "Where and how was this custom template created?"
    Login to my 1P vault online ==> In the menu on the right I went to "Templates" ==> "New Template" ==> Created the template and saved.

    Screenshots:
    New custom invoice item template - MAC

    New custom invoice item template - WEB

    New custom invoice item template - Windows

    After sending all this info to you, I tried to make a video screen record of the whole process I did to create a new category template and create a new item of it.
    When doing so, I saw that when I created the new item of the new template, it worked OK and the fields are correct.
    Still, the old "invoices" category I created and it's template still doesn't work.

  • @bundtkate If I delete the current custom "invoices" category template and recreate it, will all the current items in "invoices" also be deleted? If not, will I be able after recreating the custom template "invoices" to associate the current invoice items to the new recreated one?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @henengel,

    Thanks for the details, that helps.

    Think of custom template as blank items with a defined structure that you're cloning, it means any changes you make to the original template will never affect the existing items as they are not really connected to the original template. So, deleting the template will not affect your existing items at all, they'll remain in your 1Password database. The difference is that 1Password will not be able to let you clone items based on the non-existing template.

    However, there is a bug on Windows where it still shows the deleted templates in the New Item list, this will be fixed in the near future.

    ref: OPW6-1228

    After updating just tried to create a new custom invoice item, and noticed that the fields in the template are not identical to what I set.

    That sounds and feels like 1Password for Windows cannot find the template, so it incorrectly pulled from the last item's template data locally. This is a known bug that'll be fixed by getting rid of the deleted/missing templates from New Item list and not pulling the last item's template (part of why we're beta testing this).

    Can you provide a screenshot of your New Item list? I wonder if there is a duplicate or something that's causing 1Password to get confused.

    If not, will I be able after recreating the custom template "invoices" to associate the current invoice items to the new recreated one?

    You won't be able to "migrate" the old items to a new template like that, you will have to re-create the data manually. They're two separate templates with different field IDs that won't match.

    Not sure if this can be considered as an "issue", maybe more of a feature not fully supported yet, but the custom category image is not shown in 1P on Windows, as opposed to MAC where it does show the correct category image.

    There is no support for custom template icon, so what you're seeing on Windows is the correct behavior, there should only be the generic template icon.

    Can you clarify what you're referring to? In the screenshots you're attached, both macOS and Windows apps did the right thing, it showed the generic template icon. The web app is incorrect, it should not show that reward icon.

    In addition, the item list is also incorrect for custom templates in all 1Password apps, they should be the generic one by default.

    From some reason, there always seems to be differences between the Windows version and the MAC version.

    In this specific case, custom template is still a beta feature on 1Password.com Teams, there will be issues across platforms until we figure out how Custom Templates should work. We do not have a clear specification on how this should all work, that's why it is in beta, so we can figure out how to move forward with a better design.

    The issue is that any custom template items you've created a long time ago would stay like that forever, regardless of what changes you make to the templates on 1Password.com.

  • @MikeT

    Can you provide a screenshot of your New Item list? I wonder if there is a duplicate or something that's causing 1Password to get confused.

    As you said, there is the bug where deleted template are not removed from the "New item" list.
    In the screenshot below, "test" has been removed, and "invoicesNew" is a template that I created to see if I can associate the existing invoices with a new category (also currently deleted).

    You won't be able to "migrate" the old items to a new template like that, you will have to re-create the data manually. They're two separate templates with different field IDs that won't match.

    That is a really big issue for me since the invoices have a lot of information, and recreating them from scratch will be a lot of work!
    This means that there is no point in creating a new template based on the old one.
    So what do you suggest we can do in order for me to be able to create new invoices based on the correct template?

    In addition, the item list is also incorrect for custom templates in all 1Password apps, they should be the generic one by default.

    Not sure exactly what you meant.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @henengel,

    So what do you suggest we can do in order for me to be able to create new invoices based on the correct template?

    Just to be clear, did you ever deleted the original Invoices template and recreate it with the same name in the past?

    1Password should be picking up the updated template automatically in real time, which means you should still be able to create new items based on the Invoice template stored on 1Password.com.

    Not sure exactly what you meant.

    In your screenshot, all of the Invoices item have a custom icon with a $ sign on it, did you add that manually or did it came as part of the template? We don't have support for template icons, so I'm trying to narrow down where the original template came from.

  • Just to be clear, did you ever deleted the original Invoices template and recreate it with the same name in the past? 1Password should be picking up the updated template automatically in real time, which means you should still be able to create new items based on the Invoice template stored on 1Password.com.

    No, I haven't deleted at all the Invoices template at any time. I just created the same template again under a new name "InvoicesNew" to see if the item can be moved between categories (that was before you told me that it isn't possible).When seeing that it wasn't possible, I deleted "InvoicesNew".
    Is mentioned here before, I can create new Invoices properly, based on the correct template only on the web, and on MAC.
    Not on Windows.

    In your screenshot, all of the Invoices item have a custom icon with a $ sign on it, did you add that manually or did it came as part of the template? We don't have support for template icons, so I'm trying to narrow down where the original template came from.

    I did add those icons manually when created on my MAC.

  • ... so I'm trying to narrow down where the original template came from.

    Also forgot to mention, maybe I can help you with this question.
    As I said here before, before using 1P team, I used the standard 1P.
    When using standard 1P, in order to use templates, I would take an existing template (in this case I use the "Membership" template), changed its field and save that item as a template. When creating a new invoice I duplicated the template item and filled out the details.
    When moving to 1P team, I created the Invoice template and manually created the invoices with the new template from scratch.
    Now if I'm correct, when creating a new invoice on Windows, for some reason I get the Membership template (again not sure why since I created the invoice items from scratch), but still, that is what I get.
    Just wanted to make all this clear...maybe it will give you an idea of what's going on.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Henengel,

    Now if I'm correct, when creating a new invoice on Windows, for some reason I get the Membership template (again not sure why since I created the invoice items from scratch), but still, that is what I get.

    Yea, that's the weird part, where is it getting it from...as we are pulling the templates straight from the server.

    Let's dig deeper into this, could you send me your 1Password diagnostics report; please use this guide to generate the 1Password diagnostic report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • @MikeT
    Hi Mike,
    I've sent the email with the information you requested.
    Can you check if you got it?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @henengel,

    Thanks, we got the report and will reply to your email as soon as we figure out what's going on.

    ref: XCU-91969-288

  • @MikeT Great, looking forward to your reply...
    Thanks for your help...

  • bundtkatebundtkate

    Team Member

    Thanks for your help in improving things, @henengel! You feedback is always appreciated. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file