1Password extension not working with Firefox 56.0.1

vulgrisvulgris
edited October 2017 in Mac

Hello guys,

now that I'm running 1Passwort under High Sierra I'm not able to use the Firefox Extension.
Under Firefox 56.0.1 the button is grayed out and won't work properly.

To be honest it is doing absolutely nothing.

Are the any suggestions to solve this problem?

Thank you in advance for your feedback.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Mac OS High Sierra
Sync Type: iCloud

Comments

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @vulgris! I'm sorry to hear you're having trouble with 1Password's Firefox extension just now. You didn't provide us with any information other than your Firefox and macOS version, so I don't know what else you might be running. But would you please make sure you're using the latest 1Password for Mac (6.8.3), and then delete the 1Password extension from Firefox, restart FF, and re-download and install the latest Firefox extension from our extensions page. Let us know if that works for you.

  • Hello, I have the same problem. When I want to download the extension I get the error that the file is corrupt.
    FF 41.0.1 (latest version)
    OS 10.12.6
    latest Version of 1password

    Any idea?

  • Hello guys,

    some more information to my setup:

    FF Version: 56.0.1
    OS High Sierra 10.13
    1Passwort 6.8.3 (6830004)
    1Passwort Extension 4.6.11.91

    I restarted my machine yesterday... and suddenly it works!

  • LarsLars Junior Member

    Team Member

    @vulgris -- you'd be surprised how often a simple restart results in things just sorting themselves out. Thanks for the update, and let us know if you need anything further.

  • LarsLars Junior Member

    Team Member

    @liebling -- you're using too old a version of Firefox to use the current extension. Please update your version to the current Firefox, which is 56.0.1, not version 44.

  • I am running into the same issue now also. The plugin is grayed out. It use to be if I switch in firefox - advanced to Native Messaging it would work agian, however it seems that option is removed in FF 56.0.1

    Windows 10
    Firefox 56.0.1
    1password plugin 4.6.12.90

    Chrome works fine

  • LarsLars Junior Member

    Team Member
    edited October 2017

    Hi @theseizure - please try deleting the 1Password extension in FF, restarting your Mac, and re-installing it.

    edited to add: ah, I see you're using Windows; this is the Mac forum, which is why I missed that and told you to "restart your Mac." The reason we keep these separate is that often the instructions (and the issues) are quite different between platforms.

  • @Lars

    Hi lars, I cannot restart my Mac since i stated I have windows 10. but that's okay, I'm sure you're just doing the standard cut and paste you tell everyone.

    For everyone else, Launch 1password the desktop version whether it's v4 (private vaults) or v6 (cloud option). Go to the Settings (Gear Icon, or F10) - OPTIONS - Advanced

    Check to enable "Native messaging for Firefox" and the plugin will start working again.

  • edited October 2017

    @Lars No worries, sometimes it's hard to please us tough crowd when troubleshooting issues. Plus probably my fault i stumbled on the mac forum, but i googled for Firefox 56.0.1 and 1password and this was top link.

    I think you should put that fix somewhere visible, I imagine others might have this issue as Firefox has transitioned everyone to x64 stable which has native messaging and no longer will work with websockets which I believe is what 1password desktop is using by default?

  • LarsLars Junior Member

    Team Member

    @theseizure - it's not so much cut-and-paste as it is not expecting to see Windows questions on the Mac board (as I edited my post to reflect, above), as well as the fact that with this issue in particular, both of what I mentioned previously (as you see in the thread above) is helpful in solving the issue for many users; enough so that I want to make sure the easy stuff is tried before we go down a rabbit hole.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file