Installer on MAC Download,Update,Download,Update loop

I have a MacBook that I installed 1P on and about two months ago had to manually re-download the installer because it got into a loop of downloading the updater, getting to the "Update and relaunch" button, then when I pressed the update button it would download again. This would get into a loop and I couldn't get it out of that loop.

Now I have been running 6.8.2 for a while and it is in the same loop trying to update to 6.8.3. I do not have this problem on my other family MacBooks nor my other iMAC's.

What is causing this issue and how can I solve it permanently?

1Password Version: 6.8.2
Extension Version: N/A
OS Version: 10.12.6
Sync Type:


  • Hey @rajkej

    Just to clarify, do you have the Mac App Store version of Evernote or the direct download version?

  • Also, check if you have any security software running when you're trying to update. If you do, try disabling it temporarily to update. I don't think this fixes the underlining issue, but to get you going you can download and install 1Password from

    I hope that works =)

  • LarsLars Junior Member

    Team Member

    @rajkej -- thanks for writing in, and sorry to hear you're continuing to have this trouble on your MacBook. Without taking a closer look, I'm not entirely sure what might be happening, but can you please try the steps outlined in the AgileBits Proven Solution from this thread and let us know if that works for you? Thanks.

  • Thank you for the replies. I originally purchased 1Password directly from Agile Bits and do not have the apple store version.

    Good idea about the security software check as this computer has different software on it. I did disable the security software and the problem persisted.

    I'll try the link Lars provided next.

  • So Lars' request worked but is the same/similar procedure I performed in the past. I don't recall if I rebooted between the empty trash and re-install last time however. So if that was a key factor then I definitely did it this time even though I didn't last time. Hopefully this issue will stop occurring. But if it does occur again I'd like to debug it further as to prevent it from happening again. Thanks!

  • LarsLars Junior Member

    Team Member

    @rajkej - I'm glad to hear that worked for you. The reason this may have persisted over more than one instance is that you have to completely remove the old version before you install the new one. I'm not sure what you did last time, but if you installed over an existing version, that's not going to remove the problem, only solve it temporarily until next upgrade. Let's hope this time is permanent. Let us know! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file