Firefox Nightly 58.0a1 (Mac) cannot connect [update to latest build of Firefox Nightly to resolve]

When loading Firefox Nightly (version 58), the extension icon is nonfunctional and appears greyed out, pulsing the normal color every few seconds, but still not working. The extension works perfectly in Firefox Beta (Quantum, 57). I have tried restarting and using 1Password and extension beta builds; none of these worked.

1Password Version: 6.8.3-BETA1
Extension Version:
OS Version: macOS 10.13 Beta (17A362a)
Sync Type: 1Password Account


  • brentybrenty

    Team Member

    @hypernova1912: Thanks for letting us know! We'll see if there's something we need to tweak there, or if we're just at the mercy of another prerelease Firefox bug. Cheers! :)

  • Looks like I reported the same problem in the Mac discussion board ( There’s a lot of XPC failures in related to 1Password.

  • Hi @hypernova1912 & @robinwhittleton,

    I've just updated to Firefox 58.0a1 and everything is working fine here. I'm not saying you're not experiencing issues just that it doesn't seem to be a fundamental issue with the extension.

    If one of you are happy to do so could you do the following for me please.

    1. Restart your Mac.
    2. Launch 1Password and unlock.
    3. Launch Firefox Nightly. Confirm it is up to date and the extension is broken.
    4. Create a diagnostic report and send it in.

    This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post the ticket ID that will allow us to locate the diagnostic report and we can see what it tells us.

  • HypoLuxaHypoLuxa
    edited October 2017

    Same Issue here, created a new profile and everything, still happens.

    Diagnostic report submitted

  • edited October 2017

    Restarted and no luck. I’ve generated a diagnostics report from my Sierra machine and sent it in, got given a ticket id of #QKN-17661-714. If there’s anything more I can do let me know.

    ref: QKN-17661-714

  • Restarting did not solve the issue. My diagnostic report has been sent under ticket ID #HMX-88371-392. Please let me know if there's anything else I need to do.

  • @hypernova1912, @robinwhittleton & @HypoLuxa:

    We've discovered the cause. It seems as part of a rebranding Mozilla (un)intentionally altered the bundle ID associated with the Nightly version and so 1Password for Mac no longer recognises it as a known browser. For reasons I'm not sure of my own up to date copy is still showing the old bundle ID hence why it works for me at the moment. Given the FirefoxFirefoxNightly naming slip we're getting confirmation this change was intentional and then will need to update our whitelist. For now 1Password will refuse a connection from Firefox Nightly but both Firefox and Firefox Developer Edition will work.

    ref: OPM-5336

  • Even though it's not working for me at the moment, opening the bundle and checking info.plist with Xcode shows the bundle name as FirefoxNightly. FirefoxFirefoxNightly is nowhere to be seen.

  • BenBen AWS Team

    Team Member

    The FirefoxFirefoxNightly thing is definitely a bug that Mozilla have acknowledged here:

    We're still waiting for an answer as to if the change to the code signature ID is intentional or not.


  • Ah, that makes sense. Thanks for digging!

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    We are working with our contacts at Mozilla to determine what, if any, action we need to take to work with the new Firefox Nightly. It is not unusual for nightly builds of any software product to experience bugs early in the release cycle. That said, we also need to be thorough and cautious to make sure that we allow the browser's release process to breathe. If there are changes we need to make, we will definitely do so once we understand what is needed. And if there are issues on the browser side, it's important that we allow them time to fix them before we jump to any conclusions.

    This is what these builds are for, and it's great that we have 1Password users that are passionate enough about their browser of choice that they opt for cutting edge releases. This has helped us catch issues early in the release process in the past, but it also means sometimes being patient when issues crop up.


    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • Resolved in latest nightly update! 1password is working again.

  • brentybrenty

    Team Member

    Awesome! Glad to hear it's working for you again. :chuffed:

  • Hates_Hates_
    edited October 2017

    I am having the same problem. Icon flashes and no way to open it.

    [this comment was originally posted in: 1Password extension failing on Firefox Nightly].

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @Hates_ Was Firefox working for you previously? If so, be sure to update to the latest Nightly release. It looks like one of the planned changes had more side effects than they were anticipating, but the new update should be in better shape. Let us know how it goes.

  • Latest nightly seems to have resolved the issue. Thank you :)

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    :+1: Glad it helped!

  • edited October 2017

    I'm using Firefox 56.0.2 (64-bit) and my extension doesn't work. It keeps flickering, also I have several log messages:

    default 09:45:32.414900 -0200   OnePasswordNativeMessageHost    683005 [EXT_NMH:(Main Thread):<OnePasswordNativeMessageHost: 0x7ffa7160dec0>] E run | Launched
    default 09:45:32.416520 -0200   OnePasswordNativeMessageHost    683005 [EXT_NMH:(Main Thread):<OPNMXPCConnection: 0x7ffa716151e0>] E connect | Attempting to connect
    default 09:45:32.451965 -0200    Bundle passed static code validation: file:///Applications/
    default 09:45:32.473764 -0200    MacOS error: -67063
    default 09:45:32.475136 -0200    MacOS error: -67063
    default 09:45:32.476326 -0200    MacOS error: -67063
    default 09:45:32.478728 -0200    683005 [EXT:(Secondary Thread 0x7fbeb9b942d0):<OP4NativeMessageClient: 0x7fbeb9f1baf0>: pid:876 extId:(null) browser:Firefox] E handshakeWithManifest:reply: | Failed to verify the connection: manifest:{
        OPNativeMessageClientArguments =     (
            "/Users/myusername/Library/Application Support/Mozilla/NativeMessagingHosts/",
            "[email protected]"
        OPNativeMessageClientBrowserPID = 876;
        OPNativeMessageClientBrowserURL = "file:///Applications/";
        OPNativeMessageClientURL = "file:///Applications/";
        OPNativeMessageClientVersion = "6.8.3";
    } : NMStatic:1 NMRuntime:1 BRuntime:0 JSON:1
    fault   09:45:32.479116 -0200    <NSXPCConnection: 0x7fbeae947050> connection from pid 1137: Warning: Exception caught during invocation of received message, dropping incoming message and invalidating the connection.
    Exception: *** -[__NSCFString stringByAppendingString:]: nil argument
    *** -[__NSCFString stringByAppendingString:]: nil argument
        0   CoreFoundation                      0x00007fff2ca220fb __exceptionPreprocess + 171
        1   libobjc.A.dylib                     0x00007fff53310c76 objc_exception_throw + 48
        2   CoreFoundation                      0x00007fff2cab3bfd +[NSException raise:format:] + 205
        3   Foundation                          0x00007fff2ea54aa0 -[NSString stringByAppendingString:] + 104
        4 0x0000000109376a09 + 920073
        5 0x00000001093756ff + 915199
        6   Foundation                          0x00007fff2ed0dddb __NSXPCCONNECTION_IS_CALLING_OUT_TO_EXPORTED_OBJECT_S2__ + 12
        7   Foundation                          0x00007fff2ed0c5a8 -[NSXPCConnection _decod<…>
    default 09:45:32.479507 -0200   OnePasswordNativeMessageHost    683005 [EXT_NMH:(Secondary Thread 0x7ffa71502520):<OPNMXPCConnection: 0x7ffa716151e0>] E connect | XPC connection was invalidated or interrupted
  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    The logs indicate that Firefox's runtime code signature is invalid. Can you try quitting and relaunching Firefox and see if that helps?

  • I tried, several times. I'll try to reinstall it...

  • I reinstalled Firefox and 1Password, but nothing... weird...

  • Even on Firefox Beta it doesn't work!

  • I removed all 1Password files and reinstalled, re-sync, nothing... same messages on console.

  • @terciofilho,

    As you've posted in two threads and your original post seems to indicate you are running the stable version of Firefox we will continue the conversation in the other location. We'll leave this thread to the subject of Firefox nightly where the issue was with a particular build of Firefox, one that Mozilla corrected with their next release.

This discussion has been closed.