Crash on iPad Pro with WLAN sync [Disable macOS firewall]

edited December 2017 in iOS

I just bought an iPad Pro, and am trying to set up 1Password on it. Exact process:

  1. I have my Mac sitting with the 1Password “WLAN Server” tab open under Preferences.
  2. On my iPad, I launch 1Password.
  3. I tap “WLAN Server” under “Already using 1Password?”
  4. I tap my Mac in the list.
  5. I input the passphrase showing on my Mac.

After this, as soon as I tap ”Next”, the app immediately closes. The next time I open the app, it says that ”1Password Unexpectedly Quit”. This happens every single time I try.

Is this a known issue that might be being worked on?

1Password Version: 7.0.3
Extension Version: Not Provided
OS Version: iOS 11.1.2
Sync Type: WLAN


  • BenBen AWS Team

    Team Member

    Hi @rhoot

    Just to be clear: is it 1Password for Mac or 1Password for iOS that is crashing? Also, either way, could you please let us know what version of 1Password for Mac and what version of macOS you are using?

    I do not believe this is an issue that we’re aware of.

    Thank you.


  • rhootrhoot
    edited December 2017

    It’s 1Password on iOS that’s crashing. I’m using 7.0.3 on iOS and 6.8.4 on the Mac.

    Edit: The Mac is running macOS 10.12.6, and the iPad is running iOS 11.1.2.

  • brentybrenty

    Team Member

    @rhoot: Thanks for following up. Indeed, I'm not able to reproduce that here. I wonder if the app is simply damaged. If you delete 1Password for iOS (backup your data first) and install a fresh copy from the App Store, are you still seeing the same issue?

  • Indeed I am. And I wouldn’t expect corrupt data either, since this is a fresh install on a new device.

  • rhootrhoot
    edited December 2017

    Oh, I actually managed to figure it out. I realized that I always had to press Next twice, cause nothing happened after pressing it just once. So I tried pressing it just once and then waiting. After about a minute, an error showed up saying the connection timed out. Turns out I had the firewall turned on in my Mac’s system settings, so my iPad couldn’t connect to it. The crash was from trying to sync while it was still trying to connect.

    Once I turned off the firewall it works. Thanks for the help nonetheless!

    Edit: Although might I suggest some kind of indicator while it’s trying to connect?

  • BenBen AWS Team

    Team Member

    Thanks for the update, and for the feedback! :) Glad to hear you were able to get it working.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file