Webinterface Login not Working with Safari

Hej there,
I just tried to log in to our 1password-team-webinterface to add a vault. Unfortunately on Safari (11.0.2) I just got the following error-message after the first login-attempt:

Cannot sign in.
Failed to generate valid signing keys after 5 attempts. <Signature failed verification>

At first it sounded to me, like someone else tried to log on to my account, but when I tried to login with Chrome Canary it worked on first try. What does this rather scary sounding error code mean? And is there still a problem with my account? (Activity log looks unsuspicious)

If thats of any importance: I did not have my Secret-Key handy so I just created a new Emergency Kit with the 1pw desktop app.

Cheers
Dominik


1Password Version: 6.8.5
Extension Version: Not Provided
OS Version: OS X 10.12.6
Sync Type: Not Provided

Comments

  • robrob Agile Customer Care

    Team Member
    edited January 2018

    Hi, @dd_dm.

    Thanks so much for the report! We're seeing this come up about 1 out of 200 times in Safari 11. It's related to a bug in Safari 11 that can generate bad signing keys. We added some code that was supposed to try 5 times before failing (hence the "5 attempts" message), but it turns out that if one attempt fails the other four attempts will fail too, so it's not as rare as we were hoping it would be. I'm hoping to get this patched up soon, but in the meantime, if you simply reload the page and try signing in again, it should work without a problem. There is not a problem with your account.

    I'm sorry for the confusion and scary message! Please let me know if I can help with anything else. :)

  • Hi Rob,
    thank you very much for the fast explanation!
    Cheers
    Dominik

  • brentybrenty

    Team Member

    Glad Rob was able to help. I know he's been investigating this. I've encountered this too, and reloading the page has always helped, so it's worth trying. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file