Every time I open Safari on Mac 1Password authentication is required

Please can you help as this is really annoying. I am running 1Password v6.8.5 and every time I launch Safari, I am presented with the authentication numbers from Agilebits.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Me too. 1Password 6.8.5 on macOS 10.13.12 and I get prompted for authorisation for the 1Password Safari extension every time I open Safari. Only happened after the recent 1Password path. Pls fix.

  • Same with me:

    • macOS = 10.12.6
    • 1Password = 6.8.5
    • 1Password extension for Safari = 4.6.12

    Every time I open Safari I get prompted for authorisation. I click the authorise button but it has no effect.

  • brentybrenty

    Team Member

    Thanks for getting in touch! I'm sorry you're having trouble getting Safari authorized.

    I click the authorise button but it has no effect.

    @seanspicer: What do you mean by "no effect"?

    Only happened after the recent 1Password path.

    @DourScotsman: Can you tell me what you're referring to here?

    @xmaspyn: Are any of you resetting or otherwise clearing data from Safari? The authorization is either being saved and wiped out, or something is preventing it from being saved at all. Thanks in advance!

  • @brenty: some more detail

    • I confirm that no Safari sessions are running and launch Safari; a new Safari session
    • my homepage preference is www.google.com, but Safari immediately redirects to https://agilebits.com/browsers/auth.html and displays an Authorisation Code
    • 1Password extensions displays a 2nd window with an Authorisation Code that matches the one displayed in Safari
    • I click the 'Authorise' button in the extension window
    • Safari proceeds to https://agilebits.com/browsers/welcome.html, confirming that 'The 1Password Extension is ready to go'
    • While this Safari session is running, I can now browse normally, open new Safari tabs and windows and am NOT prompted for any 1Password Authorisation Codes
    • I quit Safari, ensuring that all Safari Windows have exited
    • I launch Safari again and the above repeats

    I have uninstalled and reinstalled the 1Password extension, as well as Cleared my Safari History, neither of which solved this issue

    Many thanks

  • brentybrenty

    Team Member

    @seanspicer: Thanks so much for clarifying! That's perfect. I just wanted to make sure we aren't going down the wrong rabbit hole here. The good news is that everything except the very last bullet point is perfectly normal.

    Just to clarify, how have you "cleared" Safari history? Please be specific. That sounds like it may be the thing that's causing this in the first place. Also, which method are you using to quit Safari — ⌘ Q, ⌘ ⌥ Q? The latter will mean that the next time you open Safari it will start with a completely new session — no restored tabs/windows.

    Worst case scenario, if everything in in 1Password is working correctly (it sounds like it is), it may be necessary to reinstall Safari, but that's a bit extreme so I'd like to eliminate other things first. Thanks!

  • how have you "cleared" Safari history?

    Selected: Safari --> Clear History ... --> [all history] --> Clear History

    which method are you using to quit Safari

    ⌘ ⌥ Q

  • brentybrenty

    Team Member

    @seanspicer: Thanks! What happens if you authorize Safari, quit using only ⌘ Q, and then open it again? Are you having to re-authorize?

  • I have the same issue :( Quit using ⌘Q

  • brentybrenty

    Team Member

    @sr19: Thanks for getting in touch! Recently we've been hearing from some folks having this issue again, and have found that “AdBlock” software can prevent Safari from saving the authorization token to allow it to persist across sessions. Be sure to disable anything like that so it can be saved, or you'll need to authorize it every time you open the browser. Cheers! :)

    ref: YCU-28489-172

  • I am having the same problem.
    Safari Version 11.0.2 (12604.4.7.1.6)
    macOS Sierra (Version 10.12.6 16G1114)

  • brentybrenty

    Team Member

    @jbanchy: Did you try what I suggested? You'll continue having that same problem unless Safari can save the authorization — and not have it wiped out.

  • @brenty thank you for feedback. Indeed I do use uBlock & Ghostery. So I disabled all the extensions except 1P in Safari to test.. Still the same: after ⌘Q restart 1P requires reauthorization.
    Safari v11.0.2 (12604.4.7.1.6)
    1P v6.8.5 (685004)

  • brentybrenty

    Team Member

    @sr19: It doesn't necessarily have to be an extension. It could be an app you've installed, or you could simply be clearing something yourself. Unless the authorization can be saved permanently on your system, it will only work during the current session. The only other possibility is that Safari itself is broken, but that's a bit of a process to try to reinstall it, so I'd encourage you to take a harder look at what else you're running that could cause this. 1Password has no control over whether or not Safari can save the authorization, or whether it is retained afterward. Let me know what you find.

  • I normally quit using the Quit Safari option from the Apple Menu at the top. It show that it does a ⌘Q. I have also tried the ⌘Q directly. It does not fix the problem. The only extension I have loaded is 1Password. Is there something else I am supposed to try?

  • daltondalton

    Team Member

    @jbanchy: As brenty mentioned, there may be something other than an extension interfering with Safari. Do you have any other software running that may prevent Safari from saving the 1Password authorization?

  • I have no idea what to look for. You are asking this question "Do you have any other software running that may prevent Safari from saving the 1Password authorization?" If I knew that, I would not be asking for help. What could prevent Safari from saving 1Password authorization? Why is it not happening on my two other browsers, Chrome and Firefox?

  • I decided to try an old Microsoft Windows technique. Reboot. I normally don't reboot my MAC very often. So, I open the Safari, did the authorization and rebooted right away. It came up working.

  • LarsLars Junior Member

    Team Member

    @jbanchy - if I had a dollar for every time a simple reboot solved a vexing problem, I'd be...well, I dunno about rich, but able to buy a few more toys. :) In general, Macs tend to be more stable than PCs in my experience, but with any computing device, the longer it's left running without a restart, the more likely it becomes that some background process will fail or cache will get stuck or any number of other issues.

    There are certainly problems that can occur with 1Password that a restart won't solve -- but we usually are aware of these and know how to recognize and address them. But when someone comes to us with a truly strange issue that doesn't make sense and we've never seen it before, even though I know it's a cliché, a restart is often the first thing we suggest because of how often it simply works. Glad it worked for you, but definitely let us know if the problem recurs or you notice anything else. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file