Auto lock not working, Windows, 7.0.519 [Caused by nVIDIA Geforce Experience Overlay]

MirtmaMirtma
edited March 2018 in Windows Beta

As the title said. I was using 1Pass 4 as I liked that Chrome or Firefox extension did log out of 1Pass no matter if I was working on a computer. After the selected time it locked. (that's why I migrate from Dashlane - there it logged you out if you didn't work with computer for 15 minutes or more). Now I tried ver. 7 (hoping that it'll be also a standalone version because ver. 4 is getting old.). And it doesn't lock at all. Leaving computer is like sharing all passwords to anyone who comes by.


1Password Version: 7.0.519
Extension Version: 4.6.12.90
OS Version: Windows 10 64 bit
Sync Type: Not Provided

Comments

  • Just out of curiosity, what is your timeout setting in settings? (Locks for me, of course). Iirc correctly, dashlane was also an inactivity timeout.

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 2018

    Hi @mirtma,

    Thanks for writing in.

    As AlwaysSortaCurious stated, check and adjust your security settings within 1Password. 1Password does not starts its auto-locker timer until you stop using your mouse and keyboard completely.

    That means if it is set to auto-lock at 10 minutes, once you stop using your keyboard/mouse, 1Password starts it timer and once 10 minutes passes, 1Password will auto-lock. It is not related to the last time you used 1Password, a lot of folks got this mixed up.

    If you leave your computer and you're in a public environment, locking down 1Password isn't the only thing you need to do, you have to lock Windows down for the best security. Nothing stops someone from going to your computer, install some random malware that can then compromises your system and as the result, 1Password or any other security tool can be compromised.

    1Password will lock with Windows lock as an option as well (enabled by default) and the shortcut is Win key + L.

  • MirtmaMirtma
    edited February 2018

    Well, in 1Pass 4 if I stopped using Chrome and working on with other apps, 1Pass did auto lock. But now (ver. 7) it doesn't auto lock at all. I left PC for few hours and when I come back, 1Pass was still accessible (thankfully it was at home). My auto lock setting is 3 minutes.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Mirtma,

    That is also not how it works for 1Password 4, it is not supposed to auto-lock while you're using the computer.

    Given the inconsistency with the locking system in all tools including Dashlane, I'm guessing you have a hyperactive system with constant input events that doesn't allow the system to idle. We've seen this before with bad mouse or keyboard drivers, where they continue to do something in the background and the system can't idle.

    For now, please email us your 1Password diagnostics report, so we can see what's going on. Use this guide to generate the report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • I've already uninstalled 1Pass7 beta. Right now I was working in InDesing and left Chrome in background. When I come back, 1 pass 4 was locked (working OK for me). And it's same at my home and work comp.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Mirtma,

    Unfortunately, that is also the wrong and unexpected behavior for 1Password 4. It doesn't depend on any browser or application to start its timer. There is a third security option in 1Password 4 where closing the web browser and/or closing main 1Password window can lock 1Password but if you've left Chrome in the background, that's not the reason. 1Password 4 starts counting when you stop using the mouse/keyboard entirely.

    Having a look at your 1Password 4 diagnostics report would help us figure this out as well.

    Unfortunately, without understanding what's going on on your computers, we can't fix this in 1Password 7 because no one else has reported this issue, including for 1Password 6 which 1Password 7 is based on. We cannot reproduce this with any of our own computers either.

    That means if you do decide to upgrade to 1Password 7 later, which will replace 1Password 4, you will have the same issue.

  • Ok, I'll post log when I get home.

  • MikeTMikeT Agile Samurai

    Team Member

    Thanks!

  • MirtmaMirtma
    edited February 2018

    Hello again. I've just sent two reports. For 1Pass 4 and 1Pass 7. Hope it'll show something.

  • MikeTMikeT Agile Samurai

    Team Member

    Thanks, we have the email and we will reply to you there as soon as possible.

    ref: SCW-97795-312

  • Thank you.

  • MikeTMikeT Agile Samurai

    Team Member

    You're welcome.

  • Hello again!
    I found out what was causing me a problem. It was Nvidia GeForce Experience Overlay. When I turned it off, 1Password locked down automatically. So if anyone has the same problem ...

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Mirtma,

    Huge thanks for updating this thread. I have a nVidia GPU in one of my computers, I'll test to see if I can reproduce it there.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file