First and Last Name in Identities don't fill in

Title says it all... Other fields like phone, address, etc. fill in fine from an identity, but I've never had a first or last name fill in on many different websites... thoughts?


1Password Version: 1Password 6 Version 6.8.2 (682003) AgileBits Store
Extension Version: 4.6.11.91
OS Version: OS X 10.13
Sync Type: 1Password
Referrer: forum-search:identities

Comments

  • brentybrenty

    Team Member

    @DHK: Thats really weird, because I typically have trouble with phone numbers the most, since different sites want them formatted differently. Can you give me an example of one or two (or more) forms which I could access that display this issue?

  • @brenty: Go to hiltonhonors.com and click the join at the top right part of the page. You can do this even if you are already a member as long as you're not logged in. Everything gets filled in except my first and last names. I agree it is weird. I could see some pages perhaps having problems with the labels that 1Pass looks for but for me ****all of them?****

  • Hi @DHK,

    So I took a peek at the site you mentioned and it filled the fields for me. Can you try creating a test Identity item please. It doesn't have to contain real details, just values in the various fields you would expect 1Password to fill. Does this test item behave the same way for you as your real Identity item if you try filling on the Hilton page?

  • @littlebobbytables: I tried the test identity and it worked fine. Before I delete the old one I tried deleting the first/last names and re-entering them... still no go. Anything else to test before I delete the misbehaving entry?

  • Hi @DHK,

    In your original Identity item do the first and last name fields appear at the top of the item when editing it and don't have a small delete icon allowing you to delete the fields? I can't think why/how but if you weren't using the built-in fields for any reason that would explain why they aren't being used. The explanation as to how they weren't in use would be the puzzling part.

  • Nope... no delete "-" signs, which I assume means it's built in...

  • brentybrenty

    Team Member
    edited October 2017

    @DHK: That's really odd. The only thing I can think of is that there is some corruption in item itself. Do you have a sense of when and where it was created? Perhaps it's rather old, migrated from an outdated version. I'm glad to hear that creating a new item works as expected, and if you'd be willing to send us a "sanitized" export of the problem item perhaps there's something we can learn from it. Let me know if you'd be willing to do that.

    P.S: Love the cat. :chuffed:

  • Cat is a sweety... Notice how I "sanitized" her tag with Photoshop. I'm happy to send you a copy of the problem if you tell me how! The Identity isn't old. Created 5/28/17 from a Lastpass import... I'm a happy 1Pass convert. A Niece-in-law used to work for Agilebits and told me of it's benefits. I really enjoy the GUI compared to Lastpass.

  • brentybrenty

    Team Member

    Cat is a sweety... Notice how I "sanitized" her tag with Photoshop.

    @DHK: Oh I hate knowing that! Photoshop (or your skill) is too good: I really thought the name was "CAT"! :lol:

    I'm happy to send you a copy of the problem if you tell me how! The Identity isn't old. Created 5/28/17 from a Lastpass import... I'm a happy 1Pass convert. A Niece-in-law used to work for Agilebits and told me of it's benefits. I really enjoy the GUI compared to Lastpass.

    Thanks so much for the kind words, the additional info, and your offer to help! It's definitely interesting that it was an export. Perhaps there was something poor about the data, or our handing of it during the import. Here's what I'd like you to do:

    1. Open 1Password for Mac and go to Preferences > Advanced
    2. Check "Copy JSON"
    3. Select the problem Identity item
    4. Press ⌘ J top copy its data to the clipboard
    5. Paste it into a file, and replace sensitive details with something innocuous, like THISISMYFIRSTNAME, etc.
    6. Paste the text into your reply here (you can use "```" in the line before and after to format as code) — or you can email it to [email protected] and post the Support ID here
    7. If you still have the export and can isolate the item there and sanitize it, I'd love to see that too!

    Thanks in advance!

  • DHKDHK
    edited October 2017

    @brenty I don't have the Lastpass export around... sorry.

    {"sectionName":"D","details":{"sections":[{"title":"Identification","name":"name","fields":[{"k":"string","t":"first name","n":"firstName","a":{"guarded":"yes"},"v":"John"},{"k":"string","t":"initial","n":"initial","a":{"guarded":"yes"},"v":""},{"k":"string","t":"last name","n":"lastName","a":{"guarded":"yes"},"v":"Doe"},{"k":"menu","t":"sex","n":"sex","a":{"guarded":"yes"},"v":"male"},{"k":"date","t":"birth date","n":"birthdate","a":{"guarded":"yes"},"v":1483272060},{"k":"string","t":"company","n":"company","a":{"guarded":"yes"},"v":""},{"k":"string","n":"CCDCE085F9124A49A027D15F9CE68BC9","v":"99-999-9999","t":"SSN"}]},{"title":"Address","name":"address","fields":[{"k":"address","t":"address","n":"address","a":{"guarded":"yes"},"v":{"country":"us","street":"123 Any St.","city":"My Town","zip":"00000","state":"CT"}},{"k":"phone","t":"default phone","n":"defphone","a":{"guarded":"yes"},"v":"860-555-1212"},{"k":"phone","t":"home","n":"homephone","a":{"guarded":"yes"},"v":"860-555-1212"},{"k":"phone","t":"cell","n":"cellphone","a":{"guarded":"yes"},"v":"860-555-1212"},{"k":"phone","n":"fax","v":"","t":"fax"}]},{"title":"Internet Details","name":"internet","fields":[{"k":"string","t":"username","n":"username","a":{"guarded":"yes"},"v":""},{"k":"string","t":"email","n":"email","a":{"guarded":"yes"},"v":"[email protected]"}]},{"title":"Other Fields","name":"98b7705a-92ee-e912-ae86-d783a1e9a77e","fields":[{"k":"string","n":"567CC44E759A4BC397FC37BBDFF333E3","v":"Dubuque","t":"county"},{"k":"string","n":"9A23113A4560460092C86DD9F9612004","v":" -05:00,1","t":"timezone"}]},{"title":"Related Items","name":"linked items"}]},"uuid":"wzrrmclb4nhnhnpjsqph7c42iu","updatedAt":1507176111,"createdAt":1495996909,"categoryUUID":"004","overview":{"tags":["lastpass-import-5\/28\/17"],"title":"DHK bad","ainfo":"","ps":0}}
    
  • Hello @DHK,

    If it were me I really doubt I would be able to remember and answer the question but do you by any chance happen to remember what you used to import the Lastpass data?

    I found the cause and I confess it took a while. The brain tends to filter out subtle differences but eventually I noticed that your imported item had a field ID of firstName and lastName while an item created by 1Password uses firstname and lastname. We're clearly using a case sensitive string comparison somewhere and so part of 1Password doesn't "see" the fields in the Identity item to fill with them. If whatever you used to import the Lastpass data is under our control we'll definitely want to fix that because it's silly that you were forced to come ask why it wasn't working - we should have done a better job importing.

    Thank you for taking the time to supply that redacted version as it did help determine the cause and it's definitely something we should fix if it's in our code. Oh and there was no way you could have seen this without comparing JSONs which we certainly don't expect our users to be doing.

  • Glad I could help. I use json and xmls at times as I am a retired programmer/tech support person and still dabble with personal programs. As for what I used to import the info, I'm not sure what you mean. Didn't i just export a file from LastPass and then import it into 1Pass? If you can clarify, maybe I'll remember... then again...

  • Hi @DHK,

    My area of focus is on the extension and filling so I confess I've lost track of where we stood with importers. If you think all you did was follow steps on our site and you imported a LastPass file directly into 1Password then that definitely sounds like something we need to check and likely file a bug report to solve. That's exactly what I was hoping to learn so thank you :smile:

    At one point 1Password didn't really have any import abilities and one very passionate user built a number of importers but it sounds like this is our own importer to blame.

    If you're happy mucking about with JSON and you want to avoid creating an entirely new Identity item then you could copy the JSON, edit the case on those two IDs and then copy the altered JSON into the macOS clipboard. You'll find a menu option in 1Password at File > New Item from Clipboard which will create a new item based on the modified JSON. You should find that fills without manually copying each field over. That's assuming this doesn't come too late and you've already made the new item.

  • It's really no big deal, and I had made a new item to be able to find out that that one worked. I think I can type name/address, and the one or two personal fields I had added. OK to delete the old one now? I'm finding more and more things other than logins I want to add to 1Pass. I even use it as a way to send secure notes to my son who lives out of town, and shares our familiy plan... I can put info there into a shared vault that I wouldn't want to use email for. I just tell him in regular email to go look for it. As far as my end is concerned we can close this case.

  • Hi @DHK,

    Oh yes, you can certainly delete the imported/broken item now especially if you have a new working one already. Thank you for reporting this and I love that you're finding the sharing a great feature for passing data securely I know Dave and Roustem will get a kick from hearing that :smile:

  • FYI, I've had the exact same problem since I switched from LastPass too, and the issue was identical. Big thanks to DHK and the AgileBits team for working it out!

    I exported from Lastpass and imported directly into 1Password on 9/28/2016. I do not have the export file anymore; deleted immediately after successful import for security's sake.

  • Greetings @jadeorchard,

    Thank you for the details on how you imported. We will have to test and see what is going on.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file