Issue with web app on Safari, always get log out, secret key has to be entered everytime

Having trouble with the Web App on Safari, always have to enter email, secret key and master password. Even for close the page for few seconds(not quiting browser). And the tick of Public computer was not checked.
I have inspected from web inspector, and noticed the deviceUUID was different each time I access this page. Any idea how I can deal with this issue?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @Leon Guan: Either you're using Private Browsing, clearing/resetting Safari manually, or you've got other software that's performing a similar function. This state is maintained in the browser's local storage, so anything preventing it from being saved or messing with it after it has will result in you needing to sign in again from scratch the next session. Does any of that ring a bell?

  • @brenty I am not using Private browsing, and I did reset cookies and storage for 1password site manually, all no luck. But I haven't resetting and clearing Safari totoally yet, too much loss. Actually, I am using Safari Technology Preview, the interesting part is that's ok with Safari. So I am trying to nail out what might be the cause.

  • brentybrenty

    Team Member

    I am not using Private browsing, and I did reset cookies and storage for 1password site manually, all no luck.

    @Leon Guan: Wait, no! I'm sorry for not being clearer, but that's the problem. What I'm suggesting is not clearing Safari's storage, as that's wiping out any information 1Password.com has to maintain the authorization.

    But I haven't resetting and clearing Safari totoally yet, too much loss.

    Definitely don't do that.

    Actually, I am using Safari Technology Preview, the interesting part is that's ok with Safari. So I am trying to nail out what might be the cause.

    Ah, that makes sense. Thanks for letting me know! Glad to hear it's working in the stable version of Safari as expected, and we'll continue to monitor the situation with the prerelease version. Cheers! :)

  • @brenty thanks, I might seek chance to login with a new user to see if the issue persist in Safari Technology Preview version or not. And then I might try in another computer to check. Will let u know.

  • brentybrenty

    Team Member

    Sounds good. :):+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file