Browser disappears when using 1Password on Surface tablet

I use a Microsoft Surface Pro 4 computer. When in tablet mode and using Google's Chrome browser:
When I click on the 1Password icon to fill in log-on details, Chrome disappears and the Windows desktop is displayed.
I then need to "reopen" Chrome to view it. Log-on fields are correctly populated.
Just an annoying experience!


1Password Version: 4.6.2.626
Extension Version: 4.7.0.90
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • bundtkatebundtkate

    Team Member

    @TimTDP: 1Password is designed as a desktop app in order to support folks still using Windows 7. In fact, 1Password 4 was built before Windows was available as a mobile operating system at all. This means it really isn't designed with tablet mode in mind. Tablet mode is largely optimized for apps designed specifically for Windows 10. Since this isn't an option for us without cutting off a good chunk of our customers, we decided to stick with a desktop app specifically, even for 1Password 6 and 7, at least until Windows 10 is more widely adopted. For now, particularly with 1Password 4, I'd recommend using 1Password in desktop mode whenever possible.

  • GregGreg

    Team Member

    Thank you for understanding @TimTDP! :chuffed:

    You would want to keep an eye on 1Password 7 for Windows, which is already available in beta. We are building it from the ground up and it is better optimized for touch screen devices.

    Let us know if you have any additional questions, we are always here for you. Thank you!

    Cheers,
    Greg

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file