Trouble filling ticketmaster.ca from e-mail link

Got a concert reminder, and want to log-in to print my tickets, but the browser version is not recognizing the site because of the e-mail tracking parameters on the URL. The URL looks like this:

https://www.ticketmaster.ca/member/order_history?wt.mc_id=EML_TMNT51254_1654_0[DayBefore_viewtickets&et_cid=TM_51254&et_rid=<......snip-64-hex-digit-tracking-id......>&utm_source=&utm_medium=tmemail&utm_campaign=DayBeforeEvent_CA&utm_term=51254&utm_content=DayBefore_viewtickets&landing=c&u=<......snip-7-digit-id......>

My saved ticket master entry has a URL of https://www.ticketmaster.ca and should (to my knowledge) match this login form.
If I remove all the tracking parameters from the URL it seems to work.

I don't understand why it won't work with the tracking variables in place.
It's not that I like being tracked, but at least some of them are there to redirect me to the exact ticket page for the exact event I want after logging in, instead of having to find it on their site manually.


1Password Version: 6.8.4
Extension Version: 4.6.12.90
OS Version: macOS 10.13.1
Sync Type: Not Provided

Comments

  • Greetings @t3rminus,

    You've been bitten by a bug in 1Password but one that we're aware of and unless anything trips us up will be fixed in the next version. Now whilst unlikely I do need to add the disclaimer that until something is shipped things could change as you never know what might happen and in the past we've disappointed people when we built up their hopes of something being added only for us to hit a stumbling block. That said, I don't see this being one of those situations. If you're curious, it is the present of the square bracket [ that has tripped up 1Password and is why when you remove the entire query component of the URL that 1Password starts behaving again. Know that we understand this it shouldn't happen again once we've got it fixed.

    ref: OPM-5278

  • Hi @littlebobbytables ! Thanks for the update and the quick reply. Glad to know it's a known issue that's being worked on. I shall patiently await the update where it's fixed (and I totally understand if it's not immediately in the next release!)

  • brentybrenty

    Team Member

    Totally! Thanks for your patience while we work on this. :)

  • Hey, so I have been encountering this same problem and found this post when trying to investigate.

    @littlebobbytables suggested that this would be fixed in the next version in December 2017. Since then, it seems that there have been at least 4 releases. So I have got to ask, could we get a progress update? When do you think this bug will be fixed?

  • bundtkatebundtkate

    Team Member

    @bytesized: I see you linked to Windows releases, but this issue was specific to 1Password 6 for Mac and has since been resolved. We tested 1Password 6 for Windows at the time and the Windows app wasn't affected. I just retested to confirm and I'm not having any trouble with URLs with brackets matching domains on Windows, so whatever is causing your trouble is likely something else entirely.

    All of that said, we'll want to make sure we track down your trouble all the same. Are you otherwise experiencing the exact same issue – able to sign in to ticketmaster.ca, but not when accessing it from an e-mail reminder?

  • Ah right. I use both MacOS and Windows and when I wrote this I was using Windows even though I was talking about a problem that I had on MacOS.

    And my issue seems to be just about identical, but with ticketmaster.com rather than tickemaster.ca. If I visit ticketmaster.com, click "Sign In", and click the browser button for 1Password, I see my Ticket Master login listed. If I click it, my credentials are filled in where I would expect it to be.

    However, if I click the link from my email and click the browser button for 1Password, I do not see my Ticket Master login listed. I can find it under logins or search for it by name, but it does not seem to do anything if I click it. I can also observe that the URL does contain an open square bracket. If I take that parameter out of the query string it seems to work as expected.

  • brentybrenty

    Team Member

    @bytesized: What "link" are you referring to? It sounds like you're simply going to a different website than the one you have saved in the login. Without knowing either I won't be able to test what you're describing, but you can certainly check yourself — and change what you have saved or add multiple URLs if you wish. Let me know what you find.

  • This works:
    https://www.ticketmaster.com/member?tm_link=tm_homeA_header_my_account
    This doesn't work:
    https://www.ticketmaster.com/member/order_history?wt.mc_id=EML_TMNT11111_11111_1[EP_viewtickets
    This one does work:
    https://www.ticketmaster.com/member/order_history?wt.mc_id=EML_TMNT11111_11111_1EP_viewtickets

    The websites I have associated with the login are
    https://www.ticketmaster.com
    https://identity.ticketmaster.com

  • brentybrenty

    Team Member

    @bytesized: Hmm. I tested all of those on both Windows and macOS, and, as far as I can tell, the login form is the same in each case, and 1Password had no trouble filling at all. What browser version are you using?

    I'm also not seeing inconsistencies with the save login not being shown at all, as each of those are still ticketmaster.com — 1Password just matches the ticketmaster.com URL saved in the login to the webpage in each of those cases.

    Did you perhaps save this login a long time ago, or create it by hand at some point? In many cases manually saving a new login for the site will allow 1Password to save additional information from the form to fill better. Just try these steps to save the login manually:

    1. Navigate to the website
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill
    8. Submit the form manually if you have autosubmit disabled

    Let me know if that helps.

  • My browser version is Firefox 59.0.2 (64-bit). My 1Password version is 6.8.8 (688001).

    I tried the steps that you provided two different ways and got two different results
    The first attempt, for step 1, I visited
    https://www.ticketmaster.com/member?tm_link=tm_header_signin
    After following the remaining steps, I visited
    https://www.ticketmaster.com/member/order_history?wt.mc_id=EML_TMNT11111_11111_1[EP_viewtickets
    I still encounter the same problem that I already described.

    On the second attempt, for step 1, I visited
    https://www.ticketmaster.com/member/order_history?wt.mc_id=EML_TMNT11111_11111_1[EP_viewtickets
    and followed the remaining steps. After this, revisiting the URL allows 1Password to work properly.

    But frankly, I am not happy with this solution. I feel that this should have worked either way. And I see no problem with the Login Item I have stored already and feel that it should work as well.

  • Greetings @bytesized,

    The bad news is due to various development scheduling issues none of the minor updates to 1Password for Mac included the proposed fix for this bug, the one where the square bracket messes with comparing the hostnames. I wish I had some promising news for you but at the moment I simply don't. For that I am sorry.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file