1Password X not working in Firefox in Ubuntu 18.04

edited May 2018 in 1Password X

Hi all,
I'm trying to get 1Password set up in Ubuntu 16.04 in Firefox. The 1Password X addon installed just fine, but when I click on it to eneter my master password, the dialog appears for a split second and the quickly disappears. I tried that severaltimes to no avail. What can I do to get 1Password working under Linux?

1Password Version: 6
Extension Version: 1.7.1
OS Version: Ubuntu Linux 16.04
Sync Type: 1Password


  • I'm on Ubuntu 18.04,o but having a the same problem with the login dialog box disappearing.

    However, I noted that if I login to the web version of 1password, then 1Password X works normally. I've been keeping the browser window open in a tab as a workaround to re-login after timeout.

  • Ah, I made a typo. I'm using Ubuntu 18.04 as well.

  • I have the same problem, started a thread about that as well with a temporary workaround here:

  • I have worked around this problem by visiting http://my.1password.com/ and signing in and then the window seems to stay open for filling passwords. But would like to see this fixed too :)

  • Seeing the same problem. Is there a bug tracker to follow for this?

  • Thanks guys, this temporary fix works for me for now, but I hope the bug gets fixed. One more data point that might help: I'm using Mozilla Firefox 60.

  • beyerbeyer

    Team Member
    edited May 2018

    Hello everyone!

    I greatly apologize for the delay. We've discovered there is a bug in Ubuntu 18.04 which is causing all Firefox extensions with password fields not to work correctly. I've just created a post which explains the issue in detail with possible ways to work around it.

    Please let me know if you have any questions and have a great week!


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file