Websites where 1Password X doesn't appear in the Login field

blaxxzblaxxz
edited March 2018 in 1Password X

Hello,

i wanted to start a Thread for us to report Sites which 1P X can't handle with.
If the Moderators let me :)
If not, delete this Thread please.

---------------------------------------------------------------------------------------------------------------

Site: http://www.samsung.com/de/
1P: 1Password X 1.6.0
Browser: Chrome x64 Version 65.0.3325.181
OS: Windows 10 x64


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @blaxxz: Thanks for the details! Unfortunately I'm not able to locate any login forms on that page. Is there a specific URL for that? Thanks in advance! :)

  • brentybrenty

    Team Member
    edited March 2018

    @blaxxz: Aha! Thank you! Weirdly, I don't get any of those options at the top. So I am especially grateful for the direct URL. :)

    And, sure enough, I see clearly what you mean...but also I can see that there is no login form on that page, strictly speaking, just a couple spots they've pasted "Email" and "Password". So 1Password is ignoring this completely. I'm not sure we should be treating anything like that as a login form even when it's explicitly been coded not to be, as that cold break a lot of sites, but we'll see if there's something we can do to work around it. In the mean time, if you create a login for it by hand in the 1Password.com web interface, you can fill it using the 1Password X menu. Thanks for bringing this to our attention!

    ref: b5x-344

  • brentybrenty

    Team Member
    edited March 2018

    @Mongoose089: Can you elaborate? This is all those links show me:

    I'm not sure how 1Password X would be involved in that case. :(

  • edited March 2018

    @brenty This is the EZ Pass Website for NJ. The toll payment system. This is what you should see:

  • brentybrenty

    Team Member
    edited March 2018

    @Mongoose089: Well that's annoying. I had thought maybe the site was just broken or I wasn't allow to access it. But I guess they're doing "location"-based traffic filtering. What if you're trying to give them money while you're on vacation outside of Jersey? Yeesh. Anyway, VPN to the rescue! :lol:

    Long story short, after I was able to access the site, I could reproduce the saving and filling issues there. This is a bit of an odd duck, but we'll see if there's something we can do to get 1Password filling there. Thank you for reporting this!

    ref: b5x-348, fill-149

  • @brenty That site has always been a pain from a user stand point as well. It was newly redesigned and I often get that location error too, even though I'm in NJ. I VPN to another state sometimes to get it working.

    Thanks for your guys hard work and constant progress. This is one of the reasons I haven't looked back after abandoning my long time favorite Lastpass a few months ago.

  • brentybrenty

    Team Member

    That site has always been a pain from a user stand point as well. It was newly redesigned and I often get that location error too, even though I'm in NJ. I VPN to another state sometimes to get it working.

    @Mongoose089: 🤦‍♂️

    Thanks for your guys hard work and constant progress. This is one of the reasons I haven't looked back after abandoning my long time favorite Lastpass a few months ago.

    Wow. Thanks so much for the kind words, and for your support! As much as I'm enjoying 1Password X, the best is yet to come. Have a great weekend! :chuffed:

  • beyerbeyer

    Team Member

    @blaxxz: Thanks for passing on the URL to this website. It looks like the inline form (1Password logo) does appear at first, but there's an issue displaying it after some content is updated/refreshed in the "Live highlights" section of the page. I've created an issue on your behalf so we can take a look and get this resolved in a future release of 1Password X.

    Thanks again and have a great weekend!
    -Beyer

  • dtearedteare Agile Founder

    Team Member

    Thanks for sharing all these sites and issues. Knowing about them will give us the chance to make 1Password X better.

    At the risk of creating too much bureaucracy. I really think we need to have separate threads for each website. This thread has only been open for a week and we already have 5 completely different websites here and has already become unwieldy.

    For https://www.ubisoft.com/en-us/, I found this worked perfectly for me:

    1. Go to the sign in page
    2. Type my email address
    3. Generate a password
    4. Save the login
    5. Reload the page and fill saved login

    Now of course this isn't how you would typically do things as it's a login page but it's a quick way for me to generate test logins for sites I don't have in 1Password already. What's interesting is this works perfectly but if I change step #3 from generating a password to manually typing the password, the saved login has no username nor password and won't fill. Even if I edit the login to include a username and password it still fails to fill.

    This is most curious and I'll need to dig deeper to see what's going on. In the mean time you can generate a password like I did above and then edit the newly created login to have the correct password. That should fill fine for you. With any luck anyway 🙂

    ref: fill-155

  • dtearedteare Agile Founder

    Team Member

    Will do! 👍

  • dtearedteare Agile Founder

    Team Member

    FWIW, Gamesplanet works for me in 1Password X 1.6.1. This is the beta version so perhaps that's why but I thought most of the changes in 1.6.1 were related to other things. Can you confirm you're running 1.6.0? And if it's not too much trouble, please give the beta a try as well as we release beta updates frequently.

  • dtearedteare Agile Founder

    Team Member

    I think we both pressed Post Comment at the exact same time! 😂

    Please try Gamesplanet again and see if it's still broken for you. Given what you've been saying in the Update Login thread I'm starting to wonder if this is a systemic issue for you. I see you're on Windows 10 which should be fine. I also see that you are on 1.6.0 so all of this should be working.

    It's most curious. 🤔

  • MitchMitch

    Team Member
    edited May 2018

    Hey @blaxxz,

    I had the same problem filling my Uplay login on that Ubisoft page, but I was able to get it to fill by saving a new login directly from the form on the page. Please try that and let me know if it works!

    -Mitch

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file