1P icon in field that it shouldn't be in

camnercamner Member ✭

So, I was editing a field on a web page, one where there wouldn't/shouldn't be anything for 1P to volunteer to fill in on my behalf. But, there it is!

I can see why this might be happening, because 1P is trying to be more convenient to access than it was in earlier versions where I had to go to the 1P extension icon in the browser.

BUT, now I can't see all the characters in the field, which means I can't see what I'm editing!

Is there a workaround here?


1Password Version: 7.04
Extension Version: X 1.7.3
OS Version: 10.13.5
Sync Type: Not Provided

Comments

  • dtearedteare Agile Founder

    Team Member

    Hello again, @camner! I'm seeing you a lot today. πŸ™‚

    Thank you for reporting this issue. Ideally we would never show the 1Password icon in a field where it's not needed but as you see we're not 100% there. At least not yet!

    At the moment the only way to prevent this is to disable the inline menu completely in Settings. You can find this by clicking the 1Password toolbar icon, selecting the gear icon, and then Settings. There you can disable the Show 1Password icon in forms preference. Unfortunately this is a global switch so you'll lose this feature everywhere. We do have an upcoming feature planned where we'll allow you to disable the inline menu for a specific site, but it's not available yet.

    This looks like a private site, but if it's possible for us to create an account here and test this ourselves, please share the link and we'll dig into it to see if we can improve our form detection logic.

    I hope that helps. Take care and enjoy the rest of your weekend. πŸ‘‹

    ++dave;

  • camnercamner Member ✭

    Sorry to be slow in responding; I was trying to figure out how to give you access.

    Yes, it is a private site; or rather, the public can register for it, but only as a "student." The page in question (with the field in which 1P X shouldn't show an icon) is only available to "instructors," and I don't have the privileges to approve instructors.

  • dtearedteare Agile Founder

    Team Member

    Thanks for getting back to me, @camner.

    That's sad we can't test directly but I do have some good news: in the beta we made some changes on when the toolbar appears and I believe it will help you on this site. Once version 1.8 becomes available, please let us know if it helps. I expect to publish it sometime next week.

    Take care,

    ++dave;

  • camnercamner Member ✭

    Good news! I’ll check it out when it’s available

  • dtearedteare Agile Founder

    Team Member

    πŸ‘

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file