7.05 crashes

edited June 2018 in Mac

I just updated from 7.04 to 7.05 with no other changes. Unfortunately 7.05 permanently crashes as soon as I take any action (regardless if from within Firefox via Shortcut oder via Menu). Reboots dont help
I manually killed the processes of 1Password and helper and installed the old version 7.04 from Time Machine, reboot - that works as usual.
Are there known issues?
I followed the intructions during update, but maybe something went wrong there? What?
Environemt:
iPassword from agile via purchase, not App Store

Not urgent, old version works
Bernie


1Password Version: 7.05
Extension Version: 4.7.2.90 (FF9 and 4.7.1.(Safari)
OS Version: 10.12.6
Sync Type: Dropbox

Comments

  • Smoky FredSmoky Fred Junior Member

    I manually updated my iMac (10.12.6) with 7.0.5 and now my Safari extension (4.7.2) crashes (screens blips when clicking on the extension) every time. I also tried it on my MacBook Pro (10.13.5) and it does the same. Rolling back to beta-3 (which worked fine) does NOT restore the function of the extension. Needless to say, major pain. Any ideas?

    I also tried in Firefox (61) and it does the same.

    Fred


    1Password Version: 7.0.5
    Extension Version: 4.7.2
    OS Version: 10.12.6
    Sync Type: Dropbox

  • I had frequent crashes of 1Password Mini as well with 7.0.5. Never happened before.

  • billjbillj Junior Member
    edited June 2018

    Since manually updating to Mac 7.0.5 last night, clicking on both Safari and Chrome browser extensions crashes the 1Password app and with it, 1Password QuickMenu.

    Tried deleting and re-installing extensions, hoping for new versions. Reinstalled version numbers same as before, and crash the app as before.

  • This is happening to me and is a frustrating problem. So much so that I am concerned about continuing to use 1password. I just tried it again and was able to log into this site to leave this comment. Makes me realize how much I depend on this program and if it doesn't work I'm in trouble. Anyone who has thoughts on how to back up 1password so you can get to passwords if 1password doesn't work please comment.

  • billjbillj Junior Member

    I'm wondering if the culprit is really 1Password Mini in 7.0.5. I just launched Chrome, noticed the Extension was showing, so deleted the Extension, then (with the 1Password app NOT running) clicked on 1Password Mini on the menu bar so I could get a username & password to enter into a login page. And BOOM, 1Password Mini blew up and crashed. Something is definitely amiss.

  • billjbillj Junior Member
    edited June 2018

    This behavior in 7.0.5 may also be addressed in the forum topic titled, "Safari Extension crashes after 7.0.5 update."

    https://discussions.agilebits.com/discussion/92845/safari-extension-crashes-after-7-0-5-update

    A request to AgileBits Support: At this point, I would like to fully remove 7.0.5 so I can re-install 7.0.4. (I kept a copy the 7.0.4 installer.) Would you please provide step-by-step instructions for deleting 7.0.5--both visible and "hidden" components?

    Bernhard at Lake Constance (top of this thread) mentioned killing 1PWD 7.0.5 processes prior to deleting 7.0.5. I'm guessing he used Activity Monitor to do this. Would you please tell me exactly which processes to kill?

  • billjbillj Junior Member

    This behavior in 7.0.5 may also be addressed in the forum topic titled, "7.0.5 crashes."

    https://discussions.agilebits.com/discussion/92855/7-05-crashes

  • @billj:
    I indeed used the Activity Monitor, use first register (CPU), sort by Process Name shows the 2 processes on top I killed (1Password + 1Password Extension helper). Use right mouse and popup menu to kill. Then TimeMachine allowed me to replace the new one with any older version (i took the one from yesterday). Reboot.
    I have no idea weather this is the perfect way to go back, I assume agilebits will rspond to this very soon.

  • billjbillj Junior Member

    @Bernhard at Lake Constance:

    We'll see what they say. Meanwhile, I found a mention in a forum thread that clicking on 1Password 7 File menu and holding down control + option changes Quit to Quit 1Password Completely. Which, I'm hoping, kills all 1Password processes.

    And before I did this, I went into 1Password Preferences and unchecked Always Keep 1Password Extension Helper Running.

    Then I restarted in Safe Boot mode, deleted 1Password 7.app, and restarted in "regular" mode. Then deleted AgileBits cache in ~/Library/Caches, and searched for "agile" and deleted 1Password-related items in Google and Firefox support directories.

    Would have done your thing with Activity Monitor, but didn't see your response till after I did above.

    Oh, and once I did a fresh install of 7.0.4, I installed & tested browser extensions (all work without crashing), unlocked 1PWD from 1Password Mini (worked without crashing), and finally, went into Preferences, made sure Always Keep 1Password Extension Helper Running was CHECKED, and UNchecked Automatically Update AND Check for Updates. (I will re-enable Check for Updates once a stable successor to 7,.0.5 drops, but I will NOT enable Automatically Update. After 7.0.5, I'd rather be cautious.)

    Anyway, so far, so good.

    How did restoring from Time Machine work for you?

  • billjbillj Junior Member

    @Bernhard at Lake Constance

    I wonder if "Quit 1Password Completely" ( FILE MENU+CTRL+OPT or CTRL+OPT+CMD+Q) kills all running 1Password processes?

    Anyway, after doing that, restarting in Safe Boot Mode, deleting the app, and doing some additional cleanup (delete agilebits caches and items in Chrome & Firefox support directories), I ran the 7.0.4 installer and separately installed browser extensions. I also UNchecked "automatically update" in 1PWD 7 Prefs, and, at least for now, also UNchecked "check for updates." So far, so good. Can use browser extensions and 1Password Mini without crashing.

  • @billj
    I think you are right and quitting via ctrl-option Menu is the correct way. I forgot about that.
    Anyway, you also solved the problem with a work around. Lets see what agilebits will respond. I also sent the analysis data to them after the crashes, I assume they are working on it already. For the moment: lets enjoy weekend
    Greetings from Germany

  • abch7abch7
    edited June 2018

    Same here. Immediate crashes with 1Password7 v7.0.5 (70005004) on macOS Sierra v10.12.6 when performing various actions (eg. changing the icon of a login entry or trying to use the dropdown menu in Firefox). Isn't there a simple way to downgrade to the previous release?

  • rudyrudy

    Team Member

    7.0.6 will be posted shortly, which will resolve the crashes.

  • Thank you so much for the super speedy fix! Your effort is very much appreciated. The new version 7.0.6 works like a charm.

  • brentybrenty

    Team Member

    On behalf of Rudy and the rest of the team, you're very welcome! Glad to hear all is well for you now, but we're here if you need us. Have a great weekend! :chuffed:

  • Smoky FredSmoky Fred Junior Member

    Well, I must be unique. 7.0.6 crashes same as 7.0.5. I installed 7.0.6 over 7.0.5, even reinstalled 4.7.2 extension and the extension still will not bring 1P up to login, just the same brief flicker of the window and boom, it's dead. OS 10.12.6

  • Smoky FredSmoky Fred Junior Member

    I've got another more serious issue now for which I will start a new discussion.

  • 7.06 works fine. Thanks for the fast update. Shit happens...

  • If so many serious bugs really did not show up during the testing, your team had better reconsider the testing procedure itself. We are talking about a “stable version” here, not betas. The more important 1Password becomes for users, the more stable its “stable version” should be.

    Shortly after releasing our 7.0.5 update yesterday we became aware of some issues that did not show up during our testing. This update addresses those problems, with our apologies.

    • Fixed regression in 7.0.5 where item URLs could not be saved. {apple-issues#1728}
    • Fixed regression issue in 1Password 7.0.5 where the trash on standalone vaults didn't empty right away. {apple-issues#1732}
    • Fixed a regression in the last release that prevented display of Software licenses. {apple-issues#1727}
    • Fixed an issue that caused placeholder text of "this is the beginning of a note" to appear for new Software license items. {apple-issues#1427}
    • Fixed an issue that would cause a crash during item saving. {apple-issues#1734}
    • Fixed a crash that could occur when viewing Secure Notes. {apple-issues#1724}
    • Fixed a rare crash that could occur during unlock. {apple-issues#1731}
  • @billj
    Sorry, forgot to answer one of your questions:How did restoring from Time Machine work for you?

    The app you plan to restore from TimeMachine must not be running. So you either finish it regularly or by killing the process(es).
    After that you just open the apps folder, click the app you want to restore, go into Timemachine back to a point where you are sure a good version is stored and restore. In the 1Password issue I just went back a day to ver 7.04. You need to enter your Mac User PWD and thats it.
    I have frequently done it in the past for other apps, whenever an update went wrong - but this time it was the first time for 1Password. I hope agilebits are learning from this.!!!
    Anyway, regarding 1Passsword I will from now on do the same as for many other SW-Updates: No auto updates any longer, just wait a week or so and monitor forums.

    By the way, my stragey regarding MacOS updates has also been changed a couple of years ago (Mavericks) when Apple first started introducing untestet bad betas in their major releases: I only install the latest and greatest version of MacOS right before they issue a new major update. So I installed 10.12.6 last July 2017. I will istall 10.13.6 or 7 wehenever that is out, maybe this month. By this I ensure I have a stable update, I need bothering updates only once a year - and I can personally live with the fact that I am having an old version as soon as Mac publishes a new major release. I will never ever again install a .0 version or any intermediates. 10.14.0 may bother 90% of Mac users - not me.

  • brentybrenty

    Team Member

    @ojix2: None of our beta testers reported crashes, and we didn't see them internally either. Unfortunately the nature of beta testing is that it's a much smaller pool, so some issues don't become apparent until a wider audience uses it. I'm glad we were able to push out a fix this weekend once we received reports from users, but I'm sorry for the inconvenience caused to you and others in the mean time. :(

  • brentybrenty

    Team Member

    @Bernhard at Lake Constance: I'm glad to hear that that the update resolved this for you. Thank you for reporting it to us!

  • Since 7.07 I have the same crashes: it hangs as soon as I take any action. However, this behaviour only happens at certain sites, in this case a DirectAdmin page. I sent the crash reports (to you?), but is there anything I can do to help you analysing this issue?

  • brentybrenty

    Team Member

    @krissp: Thanks for getting in touch! If you're still having this problem, the best thing to do will be to restart your Mac, reproduce the same issue, and then generate a diagnostic report so we can look at the logs to determine exactly what is happening:

    https://support.1password.com/diagnostics/

    Please send it to [email protected] and add the following Support ID (including the square brackets) to the subject of your diagnostics email before sending:

    [#JUV-99992-137]

    If you’re reading this and you are not krissp, this Support ID is for krissp only. Please ask us for your own if you also need help.

    This will link your diagnostics to our current discussion. Please also include the email address the crash reports were sent under. Let me know once you've sent it. Once we see it we should be able to better assist you. Thanks in advance!

    ref: JUV-99992-137

  • Smoky FredSmoky Fred Junior Member

    @brenty - I just responded on another discussion that restarting fixed it for me.

    Fred

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. I'm glad to hear that restarting helped clear things up on your Mac. It sounds like you should be all set, but don't hesitate to reach out if we can be of assistance. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file