Vivaldi keyboard shortcut binding doesn't work

Aware this isn't a target platform, but in case it's useful.

The extension works just fine, including the ability to set the keyboard shortcut. Passwords can also be filled by mousing over to the extension icon and activating that way. The only problem is that the keyboard shortcut doesn't open the extension menu.

I've checked this on OS X and Ubuntu 16.04, and it's the same behavior.


1Password Version: Not Provided
Extension Version: 0.8.6
OS Version: 10.11.6, Ubuntu 16.04
Sync Type: 1password.com

Comments

  • beyerbeyer

    Team Member

    Hey @seandmr,

    Thanks for taking the time to inform us of this issue. At this time Google Chrome is the only browser we are developing for and testing on. However, I was able to reproduce this issue and it has peaked my curiosity, so I'll dig in when I have a few moments and see if we can determine the cause. I'll let you know when I find something.

    Have a great week! :)

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • edited July 2018

    FYI I was able to set the usual keyboard shortcut (Command+\) successfully by modifying (on macOS) ~/Library/Application\ Support/Vivaldi/Default/Preferences

    1. set a keyboard shortcut initially to "Command+S" for the 1password extension in Vivaldi
    2. Quit Vivaldi
    3. Search for "Command+S" in the file and replacing it with "Command+\\" (with two backslashes, because it's JSON and needs an escape sequence for a backslash)
    4. Save the file and relaunch Vivaldi
  • brentybrenty

    Team Member

    Thanks for sharing that! Others may find that useful as well. :)

    ref: apple-320

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file