Bug report: list picker does not update details pane after first launch and first search

kop48kop48 Junior Member

I can't quite figure out why, but I'm seeing an issue with 1Password in the last few weeks:
1. Cold launch the app
2. Unlock (I usually make a mistake with my master password here)
3. Go to the search field, and search

Either the list does not update from the search, or the search results don't respond to input - the details pane stays on the top-most list item. I can work around it by switching vault to another and back to the one that I want.

I don't have a clear repro either.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 10

    Hi @kop48,

    Thanks for reporting this.

    That's a known threading issue, 1Password's interface can't update until the background sync is done. If you start the search before the sync starts 10 seconds, it'll be fine but if you start after, it'll delay the feedback until the sync is done. For some, it can take up to a few minutes.

    We're working on fixing this for the upcoming 7.3 betas.

    ref: opw/opw#3162

  • kop48kop48 Junior Member

    @MikeT great, glad to hear it!

  • MikeTMikeT Agile Samurai

    Team Member

    Yea, it's been haunting us for the past few updates, we're focusing solely on fixing that right now.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file