Browser extensions don't work -- Chrome, Firefox, Safari

When attempting to use the browser extension in any of these three browsers, the same thing happens... If the 1Password app is open, it will flash to the foreground for a second and then disappear. If the app is not open, the browser's chrome flashes, but nothing else happens.

This has been occurring for several months. I've rebooted often, all browsers and 1Password are up to date. I've enabled and disabled various extensions in each browser, same thing.

I've also tried the Chrome beta extension to no avail.

At any given time, the following processes are running:

  • 1Password7
  • 1Password Extension Helper
  • 1PasswordNativeMessageHost

Not sure where to look next.


1Password Version: 1Password 7 Version 7.0.7 (70007000)
Extension Version: 4.7.2.90
OS Version: OS X 10.13.6
Sync Type: Not Provided

Comments

  • Greetings @ScoutJosh,

    If I had to guess it sounds as if 1Password isn't running from /Applications/. Due to the checks we perform and the security framework we need to use given 1Password 7 is sandboxed it means the checks will only succeed if 1Password and the browser are stored in /Applications/. If you need to move 1Password I would recommend:

    1. Quit 1Password by holding down the alt ⌥ key and clicking on the 1Password icon in the macOS menu bar. Select the menu option Quit 1Password Completely.
    2. Move the 1Password application bundle to /Applications/ from wherever it is currently located.
    3. Launch 1Password from its new location.
    4. Restart any open browsers.

    Now if that doesn't explain the behaviour you're seeing then I'd like to review a diagnostic report from the Mac. Can you create one please and send it in. This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ticket ID here it will help us locate your diagnostic report and we'll see what it reveals.

  • Thanks for the input. Reading your suggestion led me down a rabbit hole, but it's working now!

    After removing the app from /Applications/ and rebooting, 1PW was still active. I discovered that the app was also installed via the App Store. I removed that via LaunchPad, rebooted again and then reinstalled from the App Store.

    After that, everything worked as expected. I have no idea how there were two versions of the app installed, but this is a work computer that I inherited... :p

    Thanks!

  • Greetings @ScoutJosh,

    I'm always happy to learn things are working again :smile: Glad you managed to figure it out and hopefully things are working properly now. If you have any trouble though please let us know.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file