1Password 7 slow to respond immediately after unlocking [will be addressed in an update]

SystemSystem

Team Member
edited August 2018 in Windows
This discussion was created from comments split from: 1Password 7 very slow with 12,000 items in 2 vaults.
«1

Comments

  • I am experiencing the same issue and only have 382 items in my vault with 1Password 7 on Windows. I know this is mac forum but trying to see if the issue is 1Password itself.

    Guys I did a fresh install of Windows 10. Then just installed Firefox 60.0.2 and 1Password 7

    After locking my pc and coming back 1Password 7 is still laggy or slow to open sometimes. :( Like I said 1Password 6.8 works beautifully on the same system.

  • bundtkatebundtkate

    Team Member

    @ttim03: Could you provide some additional details on what, exactly, is working slowly for you when opening? Is the app itself slow to launch? Is it slow to unlock? Are you seeing your items load slowly? I noticed you also mentioned this only happens "sometimes." Could you hazard a guess at frequency or circumstances under which it's more common (after waking from sleep, for example)? Thanks! :chuffed:

  • ttim03ttim03
    edited June 2018

    @bundtkate The 1Password 7 extension is very slow to open. Takes 15 to 30 seconds to finally appear if at all.

    After waking from sleep.

  • bundtkatebundtkate

    Team Member

    @ttim03: Gotcha. I know you've already sent over some diagnostics from another thread and I've added myself to your e-mail. I don't think I'm going to get a chance to look it over today (sorry!), but I'll take a peek Monday at the latest and keep your extension troubles in mind. I've run into some sleep troubles myself, so with any luck I'll be able to reproduce the problem so we can start tracking it down. :+1:

    ref: CUP-38345-887

  • @bundtkate ok np! Thanks.

  • bundtkatebundtkate

    Team Member

    :chuffed::+1:

  • Windows 10, 1Password 7, Firefox (all latest patches) -- over the last week or there has definitely been something wrong. It takes upwards of 20+ seconds for the browser shortcut to bring up a 1Password window and even fill-in login forms. This is flat-out unacceptable compared to past performance (been a customer for what, 3 or 4 years?).

    If there's diagnostic information you'd like me to pull and submit somewhere, that's fine. I'm hoping there's a fix on the horizon.

  • Thank you @rtrd for speaking up as well!

  • Well here is the weird part everyone on my VM (Virtual Machine) 1Password 7 seems to work fine with no lag even after locking or putting my VM to sleep then coming back. My main machine still has the problem though :(

    Still trying to figure out why.

  • The only difference is my main machine is Windows 10 Pro the VM is Windows 10 Home.

  • GregGreg

    Team Member

    @rtrd: Are you using a local vault in 1Password 7 for Windows or 1Password account? Please specify. If you are using a local vault, it is very possible that you bumped into a different issue with .opvault. Thanks!

    @ttim03: We have received your system configuration file and will get back to you via email. Thanks!

    ++
    Greg

  • 1Password account -- converted awhile back from my own local vault and only had issues in the last few weeks (less than a month at least).

    I updated everything on macOS as well, and the browser extension doesn't seem to work at all anymore with the CTRL - / shortcut in Firefox. I've tried restarting the application, uninstalling/re-installing the browser extension, etc to no avail ; it's broken bigtime.

    On Windows 10 + Firefox it's just dog slow. It's faster to open the desktop application and manually right-click fields and copy/paste them than rely on the shortcut.

  • GregGreg

    Team Member

    Hi @rtrd,

    Thank you for the clarification!

    We are investigating this issue at the moment and the additional info from your computer will be really helpful. Please create a Diagnostics Report from 1Password 7 on your computer and attach it to an email message addressed to [email protected].

    Please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your report in our inbox. You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report on our side. Thank you!

    Cheers,
    Greg

  • Greg,

    I've sent the support team diagnostics reports for both macOS and Windows 10, and have included this link in said e-mail. The macOS Support ID number is: #ICT-37288-321 . The Windows 10 Support ID number is: #DJX-76839-884 .

    Thanks!

  • GregGreg

    Team Member

    Hi @rtrd,

    I have found your reports on our side, thank you! We will take a look and get back to you via email.

    Cheers,
    Greg

    ref: ICT-37288-321
    ref: DJX-76839-884

  • andy_vdgandy_vdg Junior Member

    Hi guys,

    I've also had severe lags with extensions in Chrome and the general 1Password 7.1.567 Win UI.
    I'm pretty sure these are caused by the .opvault I was using on Dropbox. I've migrated everything to the online vault now and I was able to resolve these issues by renaming the data folder to data-backup and starting fresh in 1Password - I only added my 1Password Online Vaults and the difference is like night and day. Everything is snappy and works like I'm used to on my Mac.
    @Greg you mention another issue with .opvault - would you say I suffered from the same issue?

    Thanks
    Andy

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @andy_vdg,

    Internally, there are no major differences between the vaults from your 1Password account and standalone vaults. OPVault is an external sync format we use.

    I have 7 OPVaults in my 1Password database and it is snappy as you expect.

    The performance issue here stems from the fact that when you make a change to your item in standalone vault, we are doing far more than 1Password account vaults; we first backup your current OPVault, sync/write new changes to the external OPVault on disk, which can be slowed down by Dropbox scanning and AVs scanning (worse because it is an encrypted file), and then finally, we re-read the whole folder to check for remote updates. It's much heavier than a simple row update with 1Password account.

    The most of the lag issues reported here is that when you unlock 1Password mini, it kicks off a full sync for all accounts and vaults. If there are many changes coming in for OPVault, guess what happens? A new round of backup + sync + re-read of OPVault.

    There are several optimizations we are planning to do in the near future. The upcoming 1Password 7.2 update will have the first batch of optimizations already in general but nothing specific yet for OPvault, we're investigating why the extension is lagging and we'll optimize that first before we do more optimizations.

  • I still have this problem on 7.2.573 with latest Chrome on Windows 10. It seems random. When I encountered the problem, both chrome extension and 1password itself are very slow. The extension window does not appear/ takes ~5s to appear/cannot copy password. The 1password app does not show a menu when I right click on an entry, it only shows "...". I have created an opvault to sync with dropbox.

  • GregGreg

    Team Member

    @Vancion: 1Password 7.2.573 Beta doesn't fix the performance issue with OPVault yet, so it sounds like you bumped into the same issue there. Please create a Diagnostics Report from your computer and share it with us, so we could confirm if that is the case.

    Please do not post your Diagnostic Report here. You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and ensure that this issue is dealt with quickly.

    Cheers,
    Greg

  • @Greg thanks. support ID is [#VLN-76889-772].

  • GregGreg

    Team Member

    @Vancion: Found it! We will get back to you via email soon. Thanks! :+1:

    ref: VLN-76889-772

  • DaniloTDaniloT
    edited August 2018

    Hi, it seems I'm getting this issue as well since upgrading to version 7, I thought it would be fixed later but so far, in version 7.2.576, I still have it. I am using windows 10 with chrome, and have 175 entries. The same issue happens on both my desktop and laptop PCs, using the same vault shared via dropbox.

    The first time I try to use 1Pass, I click either the icon in the taskbar or on the chrome extension, and then sit and wait, it takes at least 30s for it to actually open. When it does, I type my 1Pass password to unlock it, select a password to fill, then sit and wait some more, it usually takes longer to fill in a password than it does to open the unlock screen. It's so bad I'm used to clicking 1Pass, switching tabs, and go do something else while it does not open. This was not an issue with the older version I had.
    The second time I use it, it is very fast, working as intended... until I try to use it on another website, then it is very slow to open again. At least it auto fills almost instantly this second time. When I try to open 1Password in a page where I don't have a login saved for yet, it seems to be very fast too.

    EDIT: Oh yeah, don't know if this is relevant but I do use many tabs, over 20 most of the times when working, about 10 when not.

  • GregGreg

    Team Member

    @DaniloT: There is a known performance issue in the current version of 1Password 7 for Windows and we are planning to address it in the future update. Could you please also share a Diagnostics Report from your PC, so we could take a closer look and confirm if you bumped into the same issue?

    Thanks in advance!

    Cheers,
    Greg

  • Hi @Greg. I've also submitted a diagnostics report for this issue: [#QDE-35836-435]. Thanks.

  • bundtkatebundtkate

    Team Member
    edited August 2018

    Fancy that, @helmas, I have your e-mail open in another tab as we speak (or type, I suppose). I'm working through the forum real quick before getting back to ya, but should be with you shortly. Talk soon! :chuffed:

    ref: QDE-35836-435

  • molovemolove
    edited August 2018

    I'm also having the same issue with 1Password 7 being desperately slow on Windows 10, both the main app and the browser plugin on Firefox. It often takes upwards of 20 seconds to react to my clicks. I have the standalone version with my vault in dropbox

  • khellkhell
    edited August 2018

    1Password 7 on Windows with both synced 1Password.com for Teams vaults and two local (.opvault) vaults synced via Dropbox. One local vault has in excess of 1000 items. Mind-boggingly slow on launch and every time I attempt to create or edit an item and has been like this since I upgraded over 2 months ago. Extremely disappointing. I use 1Password mainly on macOS and iOS and dread whenever I have to use the Windows version on my PCs as it has always been pathetically subpar in some way - but this is the absolute worst. The Windows version just keeps getting worse and worse (and it was never anywhere close to good or decent). Can you guys please step up your Windows game? Recommending this to my team who mostly all use Windows - except me - has been more of an embarrassment so far to my credibility.

  • GregGreg

    Team Member

    Hello @molove and @khell,

    I am really sorry for the troubles with the current version of 1Password 7 for Windows. There is a known performance issue in 7.2 that we are currently investigating and have plans to address in the future update.

    Could you please also share Diagnostics Reports from your side, so we could confirm the issue?

    Thank you very much!

    Cheers,
    Greg

  • I get one shot at anything. One click, that's it.

    Let's say I search "twitter." I get a list with my personal account and my biz account in a list. Today I wanted to update the email on my biz account, so I highlighted it. That worked. Then I tried to click "edit" (right column) and it wouldn't open the record to let me edit. Essentially that click freezes 1P.

    If I click on / try to highlight my personal account nothing happens. I have to go into my browser account to make the email change.

    Happens even when I'm just searching and trying to scroll. I get 1 click. period.

    Windows 10 1P version 7.2.576

  • brentybrenty

    Team Member

    @TJdohertyCvl: Ah! At first I was thinking "well that's nothing I've ever heard of", but I think I understand after re-reading your description, especially in light of the version you're using. Unfortunately 1Password for Windows version 7 has some performance bottlenecks currently because, frankly, we've added to many features too quickly, so we're working to streamline things behind the scenes to make it more responsive. This happens when unlocking currently because 1Password is trying to sync, fetch Watchtower info, decrypt data, configure proxy settings, and a whole bunch of other stuff, and not as efficiently as we'd like. For now, if you give it around 30 seconds after unlocking, it should work normally. I'm sorry for the inconvenience though. We'll be releasing an update to address this as soon as we can.

This discussion has been closed.