Need three fields filled on one page for login

I'm trying to login to a website that has three fields that need to be filled in, Company Name, User name, and Password. I can get 1P to store/fill the username and password, but not the company name. The url is https://webdata.omnimetrix.net/omxphp/omxLogin.php. I've looked over the various other posts regarding multiple fields on one page and most seem to point to using 'Save New Login', but that isn't working for me. Any help would be greatly appreciated.


1Password Version: 1Password 6 Version 6.8.1 (681006) AgileBits Store
Extension Version: 4.6.9
OS Version: 10.11.6
Sync Type: Not Provided

Comments

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @packdude. I just tried saving a login manually and the resulting Login filled fine for me. Can you let us know what happened when you tried that? Perhaps there's a subtle bug somewhere… 

  • Hi, I'm having same issue with one of my logins.
    I tried create/save it manually, and also adding the extra field to the web form with the correct id, but no way.
    It only works if I switch the field type to user, but than it fills the user field with the wrong value.
    I need to check this website at least once a day, and this is wy I'm asking for support.
    Any help would be appreciated.

    Link To website:
    https://bancopostaimpresaonline.poste.it/bpiol1/

    Screeshots:

    1Password 6
    Version 6.8.3 (683005)
    Store AgileBits
    Mac Os 10.12.6

  • Hi @uomopalese,

    I compared two Login items saved on the same page and noticed that the indexes didn't match up. It seems the site is adding and removing fields and this messes with 1Password's ability to fill the fields.

    There is a way around this though. What I would like you to do is to create a new Login item from inside the main 1Password window. Set the title, username, password and website field to match for this site. Before saving though click the show web form details button and add a new field with the label set to corporateCodeIForm. You should find this Login item fills all three fields.

    It is likely counterintuitive but if you save a Login item from inside the browser, adding or removing fields from the web form details section will break any specialised attempts at filling. The reason the above should work for you is because the item was created from inside the main 1Password window. Do let us know how you get along :smile:

  • Worked like a charm!
    Thank you :)

  • Glad we could @uomopalese :smile:

  • How do I determine what that field should be called? For instance I need it to work on the login page at https://www.paycomonline.net/v4/ee/ee-login.php and it asks for last four digits of social. I tried using the label next to the field on the web page but that didn't work for me.

  • bundtkatebundtkate

    Team Member

    @JC54: This can be a simple task or it can be rather complicated depending on how the site was designed. I took a look at this site in particular and it looks like that label should actually work, so I suspect what happened is that you created your login using the extension. If the Login item is created using the extension, this trick of editing the form details won't work.

    If you used the extension to create the Login, create a new Login in the main app and enter your username, password, and the URL to match the site, then click Show web form details and add a new field with label set to Last 4 digits of SSN and the value set to what you want to fill. Also make sure the type is set to password. This should fill appropriately, but if you're still having trouble, you can send an e-mail to [email protected] referencing this thread and we can take a closer look. :+1:

  • Hey, that worked. I did indeed start from the browser extension but starting over in the app did the trick. Sorry for the confusion on the field label. I was thinking the earlier advice to someone was somehow naming the field some name that was part of the html page, not the actual label. Don't know what I was thinking.

    Thanks so much. This will apply to a number of other websites as well.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni
    edited October 2017

    @JC54 This trick supports a few different attributes including name, id, and placeholder. The label works but only if it is well coded to match up to the field it belongs too. This messiness is one of the reasons we haven’t widely advertised this capability. We hope to make it more user-friendly in the future.

  • It seems more and more sites are going with more than name/pw. So anything to help work smoothly for novices would be appreciated. I could follow the instructions, but most of my family wouldn't even try. Thanks!!!

  • brentybrenty

    Team Member
    edited October 2017

    @JC54: The easiest thing is to just save the login using the 1Password browser extension. In the vast majority of cases, that will work. And when it doesn't, were here to help. :)

  • Sorry for not responding sooner, but it is working now. Thank you for your help.

  • We never say no to hearing things are working @PackDude :smile: Glad to hear it is and of course please let us know if you come across any other problematic sites.

  • I am trying to save an entry for https://www.eftps.gov/eftps/login/loginInitial

    There seems to be 3 username fields (ie SSN) and 2 Password fields. I have tried creating a new login, the information is all in the form details, but it will not fill out the screen. If I label a field username and password, It will fill out SSN3 as the user and PIN as the password.

    Any suggestions?

  • Hi all,

    I've been a 1PW user for many years and have all my family & friends on it too thanks to my evangelical attitude about it.

    I'm struggling with a website too.

    www.service.transport.qld.gov.au/SBSExternal/application/CleanBookingDE.xhtml?dswid=-701 (Have to hit accept to get to the forms part)

    When accessed from my mac it gives me just two fields

    However, from my iPhone it gives me 3, plus a drop down menu.

    I can't get it to work on the iPhone at all.

    Any help would be greatly appreciated.

  • @Woody W., what version of 1Password are you using? The new filling/saving code in 1Password 7.1 will correctly fill the expected fields from a Login item saved on that page. It is one that has caused us problems in the past.

    @alinoz, when I view that page in my preferred browser I'm seeing three fields plus a dropdown as well so what I can't readily tell is what two fields you need to fill in your browser on the Mac. As a result the following could be a bit hit or miss.

    1. Download this 1PIF (1Password Interchange Format) file and save it to your Desktop.
    2. Drag the 1PIF file to the 1Password icon in the macOS dock to import into the current vault.
    3. Edit the newly imported Login item and click the Show Saved Form Details button (show web form details if 1Password 6 for Mac).
    4. Replace the placeholder values for the three fields with your real details and save.

    Now 1Password won't be able to correctly set the drop down menu because rather than use the pre-existing select element they're using various tricks to make a menu, seems like a lot of effort to avoid using something that all browsers understand but what can you do. Hopefully though you find that works on the iPhone based on my own testing and fills the correct fields with whatever you're seeing on the Mac.

  • @littlebobbytables I am using:

    1Password 7
    Version 7.1.1 (70101001)
    AgileBits Store

    I have tried chrome and safari on my mac. I have just recently updated from 1Password 6.

  • edited September 2018

    @Woody W., I had the same problem with the EFTPS page, same version of 1P. All fixed now.

    The "easy" way to fix it
    1) In 1P find your existing EFTPS entry, and hit edit
    2) Remove the website line
    3) Save
    4) Close browser
    5) Reopen browser
    6) Go to eftps login page, hit command-\ to make sure 1P doesn't have the login data loaded
    7) Fill form
    8) Hit login. 1P will ask you to save the entry. You're done.

    The nerd way to fix it:
    1) Edit your 1P entry for EFTPS
    2) View saved form details
    3) Go down to the entry for "Password", and click on the key
    4) Scroll down to select the blank spot in the pop-up menu below the key (you're switching the key to blank)
    5) In the "PIN" field line, on the right, in the same column, click, and choose the key icon.
    6) Save

  • brentybrenty

    Team Member

    Thanks, huffalumpy! Great summary. I suspect that will help "Woody W.", but we're here no matter what. :)

  • UGH! This week the OLD EFTPS setup works. So this week you can reverse the steps in my post above - switch PIN and Password for which one is the key.

  • brentybrenty

    Team Member

    Well that sounds maddening. Glad that works for you at least! :)

  • Hi, I had the same problem on a login form requesting my SIRET (a french company identifier), First Name, Last Name and Password.

    When saving the form from Safari, the mapping of the fields is good, but when filling in the form, only 2 fields are filled in.

    So I tried the @littlebobbytables solution and it worked. So, thank you for that.

    But why? The field mapping (using field ID) is exactly the same, whether I save the data from browser or creating them myself...

    Anyway, thank you for the solution that works :smile:

  • Hi @Blackyell,

    1Password doesn't expose everything and there is some data that is hidden. Except for very specific cases like here the hidden data isn't useful and so we limit visibility to what we think makes sense. That's why seemingly two identical looking items can differ though. If something I posted helped though I'm happy and should you come across any other problematic sites do let us know and we'll be happy to investigate and try and help.

  • Hi again,

    It's really frustrating. Like I said before, the @littlebobbytables solution was working... but only for a while.

    I'll take the same form as in my previous message (SIRET / First Name / Last Name / Password) which was working but no longer (but it's not the only one I get problems with).

    Now, only the Last Name and Password fields are OK. The SIRET field stay empty, and the First Name is filled with SIRET.

    Why ?? The form has not changed, my 1Password entry has not changed. The field name/id are still OK in 1Password...

    Really, I don't understand why there is simply not a match between the field name in 1P and the field name on the form.

    Again, it's really frustrating.

  • Hello @Blackyell,

    Is this a page that I could reach and a page where you would be happy with sharing the URL here in our public support forum? If the support forum isn't appropriate but you would be okay with sharing it via email we can do that. I want to see if I can reproduce and if we can learn what is happening but for that I will need to see the page.

    It is entirely possible this may not be a page I can reach at all which will complicate matters. I'll await to hear back from you to see what we're dealing with.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file