unlocking extension fails to unlock desktop? [Intentional due to security limitation]

1password4 - chrome - I hate that I have to often unlock twice - first in browser - then on desktop.

I can find a way to auto-unlock chrome from desktop app, but not the other way around.

Help!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited September 2018

    Hi @MordachaiWolf,

    Thanks for writing in.

    I've moved your post to our 1Password 4 for Windows forum. This is due to the way 1Password 4 is built, 1Password Helper is a separate process and in order to unlock each other, it has to send a key to the other process. For security reasons, we don't allow the Helper process to unlock the main 1Password process if it was not running before.

    Make sure 1Password is opened before you unlock 1Password Helper in your browser (or configure it to automatically run upon reboots) and also, you have the setting turned on to unlock 1Password extension:

    Go to the File Menu > Preferences > Browsers to check When unlocking the application, also unlock 1Password in the browser.

    1Password 7 doesn't have this limitation as we now use one process for both the main 1Password app and 1Password extensions.

  • Ah - I may have previously set 1p4 to autostart - that might be the "trick"

    And I noticed - my chrome never indicates that the extension is installed - same as on your screenshot. Normal?

  • Just double checked - 1p4 is set to autostart. Yet unlocking in the browser never seems to unlock the desktop (but the reverse works just fine).

  • brentybrenty

    Team Member

    And I noticed - my chrome never indicates that the extension is installed - same as on your screenshot. Normal?

    @MordachaiWolf: Could you please clarify what you're seeing? If it's simpler, take a screenshot of this. To include it in your reply, simply click the document button in the top of the comment field, and select the file you wish to share:


     
    Just be sure not to post anything sensitive, as this is a public forum. Thanks in advance!

    Just double checked - 1p4 is set to autostart. Yet unlocking in the browser never seems to unlock the desktop (but the reverse works just fine).

    @MordachaiWolf: Try this: open 1Password, open your browser, unlock 1Password in your browser. Are you seeing the main 1Password app unlocked now too?

  • Same as what you showed in your own screenshot:

    Notice how that the "Install Chrome Extension" button doesn't have a check box or any indication that it is installed?
    As compared in your own screenshot to the Mozilla Firefox immediately above that does have a green checkbox indicating that 1Password 4 does know that the extension is installed (in Firefox). (I'm assuming that this is normal - but I figured I'd ask)

    I opened 1Password 4 by clicking on the "lock icon" in my status bar, then I used the chrome extension to unlock - and YES - it unlocked the desktop as well.

    But if I don't click on the main app first - I leave it simply as "autostart" - then unlocking the browser does NOT unlock the desktop - which is unfortunate since I most often need a password in the browser, and only if there is an issue, I need to fire up the desktop app to do a search or something more complex - and I Have to unlock it a second time - often right in a row.

  • Okay - after testing that opening 1p4 worked (unlocking in chrome did unlock desktop after I opened desktop)

    I forced desktop to lock, closed it (but not the icon on the status bar, just the main window), and then I unlocked via chrome - and it unlocked both.

    So - I'm confused why it sometimes works, but not others.

    I wonder if something could be getting in the way when I first start up after a power-down? The icon is there but something isn't right?

    Or could my 2nd test be invalid because I'd already established a connection between chrome and the desktop through my previous attempt?

    Hmmm...

  • brentybrenty

    Team Member

    @MordachaiWolf: Hmm. The only screenshot I posted was the one illustrating how to attach an image here in the forum. Anyway, the main 1Password app cannot unlock with the browser if you don't have it running. That definitely works every time. You can even minimize it to the notification area. But it cannot unlock if it is not running. This is not something that has changed at all. The 1Password Helper (Agile1PAgent.exe) is a separate app which handles the browser integration. If only that is running, then 1Password will only unlock in the browser when you unlock 1Password in your browser. If you want the main 1Password app to unlock too, it must be running. Does that help?

  • Ah, sorry, it was MikeT who posted that screenshot (Sorry, I didn't notice that you two weren't the same responders! - d'oh!)

  • Thanks, brenty - I'll double check that the lock icon is visible in the notification area next time I try to do this to see if can figure out why it is failing.

    I appreciate the help - it narrows down what could be failing - or it could be my misunderstanding - but I'll figure that out going forward now that I know "the rules".

    Thanks

  • brentybrenty

    Team Member

    Ah no worries. That makes sense. I don't mind being mistaken for Mike. He's good people. :)

  • brentybrenty

    Team Member

    @MordachaiWolf: I think the key for you will be opening the main 1Password app (and minimizing it, if you want it out of the way). That's what I do. That will get you the behaviour you seem to be looking for, since then it can also unlock with the browser extension (Helper). :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file