Safari and 1Password 7.2.BETA-2 (70200002)

Safari Technology Preview (Release 65) and Safari (Version 12.0 14606.1.36.1.9) are installed in parallel on my iMac. I noticed this behavior which happens every time I try this:
1. I start Safari Technology Preview
2. I click on the 1Password Plugin Icon in Safari Technology Preview
3. not only the 1Password plugin gets displayed, the released version of Safari is launched and appears on screen
4. When I type something into the search field of the 1Password plugin and hit return, the resulting web site is opened in both versions of Safari and 1Password fills in the login information in both Safari versions.

When I start the released version of Safari and use the 1Password plugin, the Safari Technology Preview is not started. Both Safari and Safari Technology Preview have the same version of the 1Password plugin installed.
I am using Safari and Safari Technology Preview for quite some time and have also used 1Password beta versions a lot. I have seen this behavior only in the 7.2 Beta.

iMac Retina 5K, 27-inch, 2017, 4,2 GHz Intel Core i7, 64GB 2400 MHz DDR4, Radeon Pro 580 8192 MB
macOS 10.14 (18A389)
Safari 12.0 (14606.1.36.1.9)
Safari Technology Preview Release 65 (Safari 12.1, WebKit 14607.1.5.2)
1Password 7 Version 7.2.BETA-2 (70200002)
1Password Plugin 7.2.BETA-2 from Password 7


1Password Version: 7.2.BETA-2 (70200002)
Extension Version: 7.2.Beta-2 from 1Passoword 7
OS Version: 10.14 (18A389)
Sync Type: iCloud

Comments

  • rudyrudy

    Team Member

    @hoehenunterschied,

    In order to use the extension in Safari Tech Preview you have to set Safari Tech Preview as your default browser.

  • Is this specific for Safari Technology Preview? My default browser is Chrome Canary. Chrome, Safari, Safari Technology Preview and Firefox are also installed. None of the 1Password plugins in the other browsers show a similar behavior.

  • rudyrudy

    Team Member

    @hoehenunterschied,

    This is specific to additional Safaris (Safari Tech Preview and WebKit nightly).

    If your default browser isn't a Safari then you can only use the extension with Safari.
    If your default browser is Safari then the extension won't work in STP or the WebKit nightly
    if your default browser is Safari Tech Preview then the extension won't work in Safari or the WebKit nightly
    if your default browser is the WebKit nightly then the extension won't work in Safari or STP

    Chromes and Canaries and Foxes will all continue to work the way they have in the past.

  • neilioneilio Junior Member

    Is setting the default browser the only way to make this work? I use Choosy so I can work with multiple browsers for work.

  • rudyrudy

    Team Member

    @neilio,

    Unfortunately that's the only way to make non-default Safari work with the extension. This is a limitation of the API, we've filed enhancement requests to improve that situation but not in time for Safari 12.

  • Seeing the same behavior. @rudy, thanks for the explanation.

  • rudyrudy

    Team Member

    :+1:

  • Another thing to note is that with Safari as the default browser, the fill with mini actual does work into Safari Tech Preview, but Safari pops up. If you return to Safari Tech Preview, the form is filled.

  • rudyrudy

    Team Member

    @verdi1987,

    its very much less than ideal, but its what the Safari API provides for now.

  • @rudy, it's better than not filling at all!

  • rudyrudy

    Team Member

    @verdi1987,

    It would have been nice to fully support it directly, but yeah, something is better than nothing.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file