Mojave challenges

I just downloaded 1password, I'm on the family trial, and am really aggravated by it. Nothing works as is in the docs. Not sure what I'm doing wrong.

The below behaviors are identical in Safari or Chrome on Mojave

  • There's no 1p little icon in password or username fields.
  • The only password suggestion for creating an account I get is from Apple keychain, not 1password
  • If I take the keychain password 1password will at least prompt me to save that one.
  • If I go to login to a website, again, no option to fill in password from 1p -- just an option to fill in keychain password.

I've read some forum posts and it claims it will be fixed in 7.2 but I have that and it's still not working.

Again, this is the same with Chrome and Safari. They both show the extension is loaded, but it just doesn't work in either.


1Password Version: 7.2.1
Extension Version: 7.2.1
OS Version: OS X 10.4
Sync Type: Not Provided

Comments

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @weave! I'm sorry for the frustration. Let's take these things one-by-one:

    There's no 1p little icon in password or username fields.

    That's because you're using the 1Password for Mac app with our traditional extension, not 1Password X. 1Password X is our newest way of using 1Password which doesn't require you to have the 1Password native app installed, but it will only work with a 1password.com account, and only with Chrome or Firefox browser -- not in Safari at this time.

    The only password suggestion for creating an account I get is from Apple keychain, not 1password

    If you're using 1Password, you should turn off your various browsers’ built-in password manager(s). Otherwise, it can become confusing and even wind up with potential data loss.

    If I take the keychain password 1password will at least prompt me to save that one.

    Can you explain this one a little more, please? I'm not sure what you mean.

    If I go to login to a website, again, no option to fill in password from 1p -- just an option to fill in keychain password.

    Here are the instructions for saving, filling and changing your passwords in 1Password. You'll need to have the 1Password app installed, as well as the 1Password extension in your browser. If you don't yet have that in a given browser, you can visit https://1pw.ca/browser and install it.

    I'm not sure which forum posts you've read, but filling into web Login forms is not broken. If it's not working for you, it's likely the result of something being misconfigured -- and I'd be happy to help you sort it out. If you feel it's set up correctly, can you describe exactly what steps you're taking to fill items (relative to what's in the link I gave above)? Thanks. :)

  • OK I just tried it on a Windows box. Signed in there to the app -- no passwords whatsoever. Also same issue there with Chrome. No little icon in password fields, no suggestions given for passwords when registering. The extension pops up a little side window but no passwords I've already put in are there either.

  • LarsLars Junior Member

    Team Member

    @weave - right. There will not be a "little icon in password fields" unless you're using 1Password X. Please look in Chrome and tell me what specific version of 1Password extension you have there. What in the version number?

  • LarsLars Junior Member

    Team Member

    @weave - also, how have you entered these passwords, and into what app did you enter them?

  • Thanks for the replies.

    I signed up for the family plan, so I'm on the 30 day trial currently and have a 1p account.

    I turned off safari keychain autofill and the procedure on that page works but does not have the autofill stuff in the form box like i'm used to. Will take some getting used to.

    Is 1passwordx compatible with 1password vaults? A bit confusing to have two separate apps for the same platform.

    The chrome version is 4.7.3.90. I just downloaded it from the chrome store following a link on your site.

    Also, why aren't my passwords showing up in Windows? In the windows app however the tiny cloud icon up top says "no network connection to 1password is currently available" for some reason. I do have Internet on that computer that works!

  • I uninstalled whatever Chrome extension I had and followed your link above and installed that and now that is working as expected. Thanks. Now just have to figure out why not syncing to Windows!

  • I turned on debug console in Windows. I obfuscated the UUID and session strings just in case that's a security issue.

    But it definitely looks like the app isn't communicating for some reason.

    Should I move this over to another forum since this is a Windows issue now?

    WRN:4440 │ 1Password::api:1796 │ 2576911ms │ no accounts in database, resetting to the fresh start.
    INF:8052 │ 1Password::api:1790 │ 2589086ms │ Decoded QR_CODE bar code.
    WRN:11084 │ 1Password::api:1796 │ 2610096ms │ notifier connect failed for account 1, trying again in 60 seconds
    get_account_by_server_email: Query returned no rows
    WRN:11084 │ 1Password::api:1796 │ 2616874ms │ notifier connect failed for account 2, trying again in 60 seconds
    INF:4440 │ 1Password::api:1790 │ 2616874ms │ > authorize account #2; account uuid: wgoxnxpu5yeb47cj3dtt7p5yji; device uuid: mtfu7t4efbkp2fd6cg43ln5fjy; user uuid:
    sessionId: MTTXJ4FSLJFX5ONGLJMSDDD3Q4
    time: 858ms

    INF:8052 │ 1Password::api:1790 │ 2617543ms │ created app key data with 195623 iterations and expected decode time 606ms
    INF:4440 │ 1Password::api:1790 │ 2617795ms │ > sync
    account id: 2; type: ; session id: MTTXJ4FSLJFX5ONGLJMSDDD3Q4
    network unavailable or not ready
    time: 0ms

  • OK I see this comment over from Windows forum...

    It sounds like you installed 1Password X extension for Firefox, not 1Password for Windows, is that possible? 1Password X is a self-contained browser extension that can run on its own without the main 1Password program. That may explain why you don't see it in your programs list.

    So the 1passwordx on windows in chrome is working for me.

    So looks like I'm good except disappointed with safari lacking easy autofill. But looks like that's not your fault.

    Now on to try iOS devices. Thanks for the quick replies and all the help. Pretty impressive actually! :-)

  • LarsLars Junior Member

    Team Member

    @weave - thanks for the updates, glad to hear things appear to be working correctly for you! I was away for the weekend, but I'm here now, so if you run into any further difficulties, let me know! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file