Amazon issue

I am running Mac OS Version 7.1.2 and are having issues with auto fill on When I head over to and attempt to login, the autofill will complete my email address and then I am taken to the password page. The password does not autofill but instead copies the OTP code instead and does not log me in. Any reason why this isn't working?

1Password Version: 7.1.2
Extension Version:
OS Version: 10.13.6
Sync Type: Not Provided


  • Hi @jkav,

    There was a big change in how filling worked in 1Password 7.1 for Mac (7.2 for Windows). It was more a happy side-effect that the old filling logic filled the hidden password field rather than being a deliberate action on our part. The new filling logic is more strict about this sort of thing and so it will mean you need to instruct 1Password to fill each stage. You can use open-and-fill for the first stage that asks for the email address but you'll need to fill the current page once you reach the request for the password. On a Mac the keyboard shortcut ⌘\ will fill the current page (`ctrl + \' on Windows) or you can click the 1Password button in the browser toolbar to access 1Password mini and select the matching Login item.

    Once you're updated to 1Password 7.2 for Mac you'll find you can either paste the TOTP filed copied to the clipboard or you can use the ⌘\ keyboard shortcut to fill this page too. 1Password 7.2 will be made available to High Sierra users, we're rolling out this version a little more slowly than previous ones because 7.2 requires Safari 12 (just for the Safari users of course) and we want to give people time to have applied that update.

  • Hi @littlebobbytables

    I'm a little confused. 1PW used to always auto fill the username and password properly into the Amazon website and then copied the OTP to the clipboard (at which point I could copy paste). You make mention of updating to 1PW 7.2 and I just confirmed I am running the latest software version available. Interestingly enough, I am also experiencing this behavior when signing into as well.

  • brentybrenty

    Team Member

    @jkav: Maybe we're not on the same page here. What browser version are you using?

  • @brenty I am using Firefox version 62.0.2 (64-bit) latest version.

  • Hi @jkav,

    So Amazon and Google share a trait with their sign-in process, there's no real page load, they're just playing with CSS and whatnot in the background for a fake multi-stage process. The older logic was filling the obscured password field whilst the new logic is stricter about what it will fill. We didn't intentionally design the old filling code to pre-fill the password field on Amazon and Google, it was just a happy side-effect of some of the code that tried to deal with a subset of weird sites, typically financial institutes based on my own experiences.

    So it will mean instructing 1Password to fill twice for now. If you're seeing other behaviour, if 1Password isn't filling a page even after using ⌘\ please let me know in case I've misunderstood but I think it's this change in the filling logic that you're experiencing.

  • @littlebobbytables I think you're right. I updated to 7.2 this morning and still doing the same thing.

  • Hi @jkav,

    As I said earlier, I'm not sure what the future will bring but for now it will mean a second fill command to 1Password. My hope is while it might seem burdensome at the start, after a while you won't notice it as much.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file