Filling not working in Safari 12

This discussion was created from comments split from: 1Password not filling in passwords on certain sites.

Comments

  • I'm having the same problem. It shows the Fill button, but it doesn't populate.
    Using 1Password 7 v.7.1.2
    Safari v.12.0
    macOS High Sierra v.10.13.6

    I have tried to download 1password extension however, it says it's already installed. But, it doesn't appear anywhere in my Applications folder.

  • Hello @gedmond,

    I've split your query away from the others because we could be looking at very different causes and I don't want anybody to get confused with multiple conversations about potentially unrelated topics.

    The issue you're having, is it with certain sites or all? If it is specific sites can you let me know the URLs please and I shall take a look.

  • Hi @littlebobbytables,

    It’s with ALL sites.

    Thank you,
    Gina

  • brentybrenty

    Team Member

    @gedmond: Sorry for the confusion. For it to work with Safari 12, you'll need to update to 1Password 7.2.1 and reboot, as we're using Apple's Safari App Extension APIs now.

  • @brenty: It worked!!! Updating to 7.2.1 and rebooting fixed it. Thank you so much!!!

  • brentybrenty

    Team Member

    Hey, you're welcome! Thanks for letting me know! Just glad to hear all is well again. It sounds like you should be all set, but we're here if you need us. Cheers! :)

  • @brenty: Yes, VERY HAPPY it's working well! I'll be in touch if there's any other issues, but I'm hopeful there won't be any for now. Cheers to you as well!

  • brentybrenty

    Team Member

    Sounds good! :chuffed::+1:

  • Hi. I'm having the same problem on a brand new MacBook Pro. I'm using 7.1.2 and it's not working on any site. When I try to update, it tells me I'm using the latest version. Appreciate any help.

  • Discovered my MacBook didn't have software update turned on. Have now updated to Safari 12. Unfortunately, same result: Won't let me update 1Password beyond 7.1.2

  • Finally got it to work. After a reboot and another attempt, an Extensions window opened, and after a couple of attempts, I figured out that I needed to check the box next to "1Password." There were no other items in the window, so it took a while to understand that I had to click that one item.

  • brentybrenty

    Team Member

    Ah, glad to hear that you were able to enable the extension, and that the reboot helped. Safari updates used to always require that, but now that they don't, I still find that necessary usually to get everything working normally again. Cheers! :)

This discussion has been closed.