Knox Vault partition on an external drive won't mount?

I created a Knox vault as a 2.25TB partition on an external drive.
This partition will not stay mounted, that is, it mounts for about 2 seconds and then disappears.
The are two other partitions on the same external drive that mount fine and can be accessed with no problems.
I run Disk Utility, it sees the "Knox" partition
I run first-aid it comes back with no errors.
I load TechTool Pro 10 - it shows that the partition on the volume is fine.
(see details below)

If I grab an image, is it going to be the 2.25 TB or the 9.14GB ???
In other words, can I create a .dmg image on another drive and then try and mount it?


TechTool Pro 10:
Volume Information
Total Folders: 32

Total Files: 1,190

Volume Content Size: 9.14 GB

Catalog B-Tree Information
Depth: 2
Node Size: 8.19 KB

Leaf Record Count: 2,446

Maximum Key Size: 516

Used Nodes: 48

Free Nodes: 43,216

Extents B-Tree Information
Depth: 0
Node Size: 4.10 KB

Leaf Record Count: 0

Maximum Key Size: 10

Used Nodes: 1

Free Nodes: 4,095

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • More Info:

    Volume name : Knox Vault
    Volume type : Physical Volume
    BSD device node : disk4s3
    File system : Mac OS Extended (Journaled)
    Connection : USB
    Device tree path : IODeviceTree:/[email protected]/[email protected],7
    Writable : Yes
    Is case-sensitive : No
    File system UUID : 10B999A3-008D-392E-B19C-6BDA43E6562B
    Volume capacity : 2,250,000,007,168
    Owners enabled : No
    Is encrypted : No
    Can be verified : Yes
    Can be repaired : Yes
    Bootable : No
    Journaled : No
    Disk number : 4
    Partition number : 3
    Media name :
    Media type : Generic
    Ejectable : Yes
    Solid state : No
    S.M.A.R.T. status : Not Supported
    Parent disks : disk4

  • Results of running Disk Utility First Aid:

    Repairing file system.
    Volume is already unmounted.
    Performing fsck_hfs -fy -x /dev/rdisk4s3
    Checking Journaled HFS Plus volume.
    Checking extents overflow file.
    Checking catalog file.
    Checking multi-linked files.
    Checking catalog hierarchy.
    Checking extended attributes file.
    Checking volume bitmap.
    Checking volume information.
    The volume Knox Vault appears to be OK.
    File system check exit code is 0.
    Restoring the original state found as unmounted.
    Operation successful.

  • Andrew_AGAndrew_AG

    Team Member

    Knox no longer works properly with external drives on Macs running under macOS El Capitan or higher. We don't have a fix at this time, and I don't know if or when we will since further Knox development is not really happening at this time because our development focus has been more on 1Password than Knox recently with 1Password memberships taking centre stage (Knox is actually not even available for sale at this time since our developer focus is almost entirely on memberships right now, and it seemed unfair to continue selling it if it is not under development at the moment).

    In the meantime however, if you quit Knox you might be able to get OS X to mount the drive as a workaround. I am sorry for the inconvenience though.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file