Can't use TouchID when the lid is closed

TomWolskyTomWolsky
edited April 2018 in Mac Beta

This came up before in an earlier version. Not sure what this is trying to say:

Clearly the lid isn't closed. The MBP is not connected to an external monitor or something like that.


1Password Version: 7b5
Extension Version: Not Provided
OS Version: 10.13.4
Sync Type: iCloud

Comments

  • JacobJacob

    Team Member

    Hey @TomWolsky! It looks like one of my teammates noticed this last night as well and filed an issue for it. I'll add your report. :)

    ref: apple-392

  • I'm having this issue as well. Got the same message, but there's no external monitor attached.

  • rudyrudy

    Team Member

    @rbudish,

    had you just opened the lid?

  • A few minutes prior.

  • rudyrudy

    Team Member

    @rbudish

    and if you bring another app to the foreground and then bring the 1Password window back to the foreground?

  • Also have this problem. Mac was awake, nothing connected (even power) and wasn't asleep. This is a ridiculous message. Any progress on this since August? i'm using v7.1.2 (i'd show the build # but i can't copy that from the about screen, so you don't get it) on mac os 10.12.6 sierra.

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @sylsoft ,

    When the 1Password window is brought to the foreground, it queries macOS for the state of the lid. If macOS tells us its closed, then we disable TouchID.

    The next time this happens, can you try bringing another app to the foreground and then bring the 1Password window back to the foreground. Does the issue then go away?

    Thanks,
    Kevin

  • I've tried bringing another app forward then reselecting 1Password but the message remains the same about the lid being closed (despite the fact that the lid is open and no monitors or other devices are attached). I have a theory: is it possible that the incorrect message (lid closed) is being displayed when another message should be displayed (touchID disabled after 1 week)? Generally bringing the app back and forward clears the lid closed message, as this thread indicated. However, I noticed today that the behavior did not work today. But I was traveling without my computer for a week+, so 1Password should prompt me to enter a password today, but not because the lid is closed. So my guess is that that the wrong message was being displayed, but the overall behavior of disabling touchID is correct -- I needed to enter a password either way.

  • MrRooniMrRooni

    Team Member

    Hi there @rbudish. That’s a good thought that we can look into it, thanks.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file