All PDF Attachments Corrupted in 1Password for Families

All my pdf attachments are showing up as corrupted with the following message: The file couldn’t be opened because it isn’t in the correct format. I am currently running 1Password 7 for Families Version 7.2.2 (70202007) on a 2016 MacBook Pro under Mac OSX Mojave. These pdf files were originally attached in an earlier single user version of 1Password.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @Diamondback26: Thanks for getting in touch. I'm sorry to hear that you're having trouble with some files. Just to make sure we're on the same page, talking about the same thing, 1Password Families, like all 1Password.com accounts, do no use attachments. Any files uploaded to your account will be Documents items. Is that what you're referring to?

    Also, could you please clarify what you're seeing? Take a screenshot of the error message. To include it in your reply, simply click the document button in the top of the comment field, and select the file you wish to share:


     
    Just be sure not to post anything sensitive, as this is a public forum.

    I suspect that when you moved to the account and copied your data over, those files were already corrupt on disk, as you would have had trouble uploading them otherwise. If you view them in your original standalone/local vault, as attachments, are they viewable there? Thanks in advance!

  • edited December 2018

    Brenty, yes I am referring to Documents. My error as I used the Add New File option in a 1Password item to upload a file into the app and automatically assumed them to be attachments. When I click on the document file saved with the item I get a generic pdf icon and a window with a quick look/ open with option. When I select my default pdf editor (PDFPen Pro) I get the error message that is attached as requested. I do not have a local standalone vault anymore as I assume all vaults were converted when I moved from version 6.7 to version 7 for families under the subscription model.

  • brentybrenty

    Team Member
    edited December 2018

    @Diamondback26: Thanks for getting back to me. That isn't a default PDF icon. It's for PDFPen. That error appears to be coming from PDFPen as well. Can you try opening it in a different app, like Preview or Safari? Also see if you can download/view it from the 1Password.com web interface, as that could bypass any weirdness with viewing on your Mac. Please let me know.

    Even if you are not currently using a standalone/local vault, 1Password ill not have deleted it from your hard drive, or from any sync service you were using before. So it will still be there if you didn't delete it yourself. If you enable local vaults in 1Password Preferences > Advanced, you can double-click your old vault in Finder to open it and see if you can open any of these files there.

    I suspect you will not be able to though, and that something was corrupted on disk a while back and you're just now noticing. Do you have incremental backups, like Time Machine?

  • Brenty, The default pdf icon I was referring to is the one attached to this comment. The screenshot I attached to my previous comment was the one I get after trying quick look/open with option and using PDFPen Pro. I have tried opening the document with various other pdf editors with no luck. I also tried the web interface with the same result. As you say I fear that the original documents were corrupted. I do have backups saved on a backup disk so I will reattach them to 1Password from there. It seems strange though that they were all corrupted.

  • brentybrenty

    Team Member

    @Diamondback26: That is an icon specific to PDFPen, so that's being displayed solely on the basis of you having PDFs associated with that app on your Mac. Most people see the Preview icon since that is the macOS default -- and doesn't cost money. :) That's why I was suggesting opening it in Preview or Safari, or 1Password.com, to rule out an issue with PDFPen. It does sound like it's an issue with the actual data. That's happened to me, where I had damaged files for years that I never noticed, and I just kept migrating the damaged data over and over again -- Garbage In Garbage Out as they say. :(

    However, if you have backups going back a fair amount of time, there may be hope that you can find one where those files are intact. Again, I'd start with your pre-1Password.com local vault just to be sure, since that would be relatively up-to-date. But from there we've got two (sort of) avenues to explore.

    First, 1Password itself periodically saves backup archives:

    https://support.1password.com/backups/

    Those can go back a year or more, and should still be there unless you removed them. So that's where I'd start. You can restore from one of those, check the files, and if they're valid, save them to disk so you can upload them to your account.

    The second, perhaps less reliable option, is to use Time Machine or a similar backup archive that can go back even farther. For example, while you probably can go back to 1Password data up to at least a year ago just with what 1Password has saved on your Mac right now, if you have, say, a backup of your entire Mac from one year ago, there should also be 1Password backup archives going back a year further from that, and so on.

    If you need help finding 1Password's files, generate a diagnostic report and I'll be happy to take a look:

    https://support.1password.com/diagnostics/

    Please send it to [email protected] and add the following Support ID (including the square brackets) to the subject of your diagnostics email before sending:

    [#ZJW-25615-553]

    If you’re reading this and you are not Diamondback26, this Support ID is for Diamondback26 only. Please ask us for your own if you also need help.

    This will link it to our current conversation. Once we see it we should be able to better assist you. Thanks in advance!

    ref: ZJW-25615-553

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file